Showing results for 
Search instead for 
Did you mean: 

Drivers & Software


Mint 19.1/Ubuntu 18.04 ryzen 3 2200u vega 3 drivers

Hello! Recently bought HP laptop 15-db0004ur (apu ryzen 3 2200u with vega 3 graphics). It had win10 os preinstalled, then i replace it with mint 19 (ubuntu 18.04 based os), and i'm not able to find (even in official HP site) a proper driver for this apu graphics module. What i already done to try solve this problem (and actually, all of these didn't help me):

* Updated kernel to 4.18.0-13 and Mesa to 19.0.0-devel

* Tried to install amdgpu from AMD Radeon site Radeon™ Software for Linux® 18.30 Release Notes | AMD (this driver already deistalled at the moment and currently i use 4.18 & mesa), 18.20/18.30/18.40 driver i tried with 4.15 kernel

xrandr --listproviders output:

Providers: number : 1

Provider 0: id: 0x54 cap: 0x9, Source Output, Sink Offload crtcs: 3 outputs: 2 associated providers: 0 name:Unknown AMD Radeon GPU @ pci:0000:04:00.0

glxinfo | grep 'OpenGL version' output:

OpenGL version string: 4.5 (Compatibility Profile) Mesa 19.0.0-devel - padoka PPA

DRI_PRIME=0 glxinfo | grep "OpenGL renderer" output:

OpenGL renderer string: AMD RAVEN (DRM 3.26.0, 4.18.0-13-generic, LLVM 8.0.0)

DRI_PRIME=1 glxinfo | grep "OpenGL renderer" output:

OpenGL renderer string: AMD RAVEN (DRM 3.26.0, 4.18.0-13-generic, LLVM 8.0.0)

inxi -Fxz output:


  Host: kirill-HP-Laptop-15-db0xxx Kernel: 4.18.0-13-generic x86_64 bits: 64

  compiler: gcc v: 7.3.0 Desktop: Cinnamon 4.0.9

  Distro: Linux Mint 19.1 Tessa base: Ubuntu 18.04 bionic


  Type: Laptop System: HP product: HP Laptop 15-db0xxx

  v: Type1ProductConfigId serial: <filter>

  Mobo: HP model: 84AE v: 86.19 serial: <filter> UEFI: Insyde v: F.03

  date: 04/26/2018


  ID-1: BAT1 charge: 40.3 Wh condition: 42.3/42.7 Wh (99%)

  model: Hewlett-Packard PABAS0241231 status: Unknown


  Topology: Dual Core model: AMD Ryzen 3 2200U with Radeon Vega Mobile Gfx

  bits: 64 type: MT MCP arch: Zen L2 cache: 1024 KiB

  flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm

  bogomips: 19961

  Speed: 1421 MHz min/max: 1600/2500 MHz Core speeds (MHz): 1: 1622 2: 1667

  3: 1588 4: 1458


  Device-1: AMD Raven Ridge [Radeon Vega Series / Radeon Vega Mobile Series]

  vendor: Hewlett-Packard driver: amdgpu v: kernel bus ID: 04:00.0

  Display: x11 server: X.Org 1.19.6 driver: amdgpu resolution: 1366x768~60Hz

  OpenGL: renderer: AMD RAVEN (DRM 3.26.0 4.18.0-13-generic LLVM 8.0.0)

  v: 4.5 Mesa 19.0.0-devel - padoka PPA direct render: Yes


  Device-1: AMD Raven Ridge HDMI/DP Audio vendor: Hewlett-Packard

  driver: snd_hda_intel v: kernel bus ID: 04:00.1

  Device-2: AMD vendor: Hewlett-Packard driver: N/A bus ID: 04:00.5

  Device-3: AMD Family 17h HD Audio vendor: Hewlett-Packard

  driver: snd_hda_intel v: kernel bus ID: 04:00.6

  Sound Server: ALSA v: k4.18.0-13-generic


  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet

  vendor: Hewlett-Packard driver: r8169 v: 2.3LK-NAPI port: 3000

  bus ID: 02:00.0

  IF: eno1 state: down mac: <filter>

  Device-2: Realtek RTL8723DE 802.11b/g/n PCIe Adapter

  vendor: Hewlett-Packard driver: rtl8723de v: v5.1.1.8_21285.20171026

  port: 2000 bus ID: 03:00.0

  IF: wlo1 state: up mac: <filter>

  IF-ID-1: br-40bf9d7c79a9 state: down mac: <filter>

  IF-ID-2: br-5456dbdc6137 state: down mac: <filter>

  IF-ID-3: br-ccc2448c9285 state: down mac: <filter>

  IF-ID-4: br-ed6a12f43190 state: down mac: <filter>

  IF-ID-5: docker0 state: up speed: N/A duplex: N/A mac: <filter>

  IF-ID-6: veth5df58ad state: up speed: 10000 Mbps duplex: full

  mac: <filter>


  Local Storage: total: 465.76 GiB used: 124.15 GiB (26.7%)

  ID-1: /dev/sda vendor: Western Digital model: WD5000LPCX-60VHAT0

  size: 465.76 GiB


  ID-1: / size: 456.96 GiB used: 124.14 GiB (27.2%) fs: ext4 dev: /dev/sda2


  System Temperatures: cpu: 52.9 C mobo: 20.0 C gpu: amdgpu temp: 52 C

  Fan Speeds (RPM): N/A


  Processes: 258 Uptime: 58m Memory: 15.39 GiB used: 3.91 GiB (25.4%)

  Init: systemd runlevel: 5 Compilers: gcc: 7.3.0 Shell: bash v: 4.4.19

  inxi: 3.0.27

P.S. Sorry for possible duplication, tried to find discussions with my problem an find nothing.

5 Replies
Journeyman III

I have exactly the same problem with R3 3200u in an Acer Aspire 5 laptop.

Journeyman III

I have exactly the same problem with Ryzen 3 2200u in an HP 255 g7 laptop.

Такая же ситуация ноут HP с amd 2200u, драйверов нет никаких: ни свободных ни проприетарных от AMD. Как будто все лишь 10windows пользуются

Adept I

the same for

AMD Ryzen 5 3500U with Radeon Vega Mobile Gfx × 8

Journeyman III

I have the Acer Aspire 5 R3 3200u vega 3 on linux mint I upgraded to kernel 5.0 and everything worked fine. however PopOs was perfect from the start.

Adept I

i try 5.2.7 &  5.3.1 both of them dosn`t log in i`ll try 5 ten years ago i use gnome and xfce since long time is just mate so i`ll try back to gnome

Thank you