Showing results for 
Search instead for 
Did you mean: 

Drivers & Software


Microsoft Teams Still Crashing PC, Vega 64

Microsoft Teams still abruptly crashes and reboots my system when using camera and/or screen sharing. I've installed the latest drivers for my graphics card (Vega 64), which notes that this issue is fixed, however a quick look at the event log is still showing 'RadeonSettings' as the culprit. Before I updated drivers yesterday, Teams would occasionally BSOD my system but now it just hard crashes and reboots without warning; much more frequently.

I am going to try another clean uninstall of the graphics software but would like to know if anyone is having similar issues. See specs below, thank you!

Ryzen 3700X

Vega 64 liquid cooled (20.4.2 drivers)

Windows 10 Pro 1909

Latest ver. of MS Teams

16 Replies
Adept I

I'm having the same issue but using a R5 3600X, X470 Prime Pro & RX 5700 flashed to XT with a slight OC to 2000 MHz & 1800MHz on the memory, not sure it matters but it never crashes in anything else.

Using 20.4.2 drivers as well and used DDU to erase the previous installations.

Yes, it is important to note that my system is otherwise 99.9% reliable as well. The issue definitely boils down to something in the graphics drivers; Teams doesn't work very well without HW acceleration enabled.

Actually, I've tried both with and without HW Acceleration on Microsoft Teams Settings and it still crashes, tried a clean W10, new drivers, everything fresh, no help. I'm stuck with this, I've also tried several other previous drivers, for some reason MT doesn't want to work without crashing.

I did write up a decent report in regards to this on the W10 feedback hub, so hopefully it at least gets put in there system for future updates. It might end up being some kind of bug in the software's code, that only causes issues on some AMD cards. It's hard to say what exactly is causing the problem but it may not be something that AMD can address with new drivers--especially if they've already tried.


Everyone here make sure to let AMD know it is still an issue:


So, AMD support actually got back to me on this and this is what they told me: disable HW acceleration in Teams and turn off Radeon features such as image sharpening and enhanced sync. If that doesn't work, then use DDU to clean uninstall and then clean install the 20.4.2 drivers.

Granted, I did test a Teams meeting since wiping and re-installing the graphics drivers with DDU, and I haven't encountered the issue again, but I'm not super confident that it's actually fixed. All my settings are set back to default, so I'll just have to see Teams crashes again.

My teams with HW acceleration off gets weird as hell, don't know why, I've tried that before installing the W10 update, no luck.

For some strange reason, it stopped crashing for me after I installed the latest optional Windows 10 Update (KB4550945), I'm really still wondering how is this possible, maybe it was a W10 issue after all, not sure.

I've had this update installed since April 23rd, and it didn't seem to affect my Teams software crashing. Hard to say with this one... but I've had a number of meetings work fine today--so I'm holding out that perhaps something with the drivers, upon being reset or turned off, may have fixed it. Still, nothing is confirmed on my end.


I am currently experimenting with the likeliness of a conflict with Discord and Teams; there being a possible tie to the crashing that some of us have been experiencing. Discord, like Teams, can be used for collaboration and although I can't say for sure, it may have been running in the background while I was using Teams when I ran into the crashing problem.

Will update this post if I find anything conclusive. 


My system crashed again this morning, definitely the same scenario with MS Teams running. I did notice that while I was monitoring the card, the temperature sensor became unresponsive once or twice shortly before the system restarted itself--which tells me that it's the driver. Will update AMD support with my findings.

Discord was also not running when the system crashed this time, so I think I can rule that out as a possible culprit. 


as an FYI, AMD had this under the Fixed Issues for the driver released yesterday..

Radeon RX Vega series graphics products may experience an application crash with Microsoft® Teams when hardware acceleration is enabled.

Journeyman III

I'm still experiencing this issue with the latest drivers 20.Q2.1 for the Radeon Pro W5500.

I'm not sure if the fix was already provide to the Pro series drivers.

I already went to different cycles of reinstalling my entire OS and drivers, without any result. My installation is really the bare minimum. So no games installed. Just the OS and Office + Teams.

Curious if there are still other people who still have this issue after the latest driver updates.

Journeyman III

I'm having the same problem with my newly bought Radeon RX 5700 XT.

Teams and Skype keep crashing, when I start screensharing (or sometimes also half a minute later), however it doesn't happen with all of my colleges.

One college works fine, no crash at all, one another crashes immediately after I start screensharing.

But in the end, the timing when it crashs seems to be kind of random.

And yes, I already disabled hardware acceleration for Microsoft Teams.

This is really annoying, especially for work.

Side note: Zoom seems to work without problems.

Adept III

Do not use Adrenalin Gaming Drivers on Vega architecture based cards because that software has a lot of stability problems (BSOD, blackscreens, freezings) and other lot's of stuff with background software using GPU acceleration...
Use Radeon Pro/Enterprise drivers for fixing any Vega stability problem. That was the only way me and other users found, looking for a solution after all these years, it seems AMD is unable to develop some stable drivers for a 3 years old GPU. 

Download and install driver for Radeon WX 9100 if you have a Vega 64.
or Download and install driver for Radeon WX 8200 if you have a Vega 56. 

Adept II

Try this:

  • From the list of apps, select Admin.
  • From the menu select Settings > Services & add-ins.
  • Find Microsoft Teams and then enable External Apps.
  • Set Allow external app in Microsoft Teams to On.
    Restart Microsoft Teams and then try searching for Dynamics 365 again in the Microsoft Teams app store.




Which list of apps? Can you be more detailed please?