cancel
Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

nightwa1ker
Adept II

Massive stuttering with "Enhanced Sync" On.

When i am enabling "Enhanced Sync" in radeon settings, all my games starting stuttering and microfreezing as hell.

I really love this technology, but i can not use it.

Driver version 19.1.1

CPU - i5 3570k

DDR3 - 16gb 2200 ( 11-12-12-30)

GPU - sapphire radeon rx480 8GB nitro+ OC

MOBO - asrock z77 pro3

Windows 10 LTSB 2016 v1607

Can somebody help me please?

14 Replies
nightwa1ker
Adept II

UP

0 Likes
nightwa1ker
Adept II

UP

0 Likes
yahaway
Adept II

Most forums really don't like it when OPs 'bump' their own posts...I 'learned' that from the msi forums many years ago. anywho, have you tried enabling/disabling vsync ingame? try both ways and see which, if any, makes the difference. also, turn off chill and framerate limiter for now and see if there is any difference. it just sounds like one of your settings isn't playing well with the others. hell, i'd start by placing all my radeon settings back to default and go from there. also make sure your monitor's freesync (if you have that) is enabled.

my monitor is not freesync. tried vsync off and on, didn't work. Settings of deafult, chill is disable. Sorry for upvoting my own post.

0 Likes
kingfish
Volunteer Moderator

This stuttering only happens when enhanced sync is enabled? Are you enabling it in the game profile or the Global settings? Did you enable 'AMD User Experience program' when you installed the drivers? If so, disable it in Wattman 'Preferences'. Do you have the Power Limit set to +50 in Wattman?

0 Likes

Tired both(in game profile-global settings), amd user experience program is off, power limit set to +50

0 Likes
shadow07
Adept III

OP Did you perform a clean install?

0 Likes

Yes, tried differents versions of drivers with DDU

0 Likes
waltc
Miniboss

No problems with Enhanced Sync here, glad to say--works as advertised through all driver versions thus far--and I don't have a freesync monitor.  Only thing I can think of immediately is to say that enhanced sync won't function properly or at all if you have vsync in-game switched on.  Vsync in-game should be set to "off" when you use the Enhanced Sync setting in the drivers.  Used that way--works splendidly for me--provides 90%  of the fps of vsync off  with < 10% of the screen tearing usually caused by vsync off.  A tip I would suggest as well is to test each game you play with vsync-off set in the drivers instead of Enhanced Sync, and if your monitor is up to it you may see little or no screen tearing with vsync off--which is true for several games I own.  But if you see screen tearing--then that is the time to use Enhanced Sync.  I now have an RX-590/480 8GB multi-gpu ("Crossfire" before D3d12) system, connected to an AoC U3277PWQU 3840x2160 monitor.  For 2018 I owned the RX-480 8GB by itself but the Enhanced Sync worked properly then, as well.

0 Likes
kingfish
Volunteer Moderator

Glad you brought this up..I have been mis-understanding the function of enhanced sync. I was told early on that Enhanced sync worked with v sync and to enabled vert sync in the game. Sure enough I got a solid 60fps overall...with sections of the game occasionally running 80-135fps. So I thought it was working. Now I tried it with vsync off in the game and enhanced sync on in Wattman. My fps average went to 81fps with occasional 100-110fps. 

Still don't know why I saw higher fps (occasionally--not average) with it enabled in the game..but I'm glad I read this.

0 Likes
kingfish
Volunteer Moderator

Enhanced sync enabled:

Older game..MW2/Max settings/FRAPS

Vsync Enabled:

Max  261

Average  177.77

Min   95

Vsync disabled:

Max 379

Average  162

Min  74

0 Likes
noodles59
Miniboss

Yep, as above, Vsync (on) / Enhanced Sync don't like each other - keep vsync off

0 Likes
nightwa1ker
Adept II

nothing helped Maybe it's something in windows 10? xbox dvr is off, superfetch is off, every overlay-steam,uplay,discord,relive are disabled too

0 Likes
myrequiredusername
Journeyman III

I was experiencing stuttering in Disco Elysium until I found the solution: Fullscreen Stuttering :: Disco Elysium General Discussions 

Apparently, it's a common knowledge that Enhanced Sync leads to stuttering.

My specs:

144Hz monitor (Samsung space + freesync driver)

RX 590 Nitro+

Game was running in fullscreen, around 60fps.

OS: both win7 and win10 are prone to this problem

Stuttering, before I disabled enhanced sync, was happening every ~4 seconds.

0 Likes