cancel
Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Highlighted
Adept II
Adept II

Manual Fan Curve Zero RPM Fix

Hello!

In the new 19.2.3 Update AMD claims to have fixed the zero RPM bug when using the manual fan curve.

And of course, its a lie once again. However, by being a little lucky i found a fix for it, without any third party sortware

but with just the AMD adrenaline.

In 19.2.3 as soon you from automatic to manual the zero rpm option greys out.

If you have any curve settings saved from 19.2.2 when one was able to save a manual fan curve with

zero rpm enabled that problem can be solved.

1) Reset the global wattman settings (not to factory default, just in the global wattman fan settings).

2) Load the 19.2.2 profile with manual curve with "zrpm on". It will still show as off, but do not worry.

3) !!! Load the same file again. It will magicaly turn to on.

Save this file, and from now on you will have full control over your speeds with the zero rpm (that actually works)

ability. Should it bug out on PC restart, just load it twice again.

Hope that helps!       

(still not sure how is that possible that AMD cant figure zrpm out for 8 months)

(If you do not have any saved 19.2.2 manual curve settings with zrpm on, i am attaching my 19.2.2 profile)

18 Replies
Highlighted
Big Boss
Big Boss

Re: Manual Fan Curve Zero RPM Fix

If you are saying you can get the fan to return to not running with a manual curve enabled that's awesome. If so please send all of what you figured out to AMD maybe they will do something with it. LOL NOT A CHANCE. But maybe!

Online Service Request | AMD 

Also could you repeat what you figured out on this in the original thread on this topic?

https://community.amd.com/thread/235617 

0 Kudos
Highlighted
Adept I
Adept I

Re: Manual Fan Curve Zero RPM Fix

Then basically you're asking people to open their profile XML, find
<FEATURE ID="18" Enabled="False">
and change it to
<FEATURE ID="18" Enabled="True">

I wish something like that would work for the fan curve settings... A minimum of 35% speed and maximum 65 degrees is a ridiculous limitation for a Vega56

Highlighted
Challenger
Challenger

Re: Manual Fan Curve Zero RPM Fix

Very interesting, I was looking for an XML based solution and it's hidden in the profile posted. I was looking for an old profile, but not having a one to one reference was becoming tedious.

Apparently, this is entirely possible pokester‌, as I'm able to fool around with my manual curves while having zero rpm enabled - I had to edit my profile manually.

This is what that portion of my xml file looks like: Apparently, zero rpm is feature id 18. At least for Vega 64, and by some deduction Vega 56.

<FEATURE ID="18" Enabled="True">
   <STATES>
      <STATE ID="0" Enabled="True" Value="0"/>
   </STATES>
</FEATURE>

I have tested this edit on my Vega 64 profile. It matters if state id 0 is true or false. It needs to be true. I assume 0 rpm is the same feature id for Vega 64 and 56 - as it appears the OP has a V56 profile.

I tested this manual edit, and the fan curves I set conform to the curve, and the zero rpm feature works both cutting on and off - although the card doesn't immediately turn the fans off at 50C, it does turn them on at that temperature and off at a later time....as in off after a certain amount of time - it seems to vary depending on the speed of the fans when passing the thermal threshold - I don't actually know why it does this, it just does, and then the fans go off.

I don't consider this a win per se, as that cut on temperature is the same temperature the original zero rpm mode was set at to cut the fans on while in cool and quiet mode. I'm still stuck with a 42% arbitrary floor on my manual curves despite the fans cutting on and off at 38.4% speed. I guess the fans are 3750 rpm fans on my model. they cut on at ~1440 rpm.

Vega 64, Asus ROG Strix 8GB zero rpm mode working after manual xml edit.

2019.02.27-20.12.huh.jpg

Highlighted
Big Boss
Big Boss

Re: Manual Fan Curve Zero RPM Fix

Well that was my issue every since they went to this new fan temp curve. On manual my fans never cut off. The run forever. Stay at a minimum about 35%. 

At least my new RTX 2060 works as it should. The fan rarely kicks on even in games. When it does I only know it because I see the monitor. I don't here it as it is not as loud as my CPU fan. Unlike the jet engine my RX 580 is. 

0 Kudos
Highlighted
Adept II
Adept II

Re: Manual Fan Curve Zero RPM Fix

I was a long time nvidia users, the amd xlm is a little new to me

Can you tell me what the trick behind loading the profile two times to get zrpm to "on" is?

If i load it once it is still off. And yeah, for me the idling fans temperature is pretty much random

as well, everywhere in between 49c-42c. I am just happy that i do no longer need to rely on 3rd

party soft anymore. (RX590)

Highlighted
Challenger
Challenger

Re: Manual Fan Curve Zero RPM Fix

johnsmith7171‌, 

The XML edit is a workaround for turning zero rpm mode back on for people using existing custom setting and an having exported or saved an existing settings profile set. It's more like a trick of load 4 times, but I digress on the fiddliness of the process. I didn't really intend to fix wonky fan curves, just turn the fan back on or off according to zero rpm mode.

You can reset all your setting, then enter custom settings - save a profile file as some named file. This is an XML file that can be edited by notepad++ or just notepad.

Having a custom fan curve saved in a profile with 19.2.3 and wanting zero rpm was broken.

Exporting the profile will let you save a custom file - which you can open and edit.

Once you make that export and manual edit, you can then reload/apply the profile in Radeon setting and zero rpm mode should be enabled, even if you make changes to fan curves and overwrite the xml profile afterwards Zero rpm should be enabled and should persist across the overwrite.You can make all your adjustments to the fan curves, voltages, overclocks, and so on using Radeon setting before or after in other words.

I'm not suggesting that fan curves are reasonable or even being implemented correctly. The fan curve subject is subjective to begin with. And I'm no fan of current implementation. 

What is working is zero rpm mode after the xml edit. This is back on again after editing that feature id.  - apparently theres a UI bug or something causing it to be ignored when writing out profiles. Zero rpm button interactivity is outright disabled in 19.2.3 Radeon settings UI.

I've tried custom numbers in the xml for the fan curves, there's a section for it in the profile xml data and it doesn't fix my arbitrary floor % issues. Even numbers are temperatures, odd numbers are fan load %. The first two entries I have not figured out or are not intuitive to begin with. You and I are bisically on the same page bors‌.

Highlighted
Miniboss
Miniboss

Re: Manual Fan Curve Zero RPM Fix

Apparently easy to fix but not until AMD finally fixes it!

Who got the stoopid idea to disable Zero RPM in the first place? (custom fan curve)

Highlighted
Challenger
Challenger

Re: Manual Fan Curve Zero RPM Fix

johnsmith7171 If you have a vega 56 or 64, Save your existing profile or skip to the next paragraph if you already have a custom profile saved somewhere - if you don't have one, set the slider to custom ( and make adjustments from there ) then save that. Be warned, however, that your fan curve may be hopelessly inaccurate out of the box or when switching from one custom profile to another, so go ahead and set a fan curve and apply it. Then, save that profile...

Open whatever_profile_you_saved.xml in notepad, and set these values for feature ID 18 like seen below - Just change "False" to "True" for both.

<FEATURE ID="18" Enabled="True">
  <STATES>
    <STATE ID="0" Enabled="True" Value="0"/>
  </STATES>
</FEATURE>

Then save the file and exit the text editor. Open Radeon Settings -> Gaming -> Global Settings -> Global Wattman, with slider set to custom, hit the load profile button and load the whatever_profile_you_saved.xml ...zero rpm should now be enabled. And your profile should have been applied when the file loads. Then, turn right back around and save your profile again, and either overwrite the old profile, or name a new one for future purposes.

Considering that I've had to re-load my profile every third reboot or so, I'ts safe to say that you'll probably want to create a new profile file. You'll probably want to check to make sure your global wattman settings have not reverted back to 'Balanced' mode - because mine do that all the freaking time - I don't know about you or your system. Radeon settings stopped telling me when it reverted back to Balanced mode because of driver crash, or whatever.

0 Kudos
Highlighted
Challenger
Challenger

Re: Manual Fan Curve Zero RPM Fix

Don't really know, but I guess they assumed that anyone wanting a custom fan curve always wanted the fan to be on - which isn't the case - the majority of users, and myself, would want the balanced mode when not gaming, and a gaming mode when gaming with custom fan curves.

I think they assume that the workaround is to use a wattman profile for each game in question. And that might work, to a certain degree. But this is cumbersome.

0 Kudos