cancel
Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

hurricane28
Journeyman III

Low IOPS with Samsung 950 Pro 256 GB.

Hi all,

I have a weird thing going with my system and i can't seem to solve it.

The problem is this, i get low IOPS with my Samsung 950 Pro M.2 SSD, around 75K random read and 65K random write. This is way lower than advertised and i see no reason why my FX-8350 CPU cannot handle more IOPS.

When i had the Samsung 840 EVO 250 GB i got the IOPS its rated for. I also get reset to device raidport1 was issued, rather strange because i am not running any raid configurations.

I have the latest chipset installed and i tried to install older ones with no luck and i get the same annoying warning message.

My Components are:

FX-8350 @4.8 GHz

Corsair H100i with Noctua NF F-12 Industrial PPC 3000tpm fans.

16 GB G.Skill TridentX 2400 MHz

Gigabyte 990FX Gaming G1

Cooler Master V850

MSI 970 Gaming 4G.

Windows 10 Pro.

I checked if Windows is corrupt but its all running fine, no problems and no corruptions. My overclock is also very stable and temps never reach higher as 60c under full load.

The SSD is also running very cool and is nowhere near throttling point.

Any help would be much obliged,

Thanks in advanced,

Hurricane28.

0 Likes
13 Replies

Re: Low IOPS with Samsung 950 Pro 256 GB.

It's not a problem, AMD's SATA controller has been lacking since it was created. That being said, it's still more than fast enough for anything you throw at it.

0 Likes
hurricane28
Journeyman III

Re: Low IOPS with Samsung 950 Pro 256 GB.

Yeah i know all that but still its weird that i could get above 100K IOPS with the Samsung 840 EVO and with my M.2 i can't even get 80K most of the time..

BTW, why are you benching your ram instead of the SSD? Rapid mode is just a marketing thing, never seen better performance with it enabled to be honest.

0 Likes

Re: Low IOPS with Samsung 950 Pro 256 GB.

Sorry, didn't read that as the new 950 series, thought it said 850. It's not a processor issue.

Event 129, amd_sata Reset to device, \Device\RaidPort0, was issued.

That thread from the Microsoft forums says that reverting to MSAHCI from AMDAHCI solves the RAID error, and could solve your low IOPS problem.

0 Likes
hurricane28
Journeyman III

Re: Low IOPS with Samsung 950 Pro 256 GB.

that's quite alright dude.

I was revering to your benchmark score though, you are using rapid mode which is basically your ram speed what you are benching, just saying man.

I tried the results posted on the Microsoft website but this didn't help. The warning still persist, i tried the Microsoft driver and 2 AMD sata drivers but no luck and no change in IOPS..

I can only think of that my SSD is not working properly, if it was an driver issue it should get better with another driver right?

On another note, its kinda strange that i get reset to device raidport1 is issued and the source is Nvme.. riddle me that lol

0 Likes
hurricane28
Journeyman III

Re: Low IOPS with Samsung 950 Pro 256 GB.

Yesterday when i was tinkering with the settings and drivers, i discovered that when i install the Microsoft Nvme driver i no longer see the warning message anymore but i get terrible read and write speeds so i reverted back to Samsung Nvme driver. This indicates that there is an issue with the Samsung Nvme driver and AMD sata drivers. 

0 Likes

Re: Low IOPS with Samsung 950 Pro 256 GB.

0 Likes
hurricane28
Journeyman III

Re: Low IOPS with Samsung 950 Pro 256 GB.

Wow man, that's very low. Actually too low if you ask me.

This is what i get with different SSD's:

840 EVO 250gb.png

samsung 850 pro.png

Low IOPS 950 Pro.png

As you can see with the 840 EVO SSD i did get the advertised speeds but with later models not.

I think they try to gimp AMD again... they do it with so many things its not funny anymore.

That being said, I still have the Reset to device, \Device\RaidPort1, was issued problem which is related to the AMD chipset driver that is in conflict with Samsung driver it seems because with the standard Microsoft driver i do not get that error anymore.

0 Likes

Re: Low IOPS with Samsung 950 Pro 256 GB.

Granted the numbers may be slightly slower since it is my OS drive, but you wouldn't think it'd compare the way it does to my OCZ Vector or even against my years old refurbished OCZ Vertex 3 with near 6100 power on hours. Still, it's plenty fast, and the price was low at $420 a little over a year ago (no nevermind it's $100 cheaper now, that's tech for you).

0 Likes
hurricane28
Journeyman III

Re: Low IOPS with Samsung 950 Pro 256 GB.

All my SSD's are my OS drives, it doesn't change the fact that we get less performance than we pay for and should have. Do you understand what i am trying to say?

Our hardware is more than capable of handling those speeds but the crappy Samsung software or SSD's gimp our AMD system. I provided proof with my 840 EVO.

Is your CPU stock? And do you also have the FX 8350 like me or do you have a different CPU? When i was running stock i got the same low IOPS and i noticed that in real live performance. The higher i clock my CPU the higher IOPS i get which is strange because with the 840 EVO i could get much higher IOPS than what i get with my Nvme drive.. Its not that its slow or anything by any means but i would like to get what i pay for you know.

This is what i got:

950 pro iops.png

0 Likes