cancel
Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Michi92456
Adept I

Lost HDMI an DP Audio after Update Adrenalin 2020 Edition 20.12.1

Hi, my Audio Divers doesnt work after Update to Adrenalin 2020 Edition 20.12.1 or Adrenalin 2020 Edition 20.11.2.

The "High Definition Audio Device" disappeard from my Devicemanager.

I have a AMD Asus Dual RX580 O8G GPU.

How do i reinstall my Drivers and get the Monitor sounds via HDMI and DP back to work?

 

Thanks!

 

0 Likes
2 Solutions
RPX100
Challenger

Hey there. You should try a clean install of the driver with AMD Cleanup Utility 

This is recommended each time you install another driver!

 

--- [ CPU: Ryzen 7 3800XT | GPU: ASRock RX 5700XT Challenger Pro 8GB | driver: 22.1.2 ]
--- [ MB: MSI B550-A Pro AGESA 1.2.0.5 | RAM: 2x 16GB 3600-CL16 | chipset: 3.10.08.506 ]

View solution in original post

0 Likes

Thanks! i try this and report back.

View solution in original post

0 Likes
5 Replies
RPX100
Challenger

Hey there. You should try a clean install of the driver with AMD Cleanup Utility 

This is recommended each time you install another driver!

 

--- [ CPU: Ryzen 7 3800XT | GPU: ASRock RX 5700XT Challenger Pro 8GB | driver: 22.1.2 ]
--- [ MB: MSI B550-A Pro AGESA 1.2.0.5 | RAM: 2x 16GB 3600-CL16 | chipset: 3.10.08.506 ]
0 Likes

Thanks! i try this and report back.

0 Likes

It worked, i uninstall all drivers with the tool and installed the newest version again. Sound ist back now an everything works as before.

Hey there. I am glad that it worked. Awesome!

Just remember to use the same method for all future driver updates, too.
It is recommended to clean older driver files each time you upgrade to a newer one.

cheers

 

--- [ CPU: Ryzen 7 3800XT | GPU: ASRock RX 5700XT Challenger Pro 8GB | driver: 22.1.2 ]
--- [ MB: MSI B550-A Pro AGESA 1.2.0.5 | RAM: 2x 16GB 3600-CL16 | chipset: 3.10.08.506 ]
0 Likes

I have the same issue, RX580 4GB no audio from HDMI. I tried the clean tool and after using it installed 20.11.2 to be safe instead of the latest version. Issue is still the same. There's no HDMI audio option in sound settings and it doesn't show up in device manager as an option either. I've tried half a dozen other recommendations I found across the internet, none have worked for me. From what I've seen looking around this seems to be a pretty common problem, anyone have another solution?

I'm using an MSI RX580 GamingX 4G / i5 6500/ 16GB of Geil DDR4. This is a living room media machine, it's hooked up to a TV. I've had it running like this for several years except that I just replaced an RX460 with the RX580 that used to be in my gamming rig until a recent upgrade, parts trickle down. Any help would be greatly appreciated, thanks!

0 Likes