Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Journeyman III

Looking for help! Clean Install of 5700xt drivers makes screen go black and crash my computer infinity on reboot!


When trying to install gpu drivers utilizing amd's utility, My computer black screens half way through install and then upon reboot my computer goes into a cycle of restarting and crashing to a bsod screen code "critical process died". This is only stopped by the windows repair utlity. Once I uninstall the driver or recover my computer to the point before install my computer boots up great again.

What I know (-Update):

This happens with both 19.9.2 and 19.12.1 install options (Update, AMD just released there 19.12.2 update which looks like there big effort  and now instead of getting the critical proccess died, I am recieving Video TDR Failure which I recieved with the external disks but this time it didnt break my computer it just removed gpu device. Weird!)

The gpu acts normal when no driver is installed (Fans are running, rgb lights are on, ect)

- I have now recieved a different message after bsod reboot on an america megatrends screen "VGA card is not supported by UEFI driver. CSM (Compatability support module) settings have been changed for further adjustment"

What I have tried (-Updated):

Updated Bios version 1405

Tried before and after windows install; version 1909 (Before windows update was the worse, required full clean install to reboot would not let me but safe mode or recover)

Tried it before and after audio,lan,wifi driver installs

Tried it before and after chipset driver updated (Version 19.10.22 with and without version bug fix)

uninstalled Chrome

uninstalled microsoft basic display adapter 

- Override monitor to 1080 60 hz during driver install

- using external disk drive, try and install with manufacturer disks (I found this worse than before but it did provide me with new information instead of the crash message, I recieved stop code  " Video TDR Failure what failed: atikmpag.sys")

Things I am going to try (Updated):

Change power supply slot

Remove vertical mount and extender

Does anyone else have any ideas or has anyone found a solution to this? 

My Rig:

Asus Tuf X570 - Plus (Wifi)

AMD Radeon 3800x 

16gb x G.Skill Trident Neo 3600mhz 16L (2x8)

Crucial p1 1tb

Red Devil 5700 xt (Vertically mounted using Coolmaster kit)

Rosewell 750 watt Gold+

Lian Li  p011-dynamic case


Drivers & SoftwareGraphics

1 Reply
Journeyman III

Hey there, did something fix it for you? At first I thought the GPU was a dud, but another rx 5700xt has the same issue. 

The board I use is the x470-f with a ryzen 2600.

Funnily enough my old sapphire nitro vega 64 is working correctly.

My main suspect right now is the motherboard.