Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Journeyman III

Logitech Options (LogiOptionsMgr.exe) crashes on a new platform (R3900X/X470)!

Couple of days ago I assembled my new PC. Here are the specs:
Asus Crosshair VII Hero WIFI (bios 2501)
AMD Ryzen 3900X
Corsair Vengeance RGB PRO 32GB 3000MHz CL15
Samsung SSD NVMe 970PRO 512GB
Windows 10 1903
and some other components.
I haven't installed/tested everything yet, but so far everything is working great - except for one app: Logitech Options. I tried all versions available on Logitech website, but with the same result. What's the problem? When Windows starts or if I run the app manually, Logitech Options runs 3 processes: Logi Overlay, LogiOptions.exe and LogiOptionsMgr.exe. At this point everything works as it should, but once I start running applications - let it be Edge or whatever - LogiOptionsMgr.exe disappears from the processes list (there's no information that it crashed or anything). Mouse and keyboard are still working, but once LogiOptionsMgr.exe closes, I lose possibility to use customized buttons (I have Mx Master S2 mouse + Craft keyboard and I do a lot of video editing, so this feature is very important to me!). In event viewer there's an error:
Faulting application name: LogiOptionsMgr.exe, version:, time stamp: 0x5d1858e5
Faulting module name: LogiOptionsMgr.exe, version:, time stamp: 0x5d1858e5
Exception code: 0xc0000409
Fault offset: 0x000000000067ee90
Faulting process id: 0x128c
Faulting application start time: 0x01d5513156b00a32
Faulting application path: C:\ProgramData\Logishrd\LogiOptions\Software\Current\LogiOptionsMgr.exe
Faulting module path: C:\ProgramData\Logishrd\LogiOptions\Software\Current\LogiOptionsMgr.exe
Report Id: 31e18188-71fd-450a-abc1-0abc119b7982
Faulting package full name:
Faulting package-relative application ID:
I have no idea what's causing LogiOptionsMgr.exe to close\crash, but I've already tested some things:
1. It happens with every version of Logitech Options.
2. I thought that maybe some driver/app was causing it to act like that, so I installed a fresh copy of Windows 10 1903 and then, before installing any driver/app, I ran the newest version of Logitech Options - LogiOptionsMgr.exe crashed/disappeard from the processes list right after I ran some other application.
3. I suspected that perhaps the newest version (1903) of Windows 10 is causing these problems, so I did a fresh install of 1803 version which worked with no issues on my old PC (Asus P8Z77-V, Intel 3770K, Corsair Vengeance 16GB). That didn't help either. LogiOptionsMgr.exe was crashing again.
4. Since I switched from Intel to AMD and this issue started happening, I think the problem lies in the platform (AMD/Asus). In my workplace I use the PC with Ryzen 2700X cpu and the newest version of Windows 10 on which the Logitech Options software is working flawlessly. That means it must be the new platform that's causing problems (maybe the bios, maybe some driver; perhaps Win10 doesn't work with it properly yet - I don't know).
Since I'm not sure where I should address this issue, I'm reporting it to AMD, Asus, Microsoft and Logitech.
In the meantime, does anyone have any ideas on how to fix it?
3 Replies
Journeyman III

I have the same error and found this thread.

I have ASUS ROG Strix X570-E Gaming  (BIOS 1005)
AMD Ryzen 3700X
 Corsair Vengeance RGB PRO DDR4 32GB  3200 MHz
Samsung SSD NVMe 970 Evo plus 512GB
Windows 10 1903

Latest fault:
Application: LogiOverlay.exe
Framework Version: v4.0.30319
Description: The process was terminated due to an unhandled exception.
Exception Info: exception code c0000005, exception address 00007FF935DDC79F

Programnavn med feil: LogiOverlay.exe, versjon:, tidsangivelse: 0x5d185912
Modulnavn med feil: amdxn64.dll, versjon:, tidsangivelse: 0x5d602532
Unntakskode: 0xc0000005
Feilforskyvning: 0x000000000005c79f
Feil prosess-ID: 0x2f24
Feil starttid for program: 0x01d560e9cfdf1138
Feil programbane: C:\ProgramData\Logishrd\LogiOptions\Software\Current\LogiOverlay.exe
Feil modulbane: C:\WINDOWS\System32\DriverStore\FileRepository\u0346134.inf_amd64_fba44214d7b32915\B346122\amdxn64.dll
Rapport-ID: 7ef57ee9-cc5e-4341-b37a-7c9f1f24615d
Fullstendig navn på feilpakke:
Relativ program-ID for feilpakke:

Adept I

I have it too!

Windows10 1909 + 1950x + 5700xt


Same issue here with 3900x, Strix570-E, and Sapphire 5700xt pulse.