Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Journeyman III

'Loadlibrary failed with error 87: The parameter is incorrect.' on trying to open AMD app after installing Adrenelin (both .12 and .13)

Hey everyone,

So I've scoured the forums and haven't found any solution that's addressing this in a way that fixes my issue yet. I'm getting this when I try to open the AMD app itself (and on launch, when it tries to initilise it, as well as any attempt to open it afterward).

There is no 'Rollback' option in my Device Manager settings, and I've clean uninstalled both 18.12.2 and 18.12.3 to try to solve this with fresh reinstalls of each.

My current setup is:

AMD Graphics Card: Radeon RX 560.

Setup: Desktop.

OS: Windows 10 64bit Home.

Driver version installed: AMD Adreneline 18.12.2 (currently, have tried .13 too).

Display Devices:

1x Inta Audio 23.6 Inch Widescreen TFT Monitor connected via HDMI (primary, 1920x1080) (23.6 Inch Widescreen TFT Monitor - DVI  - Inta Audio from Inta Audio UK )

1x Inta Audio 23.6 Inch Widescreen TFT Monitor connected via HDMI (secondary, 1920x1080)

Motherboard: ASUS Z370-A II Prime

CPU: INTEL i7 8700K Coffee Lake, Six Core, 3.7GHz

Power Supply: Inta Audio 600W Quiet Power Supply (600w Quiet Power Supply - Inta Audio from Inta Audio UK )

RAM: 2x 8GB Vengeance LPX DDR4 2666MHZ

Any help would be greatly appreciated, as this is driving me insane.


1 Reply
Journeyman III

To clarify:

I've tried the atig6pxx.dll rename to the .bak extension.

This error seems to just be shutting me out of opening the AMD Radeon Settings mainly right now, that seems to be the root of the problem.