Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Adept I

Linux failure to boot on Ryzen 5 3600

I am upgrading a Centos 7.5 system from an AMD Phenom II 1055T processor that has run trouble free for years to one on a MSI B550 Motherboard with a Ryzen 5 3600 processor and I cannot get it to boot.

In desperation I have tried live versions of Centos 7.5, Ubuntu 16, 18 and 20.04, Clear, and Debian and I have tried both the 7C91vA0 and 7C91vA43 BIOSes, all with the same or similar result, they get a part screen into the boot and fail. Often the screen indicates "unknown chipset", "ACPI error", or "unknown chip XID 641".

I have researched the Net and found that Centos does not support Ryzen and only the vague statement that Ubuntu runs on any amd64, which I understand the Ryzen 5 3600 to be.

I am prepared to change MB or CPU or both but not until I have some assurance that it will work.  I think that Centos or RedHat support only a few high end AMD processors and hence am prepared to switch to Ubuntu 20.04, but I don't want to commit until I know that the cpu / MB will work.

Any suggestions would be much appreciated and thanks.


8 Replies
Adept II

I've had no problems at all installing, and running Ubuntu 20.04 on my AMD Ryzen 3700X on a Gigabyte X570 Aorus Pro.


Thank You!  Very much appreciated, the first positive response that I

have had.  I had really understood that the x86_64 was a "standard". 

Since the early '80s I have successfully built my own systems until

now.  I run both Ubuntu and Centos with VMWare virtuals systems and am

reluctant to give up on the Centos but now I will be checking into and

try to understand all the variables.

Do you have any idea what the OS is sensitive to and that is different

in your configuration?




I have now reviewed most of what is available on the Net and as far as I

can see the 3800X is a big brother to the 3600, more cores and higher

frequency, but the same AMD64 / EMT64T 64 bit technology.

Could the MB implementation make the difference?  Any ideas?




I have now managed to boot Ubuntu 20.04 by using the setting

"acpi=off".  This suggests a BIOS incompatibility with Ubuntu.

BUT the result seems to be that it runs on a single CPU core.  I get the

UEFI BIOS but no performance.

More testing to be done!

Thanks for any help,



I just tried to install the following on Ryzen 2700x with Asus Crosshair Hero VII (Wifi).


Neither will boot from Live USB or install.
I also have an RX5700XT on the system so that Navi 10 GPU might be a problem as well...


I've never even considered problems with AMD processors. I know the kernel supports AMD processors, so when I'd updated to an Ryzen 7 3700X on a Gigabyte X570 Aorus Pro, running a Vega 64, I just installed Ubuntu 2.04, and didn't expect issues. And, (luckily?) I didn't see any.

Well, acpi=off means you're shutting down any, and all power features. I've found out that this may indicate a BIOS problem. I've also found an interesting page describing a very similar issue at ask ubuntu. Maybe this will help?

I am extremely pleased to report that my system upgrade consisting of:

Ryzen 5 3600

MSI B550 Tommahawk

XPG  GAMMIX D10 DDR4 memory

Nvidia Geforce GTX 1650 display processor

is up and running reliably on Centos 7.8 (Linux

3.10.0-1127.19.1.el7.x86_64).  It also runs fine with Ubuntu 20.04.

What is required is to insert "idle=loop" into the grub configuration

line "linux16" before booting and afterwards into the regular

/boot/grub2/grub.cfg file.  This let the system run with all CPUs active

(the system sees 12) all the time which uses more power and raises the

CPU temperature a bit.  BUT it works!

Thanks for your support,


Correction: "idle=poll"



Carl E. Køhn