Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Adept II

LibreOffice fails to start with AMDGPU-PRO 17.50 installed

Ubuntu 16.04.3, AMDGPU-PRO 17.50, kernel 4.13.0-32-generic.
LibreOffice just fails to start, no meaningful messages in terminal.
With 'radeon' driver (xserver-xorg-video-radeon-hwe-16.04) it starts OK.
GPU HD Radeon 7850 (Pitcairn) 2GB.

5 Replies
Adept I

If you have OpenGL acceleration enabled in LibreOffice's settings it would be a miracle for it to work at all, let alone on a closed GPU driver. If not, then it is a problem. However, I would suggest to avoid closed GPU drivers at all costs, especially for older models such as yours. The support for those is nonexistent and even the best level of their maintenance is no higher than "all the crutches and snots for it not to hang OS's kernel in 24 hours of idle uptime" for any operating system, not just Linux.


WTF? I'm not interested in upgrading hardware for now. And it is THEY who abandoned 'fglrx' in new versions of OS.


I don't think he is saying that you have to buy a new card. I gathered he was telling you to "a" make sure opengl was off in libre office. Then "b" there are often times 2 flavors of distro drivers Closed Made By Chipmaker and Open Supported By Community. If you have the option use the open drivers they often have way better long term support. Don't know if either will fix your issue, but worth a shot.

Then you know full well that expecting something from "fglrx", "Big-Dick-Gangsta Professional Crimson Byte-Cruncher 3000 on Cocaine", or whatever "THEY" would like to call it these days, is foolish. And don't worry, most likely it will equally not work on any hardware and under any OS. So, just use open drivers and be glad that they works almost perfectly on pre-Vega hardware, short of OpenCL 2.x.

'radeon' driver lack of OpenCL. So failing of AMDGPU-PRO IS a discrimination of GNU/Linux users/customers.
OpenGL in 'LibreOffice' is turned off by default, but 'Hardware acceleration' in 'View' section is turned on. And I don't think I have to bother with this kind of settings at all.