Showing results for 
Search instead for 
Did you mean: 

Drivers & Software


Latest driver 21.3.1 locked my monitor to 640x480

GPU: ASUS TUF Gaming Radeon RX 6900 XT OC
Mobo: Asus ROG Crosshair VIII Hero
CPU: Ryzen 9 3950X
Memory: 16GB @3200MHz
Monitors: Left main: 27" 2560x1440 secondary right 24" 1920x1080

Radeon Adrenalin  ver. 21.3.1 locked my left hand monitor (2560x1440) to 640x480 and it is impoosible to change the resolution.
My right hand monitor with 1920x1080 works.

My first attempt to install ver. 21.3.1 over powered the my left hand monitor with almost everything so there was not possible to even se anything on the monitor, it went bonkers. The right monitor however worked as befofre.

I had to revert to ver. 21.2.3 and then everythings is ok.

There are some seriuos trouble with the latest driver 21.3.1
Stay away from this update and I think AMD should revoke this from their website.

Best regard from Sweden.

3 Solutions

hope they can fix it, new hdmi 2.1 still ongoing

View solution in original post


Also with hdmi, the aorus FI27Q gives 10 bit color option at only 60HZ.

View solution in original post


solve the issue for my on FI27Q


downgrade frimware F03

use amdcleanuputility 


then install new driver


can used DP 2k on 165Hz hope another can fix it to....

View solution in original post

203 Replies

hope this can be the real one solution~ hope they can update new firmware...

It looks like F05 firmware is a crap. I also found another problem with this firmware - when I got it installed in Windows monitor settings I got only 60, 120 and 165Hz options, with F03 installed I got 60, 120, 144 and 165Hz options.

Adept II


It seems that people in this thread are using Gigabyte Aorus FI27Q monitor and possible connected via Displayport.

I don't know if there is a monitor issue or a Displayport issue on the GPU with this driver together with this monitor?
My second monitor a Philips 240V5QDSB-00 24" 1920x1080 connected via DVI > Displayport works no problem.

Perhaps one should try to connect the Aorus FI27Q via HDMI instead.
I have one HDMI port on my ASUS TUF Gaming Radeon RX 6900 XT OC and one HDMI cable that came with the monitor unused.
That's about the only thing I haven't tested.

Best regards from Sweden



Thanks for this workaround, but when You want to use 165Hz DP is a must, HDMI is limited to 144Hz. I don't want to use lower setting when I choose and paid for monitor with higher one only because of broken/glitched drivers.


It doesn't work, I tried it with HDMI, result was the same.


Hi, I have rx 5700 XT and Aorus FI27Q and of course i have the same problem since adrenaline 21.3.1 , but in my case hdmi working ok, problem is only in DP. 

Hope they can fix DP for next update...


Important notice: when one does a Windows installation or a Windows repair it will automatically install the latest WHQL graphics driver from Windows database (21.3.1 right now) and then of course the screen resolution will be locked to 640x480 during the whole Windows installation and afterwards.
I just tried and it was almost impossible to see and install Windows.

Ok. A workaround for this that I tested:
1. Connect the HDMI cable and then do the Windows installation or a Windows repair.
No problem now with screen resolution.
After all Windows updates and restart, manually Windows update again with restart and again and restart...

2. Revert to older working Adrenalin s/w for me it is 21.2.3

3. Shut off the computer, unplug the HDMI cable from the graphics card and plug in the Displayport cable.
Start the computer.

4. Right click on desktop > display settings > Advanced display settings > make sure that you also have the proper settings 165Hz for Displayport (144hz for HDMI) , otherwise it will be using max 60Hz in all games and apps...

5. Let the HDMI cable also be connected to the monitor and let hang loose at the other end (not connected to the graphics card) if You need it, until AMD has a solution for this.

Best regards from Sweden

Ps. This was just for testing Windows installation because I was suspicios if Windows installation will work and recognize 2560x1440 on Aorus F127Q connected via Displayport  - it did not because above notice.
Yeah I'm using Acronis True image for backup and restore, so I just restored my whole thing back to how it was before.


One more disturbing thing with 21.3.1 WHQL or the newer 21.3.2 Optional (I have tried them both) even if You get it to work with HDMI:

The screen can sometimes go complete bonkers, all kinds of splatter colors, like a crazy fireworks or just a white snowstorm.
I have been seeing this a couple of times - but never with 21.2.3 or earlier versions.
Of course it is impossible do do any thing when this happens, but in my case after a moment the screen went back to normal again.
I noticed this in my second attempt to install this driver as I described in my first post in this thread.

So again, this driver are not good at all for Aorus F127Q or maybe Gigabyte need to address this with a new monitor firmware?
Current ver. F05


Uppdate for me as well, tried the newest drivers they still failed (locked my screen to 640 x 480 and my refresh rate to 60Hz).  I am also using dual Aorus F127Q monitors.


Ihave the same problem with the same monitor ( Gigabyte Aorus Fi27Q 165hz F05)

i bought Xfx Merc 319 6800 XT and installed the latest recommended driver. Then my monitor resoulution stucked at 640*480. I have tried almost everthing but i couldnt fix the problem.

when i installed the previous driver 20.11.2, everthing works fine! its not related to our monitor. its exactly happening because of the driver.

I have sent several bug reports, hope it will be fixed soon.


Yesterday, I was very happy to finally receive a brand new card in today's market!  However when I tried to install my 6700XT I got the same problem. I spend more than 3 hours trying to fix it before finding this thread  

I also have Gigabyte Aorus FI27Q and the same issues with DP. I already figured out the HDMI workaround.  I can't revert to  version  20.11.2 because 6700XT is not supported yet. The  21.3.2 has the same problem.

Hope this issue is fixed soon. 


For the record, I just submitted a bug report to Microsoft, summarizing this issue. Let´´´ s see what they have to say.

I wrote to amd last week and they send me about clean install and instalation process ussing DDU utility.

I have aorus FI27Q RX 5700 XT Ryzen 3800

"I'm disappointed but not suprised".


Dear Rafał ,

Your service request : SR #{ticketno:[8201079993]} has been reviewed and updated.

Response and Service Request History:

Thank you for the email.  

I request you to give a try by performing clean installation of latest 21.3.2 driver for windows 10 OS by using the DDU utility and check the issue status.

To be on the safer side, I request you to please create System Restore point before performing any troubleshooting steps.

  •          Step 1 – Please use DDU Utility (Display Driver Uninstaller) by launching it in Safe mode and uninstall the previous driver. It will help you completely uninstall AMD graphics card drivers and packages from your system, without leaving leftovers behind.
  •          Step 2 – then restart your computer again and enter into the normal windows mode.
  •          Step 3 – Again restart the computer and then install drivers by clicking this below link. Please disconnect the network connection and disable antivirus before running the installer file. Radeon™ Software Adrenalin 2020 Edition 21.3.2 Release Notes | AMD

Please get back for further assistance

Thanks for contacting AMD.

is it work?


of course that no.....


I have Aorus FI27Q RX 5700 XT Ryzen 3800

GPU: Powercolor red devil rx6700xt

CPU: Ryzen 3700x

Mobo: Gigabyte X570 Aorus Master

Monitor: Gigaybte Aorus FI27Q

the same screen, video card rx 6700xt. I have the same trouble. And the only solution I found is hdmi

Yeah but using HDMI as I also found for a wo´workaround , but not quite. Even hdmi is not working as expected and it is not the best option.
HDMI can only support 144Hz and the Display port to 165Hz for the Aorus F127Q .

And when using HDMI I also had to change Windows text appearance, It went horrible to read text from any website or PDF/ MS Word-documents etc:
Start > just type Clear > in the list run Adjust clear type

Strange it differ from hdmi to displayport, but I can live with that (one time setting)  as long a new working driver that address this crazy thing about locked to 640x480 on the Aorus F127Q  monitor.

hope they can fix it, new hdmi 2.1 still ongoing

Also with hdmi, the aorus FI27Q gives 10 bit color option at only 60HZ.


I'm having the same issue FI27Q Monitor 6800XT Driver 20-11-2 onwards and the monitor is getting stuck at 640x480.


just downgrade the firmware~ it's "the only solution for now" to your display....

I flashed the Monitor with F03 Firmware

Everything is fine. But next day i get 640 x 480 again

Bad Solution: Using HDMI


I flashed the Monitor with F03 Firmware also and its still stuck at 640x480 when using any drivers newer then 21.2.3

Really Frustrating.


Another psudo solution to a problem that will never be addressed is to use CRU (Custom Resolution Utility). First install the  old amd driver that works and within CRU export the settings. Then install the newest amd driver and import the settings to CRU. There some issues with this but it will have to do until we move on to better hardware.


DDU or use amdcleanuputility first your driver, then install new driver~
that need clean your driver~ so the firmware can recognize it~ then you can test your DP cable~ like my solution the post before~

I already set the monitors firmware to F3, I've used amdcleanuputility to remove the old driver , Installed the new driver , tried two different display port drivers and I'm still stuck at 640x480. I'm a little confused I mean because I've picked a particular brand and model of monitor, this now means I cant use the latest drivers on a graphics card I've paid over a £1000 for? Who's the issue with Gigabyte or AMD or both?


hm.. your problem seems unique to me.. already update your OSDSideKick for aorus monitor?? maybe install the older one still compatible with display cable~ then update the latest driver, maybe i use RX 5700 XT it's compatible~ i don't know if the solution not compatible with RX 6000 Series...

Actually iam waiting for the next Firmware

Until there is a new Firmware, i use an HDMI Cable and 60hz ...




I've rolled back to Firmware F3, Display Port cable Adrenaline driver 21.2.3 and everything seems to work okay I just cant use any newer drivers for the time being till AMD fix there drivers.

I would like to bump is post as its still not been solved any driver newer then 21.2.3 is not working with my Aorus FI27Q I've rolled back the monitor drivers to F3 which are the only ones available I've used driver removal software to completely rid of system of any drivers before attempting to install any new drivers. Each time the same thing as soon as the new driver gets installed it locks my monitor to  640x480 . From there i've got to remove any previous drivers and go back to 21.2.3 . I'm looking for fixes not work arounds if you get me. Cheers


install new OSD SideKick then new driver~ try it~ update your OS...

Did you try it and it worked or you're just letting us try it first?

I have firmware F02 and can't install any driver above 21.2.3.

Not sure who's fault this is, but I'm really considering the option of returning the monitor if possible.


The fact that it worked with older drivers on that the monitor points to amd. However it’s hard to place the blame but something has changed within the driver that’s causing this problems ideally amd/gigabyte would work together and resolove the issue so we can use the monitor with newer drivers .

No fix in the notes of the newer driver either. They don't even acknowledge the issue. Look at nVidia forums, people had the same issue with the same monitor and it got hotfixed within seven days. Written in patch notes and all.

Yeah would be nice for AMD to actually respond and sort this out having bought one of there cards kind wish I had stuck with an NVidia card now.


hope you find a way for the solution.... maybe ask Gigabyte for new Firmware~ i think Amd not really care or they don't have team for fixing on "the driver" as fast like Green one~


They better fix this soon or I will return my hardware. This is starting to really piss me off.




Reported the Issue to Gigabyte this is all i've got back do far. Provided the information they requested.

Dear ..................

In order to duplicate the issue, please provide the information as below:

1. What is the AMD driver you tried?
2. Did you try to use AMD driver version 21.2.3?
3. Please inform us the graphics card model.
4. Which port you used? HDMI? DisplayPort?

Feel free to contact us again anytime if you have any feedback or need any support from us.