Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Adept I

kernel error, black screen, with two latest updates of adrenalin (23.7.1) on 5700XT and 5800x3D

Hello i wanted to share some experience with a 5700xt (sapphire ) and Ryzen 5800x3D, motherboard Gigabyte elite x570

My PSU is a recent cooler master 750w gold and worked fine to day

I experienced really bad issues with the two latest AMD adrenalin updates. Kernel error 41. The gpu just randomly stop working, black screen, the rest of the system work, forcing a hard reboot. That can happen on windows with no stress charge and ingame. I tried several game from very light (like 2d games) to heavy like Read Dead Redemption 2. That doesn't affect the issue.


I did anything to investigate, really :

- remove and change ram with other i had in stock

-  test psu multiple time with different processor

- try undervolt ryzen

-  try different latency for ram

- inspec and test on different SSd

- tried to change FAN setting (multiple trying) on video card

- tried on 7 several bios version ( yes im that type of guy)


Only working solution (to now) : use a tool to remove adrenalin drivers, then reinstall a previous version.

I don t know what s going on with the latest update and if im the only one but i would be very thankfull if you could investigate on that kind of problem.




14 Replies
Adept I

I've been having the same issues recently, until today game minimizes randomly and sometimes shows no visual just a black screen with sounds, and then with this update I was hoping this problem would go away but it got worse and game crashes after a few minutes, ggs..

~Cheers for the second time..

This is an ongoing problem and I don’t see them ever fixing it.  I never see them admit that it’s a known problem with their cards.  

Adept I

thanks for your answers, i forgot one thing if it can help : it seems the "performance mode" on windows power mode is not well supported. Way less crash when "normal mode" is running, don t ask me why


Kernel error 41 is due to a power related issue. I had the exact same totally random error with my RX 7900 XTX as I think it was doing some power spiking for just a very, very small amount of time (millisecs) that my 1300w PSU could not handle.  However, v23.7.1 seems to have fixed it for me - go figure.

Your 750w PSU should be more than adequate so I would recommend that you remove all overclocks/undervolting to both your cpu and gpu and put the power plan back to balanced and run stock for a few days to see if the issue still occurs. If not, start putting your overclocks back in ONE at a time to see which one breaks it.

Adept I

Hello ! thank you, but i never overclocked my graphic card



Glad I'm not running a AMD card as my main GPU

Asus ZenBook UX407IQ, Ryzen 5 4500u with Radeon graphics, Nvidia mx350, 8gb LPDDR4X ram, Samsung 970 Evo Plus 500gb SSD, Win11 home
Adept I

Hello, i came back with a solution/fix (to now) for those who read and could be interested. This is not a perfect solution as it has counterpart. So:


- go to your windows pane, then go to "system" and "advanced". You can also write in your search bar "advanced system" . Then you go to "hardware" and the second option "device settings". You change "Yes" to "No" and save.

- then, uninstall all your AMD drivers with the cleanup utility

- then, you go to amd website, you chose the driver of your card and let it autodetect


It s not perfect as in my case and i don t know why, that install "amd adrenalin pro", the blue version BUT the driver seems stable and are from April 2023 which is fine for me. LEt me know if it helped you


unfortunately i was wrong, all these stuff didn't manage to get ride off the AMD nightmare drivers

Adept II

Same here. I was playing Yuzu (TOTK) and all of a sudden my computer rebooted. Looking at the logs it said code 41 - Kerner Power. I have the "performance mode" power plan in place. it was the first time it happened.

Drivers: 23.7.1

Adept I

i write here two others things to explore for those like me :

- try manually disable DDC/CI in your monitor OSD

- try change the cable on your video card


no idea if it will do something but worth a try


Hello, i spent the day trying to resolve the problem.
This what i did (maybe it can help someone in the same situation so it s worth writing) :

- tested 3 other bios (failed)

- tested half ram 16 instead of 32go (failed)

-  tested old drivers (failed even with 22 series)

- tested without xmp (failed)


Now im trying this : all stock ( no under or overclock, no xmp nothing), driver version 22.10.3 , msi afterburner installed with the option ENLP: disable (and check afteburner work at launch), profile game (very important : no "game", just check "standart"). Disable "Enhanced Sync", and i put my monitor at 144hz (not 165hz even if it can do it).


I give it a try, will come back if it works....



Ok so i did the test, that doesn t work
Look im not an idiot i respect people but can recognize when they don t respect me.

And it s fair to say AMD doesnt respect his customers. Having billions and not being able to hire community managers like Microsoft or Nvidia does  in order to answer is at best  direspect.

I give one month to the company to check this stuff and repair it then if they did not i sell my computer, my stock (i bought a lot of AMD part) and they never see me again.

There is  a thine line between respect for customers and pur greedism

Dude, I got to say I really can't blame you. I'd probably do the same thing. 

Asus ZenBook UX407IQ, Ryzen 5 4500u with Radeon graphics, Nvidia mx350, 8gb LPDDR4X ram, Samsung 970 Evo Plus 500gb SSD, Win11 home

Did you report the problem using AMD bug report tool?

Asus ZenBook UX407IQ, Ryzen 5 4500u with Radeon graphics, Nvidia mx350, 8gb LPDDR4X ram, Samsung 970 Evo Plus 500gb SSD, Win11 home