cancel
Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

skoutariotis
Adept I

keep losing audio drivers

I have an oldie but goodie Radeon HD 5870 Vapor-x

I have installed the latest drivers, I think.

Display driver: Advanced Micro Devices, Inc. - 2/26/2016 - 15.301.1901.0 - Signer Microsoft

Audio driver: Advanced Micro Devices - 1/16/2016 - 10.0.0.2 - Signer AMD

Also, this morning my board mfg. [MSI] downloaded latest AMD chip drivers.

Both devices working properly per device mgr.

Windows 10 Home Version 2004 - Installed 7/26/20 OS build 19041.508 - Experience pack 120.2212.310

No problems w/video using displayport but my audio is the problem....

On boot audio returns to the onboard (that's not working either, lost it about a month ago, IDK why!).

In the audio selection, I only see the onboard Realtek HD audio, no AMD.

I look at device mgr. the AMD audio device is there and "working properly".

If I uninstall the AMD audio drivers, then rescan for new hardware,

then it becomes available again and works fine, till next reboot.

Any help will be greatly appreciated.

PS: This is my first post, so if I'm missing recommended info or if I'm on the wrong forum, please let me know and I'll fix it.

Thank you!

0 Likes
2 Replies
elstaci
MVP

Re: keep losing audio drivers

As you probably are aware of that your HD 5870 is considered to be legacy or not supported by AMD with driver updates. You then have a choice of 2 last AMD Drivers to install:

1- WHQL - 2015

2-BETA - 2016

I would try installing the BETA first and see if your audio continues and whether it shows up in Device Manager after installing the AMD Driver. If the problem continues then try the WHQL driver which is considered to be more stable than the 2016.

When installing or removing the AMD Driver from your computer use this basic method and see if the problem persists or not:

Uninstall the current AMD Driver using DDU as per this method:

It could be due to a corrupted AMD Driver installation.

Download free program DDU (Display Driver Uninstaller). Run it in Safe mode with the internet disconnected.

You can also run it in Windows Desktop but then you would need to Reboot the computer for DDU to finish erasing all of  the AMD Driver traces from your computer.

 Once it finishes uninstalling the current AMD Driver in Safe mode and boots back to Windows Desktop, still with the Internet disconnected, delete the AMD Installation folder C:\AMD if it was created before.

Now install the full AMD Drive package you downloaded manually from AMD Download page. Not the express package. Run the package and if it installs correctly again delete C:\AMD folder and reconnect the internet.

This should prevent any conflict when installing the new version from the previous version.

By the way, C:\AMD is always created whenever you run the AMD Driver package

It doesn't sound like a driver issue but it could be due to a corrupted AMD Driver installation.

Also run in a elevated Command Prompt or Powershell the following command to check your Windows OS to see whether it is corrupted or missing core files - SFC /scannow.

Please also post your Computer Information including Make & Model of your CPU, GPU, Motherboard, &  PSU.

0 Likes
skoutariotis
Adept I

Re: keep losing audio drivers

Yeah, when I originally had this problem, that was the first thing I did, used DDU to do a clean uninstall. I’ll check this out when I get back to my PC.

Thanks!

Wish I could afford the new stuff.

Sent from my iPhone 7 Plus on Verizon

0 Likes