Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Adept III

It looks like AMD can't do much more in the drivers department...

It's end of November and AMD STILL has the same problems (if not more being added) with its graphics drivers.

For me at least, it's the same thing even after reinstalling windows 10. In-game max framerates STILL don't match FRTC value, stutter and slowdowns are STILL everywhere especially when game reads from the SSD/NVMe but hey, we have DX11 optimizations which seem to have destroyed everything since all these problems started popping up after 22.5.1

Good job AMD for sending your customers to nVIDIA or Intel for their next upgrade.

PC build: 5800X3D, Asus C6H, 6800XT, NVMe, SSDs and HDDs, Creative SBX AE-5, LG 48-180Hz FS 1440p
11 Replies
Adept II

Not my experience with drivers.

Same here,no issues,updated to latest last night,all good

You're lucky then mate.

PC build: 5800X3D, Asus C6H, 6800XT, NVMe, SSDs and HDDs, Creative SBX AE-5, LG 48-180Hz FS 1440p
Adept II

Have you tried win 11? (Or maybe don't)

Well at least your driver still recognize the graphic card lol, mine stop working at random interval(crashes), and yes it do have random stuttering in gameplay for no reason even when i set the graphic to "Low"
22.5.1 doesn't work, 22.11.1 doesn't work, clean install the OS? Doesn't work, and i don't know whether AMD will take this thread seriously or not.
Oh boy..


Same here. I've tried Windows 11. RX 580 8GB DDR5 here.

Well, I'm getting random "No signal" or black screens when I return to desktop after playing some games... Issue started on Windows 10. Did a clean Windows 11 install and the same issue continues.

Tried installing different graphic drivers with no success.

I'm not having random stuttering in gameplay. When I'm playing everything seems to be working fine, not getting the "No signal" message (not video signal) while playing, but every single time I go back to desktop after playing, the "No signal" message appears again...

Now, with 22.11.1 driver I'm getting some random "No signal" or black screens while using a browser, like watching videos.

Another thing is that the GPU fans don't stop spinning when I return to desktop and after a few minutes the black screen shows up. But when I'm watching a video on YT and the GPU is "idle", then the black screen shows up and the fans begin to spin...

Don't know what to do with this thing, tried a lot of things and it seems there's no solution for this.


sorry you are having issues .. drivers have been great here for me since 5700xt, 6700xt and now RX 6800 .. other 2 GPU's are still running great in my daughter's and wife's setups.

I'd offer some suggestions, but it seems like this is just a rant post

ThreeDee PC specs

Rant post?

I asked for help from people in here to pinpoint what could be wrong with my PC and all i got as a response was "you don't know how FRTC works" (which i do since i've been using it for ages issue-free).

I asked AMD for help and their response was "sorry you're having problems, stick with 22.5.1".

This isn't a rant post, it's an observation post. The proof of AMD's drivers is this same forum. Just select Support Forums > Drivers & Software and you'll see how many posts there are with people speaking about bad drivers and the problems they have.

And no, it's the 1st time i've had problems with AMD drivers but this time it's consistent! EVERY newer driver after 22.5.1 has the exact same problem. Nothing changes. I've made a few posts about it, i've contacted AMD support, Hell, i even made a post in reddit/AMD and it got removed because the excuse was that i should have posted it in the "megathread clusterf*ck".

PC build: 5800X3D, Asus C6H, 6800XT, NVMe, SSDs and HDDs, Creative SBX AE-5, LG 48-180Hz FS 1440p

People that are not having issues won't ask how to fix issues they are not having .. so yeah, lol .. you are mostly only going to see people with issues asking for help .. and there are those that just want to say AMD sucks and seemingly don't want help

There are many here that would love to try and help you out with whatever issue(s) you are having

There are a plethora of things you could do/try if you wanted to ..and I'm sure you've probably done a few things already

I don't use RSR, Anti-Lag, Chill, Boost or FRTC .. so I don't have anything for yuh on that front specifically (or freesync either for that matter) .. just some eye candy settings and then tweak the fan curve a bit

But as far as just straight performance , reduce stutters stuff .. I can throw a bunch of stuff at you if you want the might help .. or might not ..

ThreeDee PC specs

Anything is welcome but honestly, seeing how 22.5.1 performs perfectly and every new driver does not is an indication that there's something really wrong with the DX11 optimization drivers released.

But don't think of me as a person who doesn't know about computers.

PC build: 5800X3D, Asus C6H, 6800XT, NVMe, SSDs and HDDs, Creative SBX AE-5, LG 48-180Hz FS 1440p

"But don't think of me as a person who doesn't know about computers."

lol .. I think you just have different priorities is all. You list your soundcard but not your power supply in your sig for example

Are you by chance running any cable extenders INSIDE your case? and/or a PCIe riser cable? ..and what PSU make/model are you running?

The ROG CROSSHAIR VI HERO is a great motherboard, but it's limited to PCIe 3.0 so you are hamstringing your 6800xt a bit there .. be it ever so slightly, you're still hamstringing it.. and maybe even a slight hinderance on overall I/O as well

Things to do/try if you want if you haven't already:

Of course, make sure your BIOS is up to date

Make sure your PCIe x16 slot is set to GEN3 .. and not GEN2 or 1.(not familiar with ASUS's BIOS's, but I had an issue on my old x470 Master SLI/ac where I had to set to GEN2 because AUTO couldn't negotiate a speed properly with my old 5700xt when it first launched .. a BIOS update resolved it so I could manually set to GEN3)

Make sure you are running latest AM4 chipset drivers from

Make sure you are running separate power cables from your PSU to each power input on your GPU

Make sure your Windows install is up to date

You probably all ready did the DDU thing

Maybe give Win11 a go

Disable MPO

Enable shader cache or switch from AMD optimized to ON:

Make sure your RAM is running at it's rated speed (Task Manager>Performance>Memory) & FCLK is 1:1

Turn HPET off

Make sure you have good air flow thru your case .. IF your VRM's and RAM get to warm, that can cause issues too

Make sure your system drives are not full or near full

IF you are running 3rd party anti-virus software .. McAfee or Norton .. uninstall it and just go with the built in Free Windows Defender .. run an adblocker in your browsers like the FREE Ublock Origin .. maybe sign up for a FREE OpenDNS account and use their DNS server addresses on your PC and/or in your networks router for another layer of protection with no impact on your PC's performance

(Different drivers can possibly interact differently with system configurations hence why I thru in the antivirus blurb)

..and lastly, the most unwelcomed suggestion, lol .. sell your x370 and pick up a B550 or x570 motherboard so you're not bandwidth limited.. I just picked up a used Gigabyte B550m DS3H with a 5900x for $275 shipped (so $40'ish for just the mobo) for another build I'm working on (going to swap out my server 3900x with the 5900x):

3900x,B550m DS3H,2x8GB 3466 (might have to run at 3200),RX 590 8GB,500GB M.3 NVMe PCIe 3.0 OS,1TB SATA HDD Data,600wtt 80+ Gold,Win11

..anyways, that last bit was a bit off topic .. but I get that your frustrated and hopefully you can get a resolve of some kind so you can get back to gaming like you want/expect

ThreeDee PC specs

Corsair Rm850X (i always forget this)

PCIE in BIOS is Gen3. Latest BIOS AGESA, MPO is on disable (meaning the 00005 value is there), RAM is 3200MHz, IF at 1600, BitDefender is on and uBlock Origin too, OpenDNS is set on the router so all devices benefit. I always use DDU but that's not the issue since i tried with a fresh windows 10 installation.

You are missing the point here though (thanks for the effort btw). I have problems with every driver after 22.5.1. All DX11 optimizations drivers have the exact same issues. Games have stutter and slowdowns (when SSD/NVMe is reading) and ingame FPS never hit FRTC value. And i'm speaking about games that DO hit the FRTC value, like A Plague Tale: Innocence, Guild Wars 2, Diablo II Resurrected.. That's where i believe the problem begins. Limiting the ingame performance to lower than what is set in FRTC seems to introduce latency and issues.

That's why i made a post here asking people's help setting FRTC to 2 fps below their max monitor frequency and testing this, to try to pinpoint what i have done wrong.

Anyway, thank you for your time.

PC build: 5800X3D, Asus C6H, 6800XT, NVMe, SSDs and HDDs, Creative SBX AE-5, LG 48-180Hz FS 1440p