Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Adept I

Issues waking from sleep with latest 19.1 and 19.2

CPU - AMD FX-8320

Graphics - MSI R7850 Twin Frozr 2GD5/OC 2GB x 2 (crossfired)

Motherboard - ASRock 970 Extreme3 AM3+

RAM - Patriot Gamer 2 Series 16GB (2 x 8GB)

OS - Windows 10 

Fresh format, when windows installs the video drivers, it automatically installs 17.1.1. With these drivers, I have no issues waking the computer from sleep, it takes about 2-3 seconds as usual. 

When I install the latest 19.1 or 19.2, the computer takes about 30 seconds to 1 minute to wake from sleep. I've troubleshot as much as I could.. disabled ULPS, disabled fastboot, etc. 

When I revert back to 17.1.1, the wake issues go away.

I do a full uninstall and clean each time using DDU and AMD's clean drivers tool.

Any thoughts?

21 Replies

Win 10 x64 1803

Mobo Gigabyte GA-970a-ud3 bios ver FC

CPU amd FX 8350, 8GB ram

GPU RX 570 4GB

I have also had sleep/resume problems with all the recent drivers, 18.10.1 works OK for me but everything newer I have tried gives me problems. Basically it seems that when I put the PC to sleep using the newer drivers, sometimes (1 in 3-5 times) it shuts down, not sure if that was due to a crash but it definitely shuts down, normally I wake it up using a remote but when its shutdown obviously I have to press the power button and it re-boots, naturally taking a much longer time than resume from sleep. Could it be that you are seeing the same problem, how do you wake the PC up?

I have no fix for this, just hoping AMD resolve it some time.

i hit the spacebar or just click on the mouse. weird thing is that, i did a clean uninstall, and reinstalled the latest 19.1.2 to do some testing. waking from sleep started to work perfectly normal. 

after a few restarts (i did nothing new since then) the problem came back. 

Adept II

Similar issues here.

I noticed that sleep/wakeup only works correctly, when i manually press the hibernate button in the start menu.

When I set the idle timer and wait, or I press sleep button (start menu) my pc still gets lost in sleep...

have you tried to hibernate?

here is my post: 


yeah hibernate takes even longer to wake. i did a clean uninstall and reinstalled the latest drivers earlier and the issue went away for a little bit. after a few restarts, i again am having issues waking from sleep.

nothing makes sense


I know that since the 17.1 drivers a lot has changed in Windows itself to the graphical subsystem. So my best guess is that AMD has likely made changes to be in compliance with these changing standards. That doesn't mean that it didn't introduce bugs. Me personally, I hate the default settings for sleep in Windows 10 being Hibernation w/ fast startup. I would try disabling Hibernation and Fast Startup and that will then use traditional Standby Sleep which is way faster to recover from. It uses slightly more power but for desktop systems IMHO is way better. Other possibilities when it comes to chasing down sleep issues and very often overlooked is the Monitor Drivers themselves. People update their GPU drivers but never look for an updated Monitor driver or worse never loaded their monitor driver to begin with only using the windows built in Generic PNP driver. So I would try that too. Also worth mentioning is that Windows 10 has a habit of periodically swapping the correct monitor driver back to the Generic PNP driver even if you had loaded the right Driver from you Monitors maker so make sure after updates or when you notice issues that the correct monitor driver is in fact still loaded. If none of that helps I can only suggest you open a support ticket with AMD support:  Online Service Request | AMD 


I actually did a full clean install of Windows 10. Full clean uninstall of the video drivers they automatically installed upon getting into the desktop (version 17) after testing that sleep properly woke just fine.

after installing 19.2, there was still wake issues.

i disabled hibernation and fast startup and only use traditional sleep. ive also installed the latest monitor drivers. ive tried disabling crossfire also. ive already opened a support ticket.

i still get wake issues

same here with computer sleep... 

neither my monitor goes to sleep properly. i set 5min idle for monitor standby. instead it turns off for a few seconds, then turns on backlight showing me a black screen. it is really annoying.


Same here, fast startup and hibernation are disabled but still getting sleep and resume from sleep problems with 18.12.2/3 and 19.1.1/2 all works fine with 18.10.1 and earlier. Though to add insult to injury when I do rollback from those recent drivers I run into the problem reported here, not happy! Sending the monitor to sleep with set up for 30 min idle on my desktop with 19.1.2 works OK but I do not put the PC to sleep though.


My screens started to flickering insanely out of no where with 19.1.2 after half a day. I couldn't even navigate my mouse around the screen. I managed to boot into safemode to uninstall the drivers and reverted back to 17.11.4... things seem normal for now again.


Have you tried to disable HDCP? It helped me to fix some flicker issues after wake up:

Radeon settings --> Display --> Specs (upper right corner) --> Override --> HDCP support --> OFF

Tried to enable/disable Windows WHQL support in bios? or reset bios?

Also: usb devices can prevent screens to sleep. Joysticks, game controllers, keyboard, mouse...

Try to unplug them and remove its hidden leftover from device manager.

Windows Device Manager View Show Hidden devices

I've seen the disable HDCP mentioned a few times, but the weird thing is, when I go into the specs page for both monitors, there is no override tab

Adept I

Oh man... so I stayed with 19.1.2, regardless of the sleep issue. Just now my screens started to flicker like crazy. Both monitors, I could barely even navigate my screen. My mouse and windows kept flickering also. I somehow was able to boot into safemode (pain on UEFI Bios cus I couldnt hit f8) and was able to uninstall the video drivers.

I'm back on 17.11.4 and things are normal again.


All I can recommend at this point is open a support ticket with AMD. I'd put a link to this thread in your request too. 

 Online Service Request | AMD 


Are you running dual monitors? If you are, try to unhook 1 of them and see if the problem is still there. This is similar to problems I'm having, but I don't use sleep. You can look at my question to get an ideal of what I'm saying.


I am running dual monitors. I've tried it with only 1 monitor attached, also tried changing out from HDMI to DVI, still wake issues

Adept II

I solved my computer sleep problem.

What i did:

Adrenalin 19.1.2 and the latest chipset drivers (18.10.1810) were already installed on my computer.

Today i decided to check the chipset installer once again.

I was quite perplexed when it showed all chipset drivers "not installed" (see custom install --> hover mouse cursor over each driver ). So i installed them and rebooted.

I also found an article that says chipset drivers version 18.10.1810 isn't up to date anymore. LINK (german website)

The new version is 18.50.06 and (for unknown reasons) it is only available on the ASUS support website.

Only two things were renewed since previous version:

- AMD GPIO Controller   (old:

- AMD PCI Device     (old:

I took these two drivers from the link above (to avoid installing the whole driver package ~370MB)

and updated directly through the device manager.

After a restarting windows and assuring everything works well I went into bios and flashed it once again (same version).

Then booted into windows with default bios settings.

Tried sleep mode --> It works!!!

Went into bios, loaded my saved settings, started windows

Tried sleep mode --> Computer gets lost in sleep again. (won't wake up properly)

Went into bios, loaded bios defaults, started windows

Sleep mode --> It works!!!

Went into bios and set everything what i need manually, without loading MY saved settings. Started windows

Sleep mode --> It works!!!


Good to hear you fixed it. You did not include your system info, am I correct to assume it is a Laptop?

In my case and I think that of the OPs  the problem is on a desktop PC so your fix may not be relevant.


Its a desktop pc:

- MSI B450M Mortar (bios: 7B89v13)
- AMD R5 2400G APU
- 16GB (2x8) G Skill Aegis 3000Mhz RAM
- Be quiet! pure power 10  600W PSU
- Philips 276E8VJSB 4K IPS Monitor (connected via HDMI)
- Windows 10

here is my post 


BTW both new driver files appear in the driver easy database as well.

you could make a find with this tool.


Nice!! I'm glad you got yours working. Because of your post, I went and also double checked if my chipset drivers were installed and saw the same thing you mentioned. I hovered over the 2 drivers and it said it was not installed. I went ahead and installed them. I also re-installed 19.1.2 prior to this just to be able to test it. 

The problem is still there, but I did notice the wake time went from 30seconds - 1 min, down to about 15ish seconds now. It's not as instant as it usually is with the 17x drivers, but I suppose I can live with 15 seconds just to have the most up to date drivers. 

I will continue to monitor this for the next few days, and if it stays consistently with 15 seconds, I will stick with it. The main concern however was the random massive flickering issues I had the other day. So far so good, so keeping my fingers crossed.

Again, I'm glad your issue is resolved! Thank you again for the help and replies!


I have an issue where when I lock Windows (Windows key + L) my monitor will go to sleep after a minute. When I turn it back on and unlock, all the windows on my desktop have resized to I'd guess roughly 800x600 and moved to the top left. It doesn't restore them properly. Sometimes it also gives me an error but I forgot to make note of that. if I see it again I'll mention it.

[ 5800X3D | Aorus 6950XT | MSI B550 | H115i Pro | G.SKILL 32GB 3600Mhz | 850W Gold | Samsung Odyssey G7 240Hz | HP Reverb G2 (v2) ]