Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Is there ANY WAY to download JUST the drivers for my AMD 2200G these days without all the bloat?


I downloaded and installed the latest AMD Andrenalin package yesterday at a whopping size of 564MBs hoping it would fix my issues with Microsoft's OneNote software. It did not solve the issue. In fact, I believe it's introduced an ever bigger issue. The drawing pens in OneNote do not even start to draw until you release the left-mouse button. This gives the appearance of a lagging pen and also makes it very difficult to draw at all since you can't see the ink as you draw. It's a horrible bug.

I had to install the whopping 564MB package yesterday when all I really wanted was updated drivers. Wishing I had not even done this now. Are there any links now or going forward where we can download just system drivers without the bloat?

Btw, my CPU is Ryzen 3 AMD 2200G with integrated Vega 8 Graphics. Thanks for reading!!!

14 Replies
Adept III

I believe the install packages that AMD makes available in Windows updates installs a fairly basic driver package. The AMD Radeon software app/control panel however is always included in an AMD driver install, to my knowledge.

I've always installed AMD drivers from the full installer, directly from AMD's website, and have never had issues. Where I DO have issues is when Windows update decides to push a Radeon driver update automatically, overwriting my AMD Adrenalin install. Very annoying. 

Ryzen 9 5900X CPU, RX 6700 XT GPU, Windows 11 Pro x64 build 23H2

I don't believe you can avoid the bigger download but when you run the setup you should be able to choose just the minimal install which is drivers only. I never use it but I have seen it.

You can also stop Windows from installing drivers. Right-click the start button > System > Advanced system settings > Hardware tab > Device Installation Settings > set it to No.

[ 5800X3D | Aorus 6950XT | MSI B550 | H115i Pro | G.SKILL 32GB 3600Mhz | 850W Gold | Samsung Odyssey G7 240Hz | HP Reverb G2 (v2) ]

@sur6e- I've disabled Device installation from Advanced system settings on a number of my AMD systems and GPU drivers still get pushed out to them, often automatically, so I've had to go through the DDU uninstalls of Windows-update-installed AMD drivers numerous times. It's most obnoxious on my RX6700XT gaming PC as I have to redo configs, overclocking, the whole process every time it happens. Occasionally I'll catch it before Windows Update attempts to deliver the drivers. I've found that the only true way to really stop unwanted drivers is to make changes to the local computer policy within the Group Policy editor, GPedit.msc, to force Windows updates to a more manual process, which is also quite a hassle from a user experience perspective. 

Ryzen 9 5900X CPU, RX 6700 XT GPU, Windows 11 Pro x64 build 23H2
Journeyman III

I'm having the same issue and it's driving me mad. All the drivers have installed but the graphics driver for the cpu (7700x) just wont install. One minute its a Radeon igpu, the next something else. At the moment its a 'Microsoft basic display adapter. I cannot get the driver to install. Ive tried shutting the firewall down. Ive tried shutting off the anti-virus. Nothing is working. Ive even gone into windows and told it to not automatically install device drivers. But even when I uninstall the device, it pops up as something eventually, totally wrong.

I'm pretty new to AMD. Only just migrated from Intel and for the most part I am over the moon with the performance. Far exceeding what ive been used to. But this driver issue is really starting to get me down. I don't know why AMD havent addressed this issue more or taken it more seriously. Whenever I try to install the Adrenalin driver pack (23.2.1), it stops everytime giving me error messages (error 195 etc). I'm just out of things to try. Ive spent more time messing around googling issues than enjoying it.


Have you tried running the AMD Cleanup Utility or DDU and then rerunning the Radeon setup again?

[ 5800X3D | Aorus 6950XT | MSI B550 | H115i Pro | G.SKILL 32GB 3600Mhz | 850W Gold | Samsung Odyssey G7 240Hz | HP Reverb G2 (v2) ]

Hi there. Many thanks for the suggestion. Now this is weird. I ran the cleanup utility, booted into safe-mode, removed all traces of AMD drivers etc and then booted back into Windows 10. Re-ran the AMD drivers and it appeared to work. The driver was installed and the device was working. But as soon as I rebooted and went back to the desktop, the driver was still there but there was an error message "Windows has stopped this device because it has reported problems. (Code 43)". I am stumped. Every time I clear a hurdle, something else happens


In the year 2019 when I downloaded the Andrenalin drivers they offered a package called: "radeon-software-adrenalin-2019-edition-18.12.2-minimalsetup-181212_64bit.exe". It's still on my hard disk. The size is a jaw-dropping 25MB.

Oh my God, how times have changed. Can we go back to the year 2019 please?


You can use Device Manager to install the GPU driver. It will install the VGA Driver and whatever basic AMD app it needs to run the driver.

You can try downloading the AMD Driver Package, unzip it, and then direct Device Manager to the unzipped AMD Folder and let it scan it and install the driver and it related software.

I just did this. Selected 'driver only' and selected the destination folder. Couldnt even complete. Got the usual error 195 'oops something went wrong'. Unbelievable. Ive been spoilt with nvidia drivers. Everything always went without a hitch.


First please post your PC information.

Did you first use DDU to remove all traces of your previous Nvidia GPU card driver or are you trying to use both the Nvidia GPU card and AMD integrated Graphics?

Here is the latest AMD VGA Driver for your 2200G processor:

Can you upload an image of Device Manager with Display category opened?

Also upload an image of GPU-Z showing either or both AMD and Nvidia GPUs.


I don't have the 2200G cpu. That is the person who originally started this thread. I have the 7700X. I only replied because I had a similar issue. Ive tried getting the simple driver downloaded and still can't. Incredible. Everything I try goes pair shaped.

Anyway, I only use an RTX3080 card, so I disabled the igpu in the bios (Gigabyte)  and although it's disappeared from the device manager, there is now another device complaining. Didn't popup until the igpu was disabled. Wants a driver as well. I'm just gonna ignore it. I can't work this out. Disappointed AMD can allow such a really bad issue to escalate like this. Think I'll just leave it like it is. I appreciate the help but honestly ive wasted two days trying to fix this. 


You can always delete the drivers you have installed and let Windows Update install the latest WHQL drivers. That's all it installs.... no Adrenaline, etc.

What? thats why I'm having these issues. Microsoft's drivers are so out of date its not even funny. Even their nvidia drivers are not even the latest. I really don't know why AMD don't send updated drivers to Microsoft. Might be handy getting your system working to a certain degree, but running a pc on old drivers? nope, not gonna happen. 


Old? Wrong. The Windows Update drivers are the latest. That is the problem when a user installs a 'optional' update from AMD. When the computer reboots (as yours did) Windows Update has installed the driver it thinks you should have. Then you get that message. The only way to prevent that is by Group Policy.

What is it about Adrenalin you don't like? You use some other third party graphics controller?

What's this all about > Anyway, I only use an RTX3080 card

This post has strayed off the OP's subject intent and differing computer parts are no way to compare. I suggest you start your own thread.