Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Journeyman III

Is my card dead? 5500 XT, Driver install causes reboot, PC ends in boot loop


I'm writing this after reading nearly 50 threads this morning of people describing a similar problem.

I have a brand new computer, less than one month old:

Ryzen 3900x

ASUS ROG STRIX b450-I (latest BIOS 3004)

Sapphire Radeon 5500 XT Nitro+ 8GB Special Edition


Yesterday when I tried waking my computer from sleep it didn't boot - the spinning logo froze, rebooted twice and made it to the recovery. It boots only in Safe mode.

I have attempted every single suggestion: from DDU to completely nuking and installing a fresh Windows 10 using 5 different ISO images I had (from build 2004 to much older builds).

I reset my BIOS settings to stock, even disabled WiFi, so my installations were completely offline. Tried installing the latest chipset drivers (both from AMD and ASUS websites). Nothing: the driver either fails to install (a black screen followed by an infinite boot loop), or, when installed manually by selecting the .inf - it doesn't boot at all (and even then fails to install, I get a glimpse of a popup saying "reboot required" before it dies).

Tried several of the available Adrenalin drivers, going back few releases.

Finally, I tried it in Ubuntu - it didn't even boot into the OS after the initial setup.

Seeing how this is a problem that affects many people my question is: is the card dead? It's a month old, I'm going to RMA it either way.

Is there really nothing else to be done to diagnose it?

Tags (2)
0 Kudos