Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Adept I

Is Freesync no longer supported for Samsung CF791?

So I bought my Vega 64 and Samsung CF791 monitor in the deals when they were first launched.

Since 18.1.1, it seems I lost Freesync when using a Displayport cable (tried numerous cables, same result with each). I then moved onto HDMI. At this time I changed to a Vega 64 LC. Then since 18.2 roughly, It seems I have lost Freesync all together.

It's definitely a software issue as reinstalling 18.1.1 gives me nice smooth Freesync game play.

At the moment I get ''less'' tearing using HDMI, and unbearable tearing with Display port.

If it's no longer being supported, why would AMD market this monitor with the launch of Vega?

To confirm: Freesync Ultimate Engine is enabled on the monitor. Freesync is ''ON'' on Radeon Settings. I've experimented with Chill and FRTC, but these remain off. I've experimented with individual game profiles with AMD optimized Freesync and Freesync ON.

74 Replies
Adept II

Hi. You are not alone with this issue. I created a similar topic in this forum and i submitted a Supportticket at AMD Support. So far so bad.

Please see my answer below - hopefully it helps:

Re: Is Freesync no longer supported for Samsung CF791?

Adept II

I as well can't get freesync to work on the newer drivers using the CF791. I believe it's an issue though and not lack of support, because you are still able to turn on freesync in the radeon settings, it just makes no difference.

Would be nice if we could get a word from amdmatt​ on whether or not engineering is aware of this issue?

Several threads has been started concerning this issue now

I agree. I also believe that amdmatt​ personally uses this monitor too...


I do and i am investigating. I have this monitor and use FreeSync, i have tested DP and HDMI extensively and FreeSync works okay in both situations. I tested a dozen games. That said, i did observe some minor tearing in Far Cry 5 with FreeSync enabled, that was not there as soon as i enable Vsync.

If folks can provide their full system specs, current driver version/OS, how they are connecting the display and full reproduction steps i will investigate further.

I uploaded my dxdiag report here: It has my full system specs i assume, it also shows that it's connected through DP. Also, i uploaded video from my android demonstrating it on sniper elite with the 17.12.2 driver first then the 18.3.4. Could you have a look?


Thanks but no need, we are already looking at the issue and do not require any further DXDIAG reports or demonstrations of the issue.


18.5.1 didn't change much reagarding the problems listed on this topic. Should we expect any improvement on the upcoming drivers?


With 18.5.2 i don't have the signal loss issue. No black screens upon starting any games so far.

But freesync is stll broken, there's the exact same tearing as shown in the video i posted above with 18.3.4


The tearing issue is still open for now, but glad to hear the black screen has stopped.

Just adding myself to the list of people with CF791 freesync problems. I went back to 17.12.2 to get it working again.  I had to fish out old my hdmi cable since using DP causes the black screens with the older drivers.

Community Manager

What GPU are you using?


Sorry, I should have listed that.  I'm using a Vega 64. (Red Devil Version)


The black screens still happen though not as frequent. Sometimes only for 2 seconds, then signal returns. Dirt Rally for example causes a permanent black screen, forcing me to power cycle the monitor.

Edit: Sorry with 18.5.2/DP


I doubt it depends on the monitor tbh, I have an AOC AG241QX and freesync NEVER worked to me. On GTA it does reduce the tearing but not delete it, on Crysis freesync only works in windowed mode ( Take a look here please​), while in other games it won't work in any way.

Adept I

Freesync issues continue not just on this monitor but on the Nixeus EDG27.

It may have something to do with multimonitor setup... maybe. I only say that because that is my setup and it was mentioned in a previous bug fix.

Adept I

I seem to have fixed Freesync with the help of Mr Nixeus.

He mentioned something about Game DVR, but in the Fall Creators Windows 10 update the Game DVR setting doesn't seem to work. I went into the registry to turn it off using these instructions.

Open Registry Editor (Run > regedit)

Navigate to HKEY_CURRENT_USER\System\GameConfigStore

Set the value of DWORD "GameDVR_Enabled" to 0

Go to HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\

Create key "GameDVR".

Create DWORD 32bit called "AllowGameDVR" and set to 0

Restart your computer.

After this, my Freesync in games and in Gsync demo is working again in 18.3.4

The windmill demo still does not work however, but I am told this is because that was old software that doesn't do freesync the way it is programmed now.

Please let me know if this fixes it for you Samsung users, and maybe amdmatt, you could look into why this is happening?

FYI:an OPS at Nvidia made up a script to disable GAMEDVR and XBOX. One of the expert commentators says it is risky to use and may open Windows to virus/malware. Don't know if this is factual or not. Anyways here is the script from Nvidia:

Hello everyone,

I have re-posted this here as it made more sense. You can't update drivers to fix this. It takes a lot more to undo the changes in the Win 10 Creators update that are causing so much grief. But there is a fix. To make it quick and simple I wrote a script that does all that is required.

There have been many posts claiming to have a fix. In most of these I have seen some really bad advice on what is wrong and how to fix it.

If you want to fix this issue once and for all. You don't need to remove your drivers, download any shady apps or wreck your folder permission to fix this. The script I provided is safe. It only changes what is required to undo the root of the problem. The instructions are below. The script must be run in the order top to bottom. So please make sure your first line is ( and the last line is ). This makes it run in series. There is no fat. Every line is required.

Simply turning off the XBOX related settings does not stop the "GameBarPresenceWriter.exe" from running while gaming. The script below can be copied and pasted into an admin CMD window or if you have powershell as the default open a powershell admin command-line and type CMD then press enter. Then paste the code below to run. You can also just save it as a .BAT and run as Admin.

This has fixed The division, Wild-lands, Rocket league, and Doom for me. I have not had the issue return either I might add!

Gaming is as smooth as ever for my friends and family. If the direction are still too hard to understand you might want to ask a "Tech" friend to assist you.

If a game is still giving issues after running the fix, please post here PM me and maybe I can help you work out why.

REM --- copy from here-----


reg add "HKLM\System\CurrentControlSet\Services\xbgm" /v "Start" /t REG_DWORD /d "4" /f

sc config XblAuthManager start= disabled

sc config XblGameSave start= disabled

sc config XboxGipSvc start= disabled

sc config XboxNetApiSvc start= disabled

schtasks /Change /TN "Microsoft\XblGameSave\XblGameSaveTask" /Disable

takeown /f "%WinDir%\System32\GameBarPresenceWriter.exe" /a

icacls "%WinDir%\System32\GameBarPresenceWriter.exe" /grant:r Administrators:F /c

taskkill /im GameBarPresenceWriter.exe /f

move "C:\Windows\System32\GameBarPresenceWriter.exe" "C:\Windows\System32\GameBarPresenceWriter.OLD"

schtasks /Change /TN "Microsoft\XblGameSave\XblGameSaveTask" /Disable

takeown /f "%WinDir%\System32\bcastdvr.exe" /a

icacls "%WinDir%\System32\bcastdvr.exe" /grant:r Administrators:F /c

taskkill /im bcastdvr.exe /f

move C:\Windows\System32\bcastdvr.exe C:\Windows\System32\bcastdvr.OLD

reg add "HKCU\Software\Microsoft\Windows\CurrentVersion\GameDVR" /v "AppCaptureEnabled" /t REG_DWORD /d "0" /f

reg add "HKCU\Software\Microsoft\GameBar" /v "UseNexusForGameBarEnabled" /t REG_DWORD /d "0" /f

reg add "HKCU\Software\Microsoft\Windows\CurrentVersion\GameDVR" /v "AudioCaptureEnabled" /t REG_DWORD /d "0" /f

reg add "HKCU\Software\Microsoft\Windows\CurrentVersion\GameDVR" /v "CursorCaptureEnabled" /t REG_DWORD /d "0" /f

reg add "HKCU\Software\Microsoft\GameBar" /v "ShowStartupPanel" /t REG_DWORD /d "0" /f

reg add "HKCU\System\GameConfigStore" /v "GameDVR_Enabled" /t REG_DWORD /d "0" /f

reg add "HKLM\Software\Policies\Microsoft\Windows\GameDVR" /v "AllowgameDVR" /t REG_DWORD /d "0" /f

reg add "HKCU\Software\Microsoft\GameBar" /v "AllowAutoGameMode" /t REG_DWORD /d "0" /f


REM ---End Copy Here---

This RE-ENABLE GAMEDVR/XBOX script was made by another User after I made a comment about undoing what the first script had done to the Registry:

A couple of corrections have been made to the script to re-enable Game Bar / Game DVR folks... I had some things backwards but it's working 100% now, I've tested it. Windows Update won't know the difference, because it also restores the original permissions and ownership to the files affected. You will need to restart your computer, though.

  • @echo off
  • goto check_Permissions
  • :check_Permissions
  •   echo Administrative permissions required. Detecting permissions...
  •   net session >nul 2>&1
  •    if %errorLevel% == 0 (
  •   echo Success: Administrative permissions confirmed.
  • move "C:\Windows\System32\GameBarPresenceWriter.OLD" "C:\Windows\System32\GameBarPresenceWriter.exe"
  • icacls "%WinDir%\System32\GameBarPresenceWriter.exe" /setowner "NT Service\TrustedInstaller" /c
  • icacls "%WinDir%\System32\GameBarPresenceWriter.exe" /grant:r Administrators:RX /c
  • schtasks /Change /TN "Microsoft\XblGameSave\XblGameSaveTask" /Enable
  • move C:\Windows\System32\bcastdvr.OLD C:\Windows\System32\bcastdvr.exe
  • icacls "%WinDir%\System32\bcastdvr.exe" /setowner "NT Service\TrustedInstaller" /c
  • icacls "%WinDir%\System32\bcastdvr.exe" /grant:r Administrators:RX /c
  • schtasks /Change /TN "Microsoft\XblGameSave\XblGameSaveTask" /Enable
  • sc config XblAuthManager start= auto
  • sc config XblGameSave start= auto
  • sc config XboxGipSvc start= auto
  • sc config XboxNetApiSvc start= auto
  • reg add "HKLM\System\CurrentControlSet\Services\xbgm" /v "Start" /t REG_DWORD /d "3" /f
  • reg add "HKCU\Software\Microsoft\Windows\CurrentVersion\GameDVR" /v "AppCaptureEnabled" /t REG_DWORD /d "1" /f
  • reg add "HKCU\Software\Microsoft\GameBar" /v "UseNexusForGameBarEnabled" /t REG_DWORD /d "1" /f
  • reg add "HKCU\Software\Microsoft\Windows\CurrentVersion\GameDVR" /v "AudioCaptureEnabled" /t REG_DWORD /d "1" /f
  • reg add "HKCU\Software\Microsoft\Windows\CurrentVersion\GameDVR" /v "CursorCaptureEnabled" /t REG_DWORD /d "1" /f
  • reg add "HKCU\Software\Microsoft\GameBar" /v "ShowStartupPanel" /t REG_DWORD /d "1" /f
  • reg add "HKCU\System\GameConfigStore" /v "GameDVR_Enabled" /t REG_DWORD /d "1" /f
  • reg add "HKLM\Software\Policies\Microsoft\Windows\GameDVR" /v "AllowgameDVR" /t REG_DWORD /d "1" /f
  • reg add "HKCU\Software\Microsoft\GameBar" /v "AllowAutoGameMode" /t REG_DWORD /d "1" /f
  •    ) else (
  •   echo Failure: Current permissions inadequate.
  •    )
  •   Pause > null

If you had attempted to use the re-enable script previously, you'll need to run the disable script again, then the updated re-enable script for it to finally be successful.

Seems a bit convoluted when all you need is what I quoted.


Am not a Programmer. This was done by someone else that suppose to Disable GAMEDVR and XBOX. I just copied what they used to disable those features.


fuzzmunky​ I checked the registry and i already have the "GameDVR_Enabled" set to 0. I created the second one "GameDVR" in HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\ set to 0 and rebooted. No avail, freesync still broken. I still see lots of tearing compared to the previous drivers where freesync was working.


Sadly same to me, but thx for the hint.

Im planning to reset my System and reinstall Windows as soon as i have the time.


I tried reinstalling windows, it still persists. But you're also free to try of course.


Have you tried resetting the monitor to defaults? I cannot reproduce this issue at all. :/


amdmatt​ No luck. Can you check out the video i uploaded above? I just tested the same game same movement on 17.12.2/18.3.4 and put them together. Would maybe give you an idea of what we're dealing with


Reinstalling Windows 10 didnt helped.


My personal opinion about reinstalling a clean Windows OS is that it should be a last resort if everything else fails. If it is a Windows misconfiguration or Windows Update or driver incompatibility, Reinstalling the OS is not going to do anything. If you run SFC /scannow or DISM and everything comes back good. It is a good bet the core Windows files are good and not corrupted or missing.

If I do decide to do a Clean Windows installation, I will make a System Backup image. That way if the Clean Windows OS doesn't resolve the problem I can restore my original Windows with all of its legacy and newer software and programs and configurations.


I'm wondering if it could be some other overlay software which is conflicting if not GameDVR. Can you think of anything you have installed? Perhaps Discord?

Adept I

Just wanted to update with my specs.

System Configuration:

Motherboard: MSI Z97i Gaming ACK (Bios: A.4)
CPU: Intel i7 4790k
Memory: 16GB DDR3
GPU: MSI Vega 64 LC
VBIOS: 115-D0500500-103
Driver: 18.3.4
OS: Windows 10 Home, Ver: 1709, OS Build: 16299.309

Monitor: CF791 Samsung

Steps to Reproduce:

1. Install necessary driver, GPU and medium-end CPU
2. Enable Free Sync
3. Any Graphical Setting
4. Screen Tearing experienced
5. Most noticeable with HDMI than DP

Expected Behavior:

Game runs smoothly with good performance with no visible issues

Actual Behavior:

Constant Tearing, oddly more visible on DP than HDMI

Tried Samsungs ''driver'' for the monitor, this creates a 'purple filter' across the screen. Tearing still apparent. Currently using the ''Generic PnP'' for the monitors as samsung' seems to make 0 difference. Patch 18.1.1 is the last working patch for me with Freeesync.

Adept II

Any updates guys? Is this issue being looked at, is there anything else we need to share?


Im using the 17.12.1 Driver at the moment. With the newest Driver im not able to get FS to work. That is with a freshly installed Win10.

Adept II

Maybe we should start to compare our Firmwareversions for the CF791. It seems there was a Firmwareupdate by Samsung last Year.

Community Manager

Interesting. What more do you know about this?


I have a Samsung Smart TV that I have connected to my GPU via HDMI. The television is also connected to the internet via WiFI. When there is a new software, driver or Firmware update it automatically alerts me if I want to install it. I click "Yes" and it downloads and installs the update.

I went to Samsung Support and there is not Firmware update. just the following for the CF791:

SEP 14.2017 | see 1.0.29 | 42.13 MB

I'm certainly not aware of any Firmware update with this monitor and I've searched for it extensively myself previously, including on the Samsung forums.


Hi. You said that Freesync is working just fine for you. Do you have V-Sync enabled while testing Freesync?


I'm assuming it's just not updated, but this is suggesting that vega isn't supported?

Adept II

Couldn't find anything related to the firmware either. But it seems there are different models. Mine is LC34F791WQUXEN, but there is also LC34F791WQNXZA. What model do you guys have?