Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Adept I

Invisible mouse pointer citrix workspace


Recently I upgraded my system to Windows 11 with the latest AMD drivers (22.8.2). Everything works fine except my virtual desktop I need for work, my mouse pointer/cursor is invisible on white backgrounds. I tried multiple things to get it fixed but the only thing that works is reverting my AMD drivers back to WHQL 22.5.1. It seems that more people have this issue Citrix Workspace App: White mouse pointer when connecting from Win 11 to Win 10 - Receiver Compatibi...

I also tried different versions from Citrix (LTSR 1912, and This doesn't fix anything. 

AMD Drivers:

22.5.1 WHQL > No issues

22.7.1 > Invisible mouse

22.8.1 > Invisible mouse

22.8.2 > Invisible mouse

Back to 22.5.1 > No issues

22.9.2 > Invisible mouse


1 Solution

Thank you for your patience, this issue has now been resolved in the 23.3.1 driver. 

AMD Software: Adrenalin Edition 23.4.1 Release Notes | AMD

View solution in original post

50 Replies
Adept I

Error still occuring with 22.11.1

Same here, latest drivers installed today.


I am having the same issue. It started a couple days ago. For me, The black portion of the mouse cursor becomes white. The mouse cursor border. So with a white background, the mouse cursor is effectively invisible. I cannot work effectively.

Which drivers are you guys referring to? Video Card? Processor? Bios?


I was able to determine you guys were talking about the display adapter. Apparently, windows auto-update installed the Universal Windows Platform driver. I disabled the automatic updates and re-installed the AMD drivers using Adrenalin Edition version 22.5.1.

Now the problem is resolved. I can see my mouse again when using the Citrix Workspace.

So, I think it's that UWP driver that is the problem. Hope this helps someone.


You can just disable driver updates from windows update vis gpedit.msc or via the registry:

  1. Press Windows + R, type regedit, and press Enter to open Registry Editor.
  2. Go to: HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\DriverSearching.
  3. Double-click DriverUpdateWizardWuSearchEnabled and set its value to 0. This will stop Windows 11 automatic driver updates. To enable the automatic driver updates again, follow the same operation to set its value to 1.

    If you just disable automatic updates when you DO click windows update it will just reinstall drivers above 22.5.1 again.

The AMD graphic drivers. Once you go above 22.5.1 (30.0.15021.11005) you have the same problem. My Windows Update doesn't update drivers, first thing I disabled. You can revert to 22.5.1.

Journeyman III

I am having this issue as well. I have a Lenovo P520 workstation with a Radeon RX 6600 running Windows 11 Pro 64bit. Since this is a new build, I initially went with the newest drivers which displayed the described problem. The workaround I found is to set a color for the mouse pointer which will work for the session. The settings are lost if you log out and you have to set them again. Windows shows that the color has been set, but the AMD driver does not pick up on the setting. If you choose another color and back, then it sets it.

I tried the 22.5.1 driver as suggested and the problem goes away. Please fix as this is disappointing as this is my new work from home build and I need Citrix to work properly.

I submitted a bug report also.

Adept I

Has AMD address this topic? Seems like it should be an easy fix for the company to provide the end user, yet here we are.

Journeyman III
Okay so I'm on the latest versions of AMD gpu and Citrix as of this post. What I did to make this work was:
(BTW on dual monitor setup, 1920x1080p & 3440x1440p screen. 5600xt)
In your home pc:
- right click Citrix Workspace on the bottom right under hidden icons
- Advanced preferences
- High DPI
- Pick Yes (for scale resolution)
Alternative solution:
- set your screen resolution down to 1080p on your local pc
Alternative 2 (and really poor solution):
In virtual desktop:
- control panel
- search mouse
- Click change how mouse moves
- display pointer trail and set to as slow as possible
For me, at least, it was an issue with higher resolutions.
No messing with driver versions or anything like that.
Journeyman III

Hello AMD support,

You have worst Graphic driver in History. The mouse pointer is disappearing on white background. I can't work on my Virtual PC since the situation there is even worst. This issue persist almost one year. Are you planning to update your driver. When can we expect the issue to be resolved ? In case you don't plan to do that please stop provide your services.

Very unsatisfied customer.

With the latest update claiming to have resolved the issue, it hasn't. At this point I'm going to count my losses and never buy a product with AMD chip again. Intel only from now on. I'll let my kids have this computer.