Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Installing SATA RAID driver to existing Windows 10 when not in RAID mode

So I recently decided to upgrade to the Threadripper series, getting the 1900 and an Asus Prime X399-A to go with it.

Now on my old motherboard, I had 4 SATA HDDs in RAID 0 and then my SATA SSD as the main OS drive. The old motherboard luckily had only 4 of the SATA ports capable of RAID, the fifth was held out of RAID configuration.

This new motherboard does not appear to have that lucky setting - either all drives are in RAID mode (though not all need to be in a RAID, of course), or all drives are not.

So I tried to boot Windows after configuring the RAID 0 on the other four drives and, lo and behold, Blue screens "Inaccessible Boot device"

Pulled the SSD over to the old motherboard and attempted to enable Safe boot before bringing it over, to see if I could safe boot with RAID mode on - turns out, I could not.

So I switch it back to AHCI and boot Windows, YAY.

I go to download the SATA RAID drivers from the AMD chipset drivers page for the x399, and when I run the installer... it only shows my display drivers (wut?).

Then I download the actual chipset drivers and display drivers and download and install them and reboot, then try the SATA RAID driver installer again, and its a no-go, still only gives me options for display drivers.

So here's what I need - I need to be able to install the SATA RAID driver for my x399 without the system being in RAID mode. Or some workaround that gets that same thing done.

I am desperately trying to avoid reinstalling Windows just to have the RAID driver installed from the start, and I'd rather not do a software RAID (Windows "Striped Volume").

Do we have any suggestions or things that I can do to get this done?

10 Replies
Community Manager

What system specs were you using previously in which you had a Raid setup?


Motherboard was an ASRock 990FX Extreme 3. The way it worked, while four of the five SATA ports were in RAID mode, the fifth port was still in AHCI mode.

SanDisk Ultra II 256GB SSD - Windows 10 OS, GPT with UEFI boot

4x Seagate ST32000646NS 2TB HDDs - RAID 0

I set it up with a similar process of how I'm doing this one. By that, I mean Windows was already installed on the harddrive and the system was in AHCI mode, then I switched it over to RAID mode in BIOS, configured the RAID on my other 4 drives, and booted into Windows. Was able to install RAID driver afterwards, but the RAID volume itself was even available for access before having the driver. (and no, Windows didn't get a chance to download the driver before I checked if it was usable).

But for this one, it doesn't keep any specific ports out of RAID mode, and there's no way to individually set ports in AHCI mode while others are in RAID mode. So although the four 2TB drives will be in the RAID, the SSD with the OS on it will not be - but the board still puts it in RAID mode causing the Windows boot loader to fail to actually load Windows, resulting in a stop.

My issue is, without the board in RAID mode, the SATA RAID driver installer doesn't give the option to install the driver preemptively.

With the board in RAID mode, I can't boot into Windows.

Journeyman III

Hi.  Looking at the manual you're right - all raid mode or not at all (chapter 4.1.3) And probably because the RAID drivers aren't booted by default unless installed in Raid mode it isn't working.  Not got this board so assuming some things but nothing here should corrupt anything - i'd backup first though.

First I would ensure that my BIOS is up to date or at least version 0503.  unpack the intel drivers onto your boot drive somewhere.  Then shutdown, unplug all your raid drives.  Change BIOS / PCH config to AHCI and boot into windows.  Then try the steps here -​ I know it's for ATA to AHCI but its the same process for raid.  Hopefully should force the basic Raid drivers on.

If doesn't work can try uninstalling the AHCI SATA drivers from controllers in dev manager before going into safe boot.

Or while in safe mode device manager-click top item (computer) on the right- Action-Add Legacy HW-next install manually- have disk and select the intel chipset raid drivers. reboot as per the ms article.  Possibly a repair or  2 is needed after rebooting.   Good luck


BIOS shipped 0503, the newest they have available is 0601, which I can try to update to, to see if that changes anything, but that doesn't seem to have much impact on RAIDs.

As for the kb article, Step 9 never succeeds. After proceeding through 1-7, after changing the mode to RAID on step 8, the next boot into Windows (any safe mode level) gives the same stop code of "Inaccessible Boot Device".

And as for attempting to manually install the SATA RAID drivers - Looking through the directory of literally over a dozen INF files... C:\AMD-RAID\AMD-Chipset-Drives\Package\Drivers\SBDrv\ - everything in the "Bolton\" and "hseries\" subfolders error that they are incompatible with the system (even the ones labeled WT64A\ - Windows 10 64bit).

There are two other subfolders to SBDrv\ - RAID_NVMe\, and RAID_BR\. I'm not using NVMe drives (and I did make sure to download the "SATA only" version of the installer), so I assumed RAID_BR\ is the one I'm looking for. That has 3 subfolders. RAID_bottom\, RAID_cfg\, and RAID_driver\. In the latter two, cfg and driver, they each have "W7\" "W764A\" and "WT64A\" folders, each containing an INF file, SYS file and others. Attempting to add legacy drivers with the W*64A\ folders does not error that it is incompatible, however it doesn't load up a device to select to continue installing drivers. The ONLY one that did is in the "RAID_bottom\WT64A\" folder, which gave me the "AMD-RAID bottom device" driver - upon clicking "next" to start installing it, and almost immediate blue screen.I unfortunately didn't get the specific stop code, and I can't even get it from event viewer... "The system could not sucessfully load the crash dump driver" (yes, it is literally misspelled in the event viewer).

And yes, for the sake of it, I tried changing it over to RAID mode to see if that driver would have worked, it did not.

So after a brief system restore to remove that driver, with the assistance of a Win10 installation flash drive... We're back to the start where the OS will not boot when the controller is in RAID mode, and I can't install the RAID driver while it is not. As much as I don't want to deal with the overhead of having a software RAID, it's looking like that may be my best option.

It's not like the system cannot handle it; it's primarily a gaming PC so the Threadripper 1900x might be a tiny bit overkill, but the idea was to future-proof it.

Adept I

For anyone else experiencing this catch 22, this method worked for me: 

  1. Clone your OS to an NVMe drive.
  2. Turn on RAID mode in BIOS
  3. Boot the OS and install the drivers for all of the missing devices via Device Manager (It will require all of the SATA only RAID driver files mentioned in the above post)
  4. Clone the updated OS back to the SATA drive (it will now boot properly, potentially even if it is not the first listed RAID device [My disc is GPT with an EFI boot partition])
  5. Secure-wipe the borrowed NVMe drive, return it, and hope nobody notices it was gone.

Probably the easiest work around would be to have an add-in SATA card on hand, but I didn't, so I used the spare NVMe drive.

Adept I

I know I'm late to this, but I ran into this exact problem, upgrading from a Gigabyte GA-890FXA-UD5 (from around 2010).  It also allowed setting some of the ports to be RAID while leaving the others as plain SATA.

The problem is 25% chipset, 25% Windows, and 50% driver installer stupidity.

1. Windows: Requires that the specific drivers for your disk device be installed and registered as "boot-start".  See Installing a Boot-Start Driver - Windows drivers | Microsoft Docs for more details.  This is where the INACCESSIBLE_BOOT_DEVICE error comes from.

2. Chipset: The newer AMD RAID chipsets inexplicably removed the feature that allowed splitting the SATA ports between RAID and plain ATA/AHCI.

3. Driver installer: The installer package refuses to install and register the RAID drivers unless it can already see the RAID devices in the device manager.  So you can't pre-install the drivers before switching to RAID mode.

So that's how you get the catch-22.  You can't boot with the RAID feature enabled until you install the drivers, which you can't do until you enable the RAID feature.

I tried an insane number of things to get it to work, but in the end I bought a cheap, generic SATA card for $20.  I hooked my boot drive to it, switched the firmware to enable RAID, and booted.  The system came up, and immediately detected the new RAID feature and I could install the drivers.  Shutdown, clone the drive over to the RAID volume, remove the RAID card, reboot, and everything was working (regarding the RAID).

However, if you're doing this on an older MBR disk, then be warned you will be in for a world of pain, because Windows does NOT like booting UEFI from MBR disks.  You will have huge problems with Windows Update not working.  I eventually figured out how to fix this, but it was a huge PITA requiring lots of low-level fiddling with Windows.

Even if a year has past, g051051's solution worked for me (keep reading, it goes beyond that). I ended up on this thread  after a lot of searching online while I was trying to use the built-in RAID function on my new Ryzen system (Asus prime B450 chipset MoBo) for 2 storage HDD's that I use. I upgraded from an older system (2012) that had the ability to split the SATA ports in AHCI and RAID and used the RAID without any problems. After the upgrade, I faced the same problems as all the users in this thread did but managed to boot in Windows 10 in RAID mode following the g051051's instructions (you rock!). Everything seemed ok but I soon noticed that since all Sata ports being in RAID mode, all the diagnostic software that I have for the disks don't work... I use a Kingston SSD as the boot drive and the Kingston SSD Manager software doesn't recognise it when booted in RAID mode (no more firmware upgrades or diagnostics). Other software cannot recognise any of my other disks too. Because of that, I didn't proceed in building any arrays (the target was to have a RAID1 on my storage disks) AND ALSO because of the complexity of the RaidXpert 2 software (or utility in the bios). All previous utilities or software for RAID configuration that I used (built in or external RAID controller) were pretty intuitive, you could setup in minutes without needing any help. This thing is a mess... Long story short, I ended up switching back to AHCI and ordered another RAID controller (the first one I gave away so...) to do my job. That's it. Stay safe.


Unfortunately, the way hardware RAID works it'll be the same problem for your new RAID card.  They completely hide the underlying volumes from the OS and just expose the "synthetic" drives.


I agree that hardware RAID has that effect but in my case mirroring in RAID1 is fulfilling the purpose of data integrity, even if I don't have individual software diagnostics to report potential errors or malfunctions on the disks. RAID will alert me (I suppose). Have you ever tried the software based (windows 10) RAID1? I researched a bit and except from the need to convert your partition to dynamic and the overhead on your system's resources, it seems to be legit. Any suggestion is welcomed at this point...


I looked into it, but didn't see that it would work on a boot device.