cancel
Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

brandibug
Journeyman III
Journeyman III

Installed 15.7.1, but it looks like no drivers are installed.

I've uninstalled, reinstalled, rebooted countless times, adjusted CCC, but no matter what, it feels as though I'm running on a random driver that Windows gives you when you don't have an actual graphics driver installed. My font looks weird, games look bad and run like I have a crap graphics card. I can't get any help on it. Any solutions?

0 Kudos
9 Replies
ckirchner
Adept II
Adept II

Re: Installed 15.7.1, but it looks like no drivers are installed.

Hi,

I had the same problem with my HD 7970 (received SYSTEM_THREAD_EXCEPTION_NOT_HANDLED by atikmpag.sys) and now found a solution:

1. Uninstall Lucid Virty MVP (if installed). This is usally active, if you upgraded to Windows 10 from Windows 8.1.

2. Install the AMD 15.6 Beta Driver for WIndows 8.1 from June22 "amd-catalyst-15.6-beta-software-suite-win8.1-64bit-june22".

Now your graphics adapter will be detected correctly and everything works fine.

The latest driver 15.7.1 is not working with my card and even after the solution, cannot be installed as Windows 10 tells me, that it is not suitable for this platform.

0 Kudos
brandibug
Journeyman III
Journeyman III

Re: Installed 15.7.1, but it looks like no drivers are installed.

Did not work :\

0 Kudos
shovon
Adept II
Adept II

Re: Installed 15.7.1, but it looks like no drivers are installed.

Try the previous version of Catalyst or Check the device manager to find out if your graphics drivers are installed properly

0 Kudos
brandibug
Journeyman III
Journeyman III

Re: Installed 15.7.1, but it looks like no drivers are installed.

I'm not sure how to check if it installed properly, but I have 15.200.1062.1002 for graphics driver :\

0 Kudos
backFireX64
Forerunner
Forerunner

Re: Installed 15.7.1, but it looks like no drivers are installed.

"15.200.1062.1002" is the whql display driver that is included in the latest AMD Catalyst 15.7.1 software package.

If that is already installed, then you should see additional resolution values for your monitor.

Or go through device manager -> right click mouse on display adapter -> select "update driver software" -> select "browse my computer..." -> select "let me pick from a list of...." and choose another driver if found.

Is there a chance that you are running on an integrated gpu, instead of your amd radeon ?

shovon
Adept II
Adept II

Re: Installed 15.7.1, but it looks like no drivers are installed.

That's why you are facing problems, you should roll back to the previous driver

0 Kudos
brandibug
Journeyman III
Journeyman III

Re: Installed 15.7.1, but it looks like no drivers are installed.

I have no other GPUs on this tower. I'm on the recommended resolution, 1920x1080, 60hz,

0 Kudos
brandibug
Journeyman III
Journeyman III

Re: Installed 15.7.1, but it looks like no drivers are installed.

I just tried that and because I uninstalled and reinstalled 15.7.1, the rollback did nothing.

0 Kudos
shovon
Adept II
Adept II

Re: Installed 15.7.1, but it looks like no drivers are installed.

Why did you re install the driver? I just asked you to use the previous version of the driver

0 Kudos