Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Journeyman III

Re: Installation of AMD chipset driver failed (Error 1603)

Thanks your advice helped me get past this issue.

I suspect AMDs drivers can't overwrite the previous version AND the installation attempt of the new version wipes out the previous installation files in C:\AMD\Chipset_Driver_Installer\ which then gets you in a state of being unable to use add/remove to uninstall the previous drivers which lets you upgrade.

To get my install fix this is what I did. I wanted to avoid any regkey editing manually or with third party tools


1. Delete C:\AMD\Chipset_Driver_Installer\ which would have been corrupted when attempting to install the current release (

2. Run the installer for the previous version you had installed. For me this was I had kept a copy locally, but if you didn't you can grab it here  The AMD installer will likely fail or not do anything. But by running the old installer it will put the files needed back in C:\AMD\Chipset_Driver_Installer\. 

3. now that you have the old files back. The uninstall will work. Run the .msi version of the installer located at C:\AMD\Chipset_Driver_Installer\ChipsetDriversExtract\MSIFiles\Packages (<-- I think that's it, not looking at it now). The install will have a “remove” option in the wizard to uninstall. 

4. Once you run the uninstall. To ensure a clean install in the next step, I deleted C:\AMD\Chipset_Driver_Installer

5. Now that you have removed the old version, you can now reattempt the new version. This time it should work

Adept I

Re: Installation of AMD chipset driver failed (Error 1603)

Just for the record, let me say that after facing the same issue with the latest AMD drivers ( I finally tried the approach with their installation from a new local account and it worked. The root cause for the original issue remains unknown to me. However, the fact that both accounts run on the same OS and in one case the installation works and in the other one it fails with an unclear and misleading message points to a problem with the installer, not with the OS. They should be more careful how they test their software.

Journeyman III

Re: Installation of AMD chipset driver failed (Error 1603)

Thanks man. This really works. I created this account to give my thanks to you. You really saved my day.

Journeyman III

Re: Installation of AMD chipset driver failed (Error 1603)

So for future reference for anyone who tried everything in here and nothing worked like me, I found a new solution.

1. After I ran the old chipset installer (this was after deleting my chipset drivers with windows uninstall tool) and it failed I poked around in the amd folder and noticed there was a folder containing all the drivers which is located in this pathway "C:\AMD\Chipset_Driver_Installer\AMD_Chipset_Drivers\IODriver" (without quotes).

2. There is where you will find all of the necessary chipset drivers to install and I installed them all manually using the installer file located in each of their respective folders (gpio2, pci, psp, smbus).

3. Then I located them in device manager and manually updated the driver by manually locating the folder where it installed each specific set of drivers when prompted by device manager and updating.

4. Then I ran the old chipset installer and to my complete surprise... it worked!

5. I decided to run the new chipset installer just to see if it would fail again... it didn't, everything installed correctly!

Honestly I have no idea why this worked but all the correct devices and drivers are installed in the device manager and all the chipset files are back when I run the microsoft install and uninstall tool. This is especially shocking because amd said on their website to delete the old chipset (without telling you how to do it, other than running their uninstaller built into the chipset installer which was not on my pc for some reason).

Journeyman III

Re: Installation of AMD chipset driver failed (Error 1603)

Was getting error "Unable to install AMD chipset drivers. System configuration is not compatible for RAID drivers or application installation. A system update is required to complete the installation."


I tried everything I could think of before I came across this simple solution... Kind of happy since next step was formatting...


Installing from a different windows profile is the solution, still not sure what profile-specific setting is causing the issue for my main one... Just created a local admin account, logged with it and installation went through without a hitch! Oh well, until the next update I guess /shrug #amdthings

Tags (1)
Journeyman III

Re: Installation of AMD chipset driver failed (Error 1603)


Still nothing fixed.

It's nice that one of the newest and major chipsets has a wrecked driver installer.


Journeyman III

Re: Installation of AMD chipset driver failed (Error 1603)

Hello I am experiencing performances issues with my computer.
I think its linked with the windows 11 bug ...
So I have read that the new amd drivers fix this my computer is already running the latest update from microsoft : Kb5006746.
But the amd drivers fails to install ... (From this link
My configuration ;

AMD Ryzen 7 5800X
Asus ROG X570e
Asus ROG RTX3080
Crucial 16 GB DDR4
500Gb Samsung 980pro & 1Tb Seagate
Corsair 850w Gold

And ofc (windows 11 pro)

I have read in the log near the end Error 1308 then Error 1603 at the end of the file.

What I have tried ; uninstalling all driver, using the ms program install diag, using amd cleanup tool, using new administrator session, turned off ms defender and ms firewall.
Nothing worked ...
Can you help me please ?

Journeyman III

Re: Installation of AMD chipset driver failed (Error 1603)

been at it for half a day and could not find a solution till your solution. Microsoft troubleshoot you had attached solved my issue. thank you so much mate