Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Journeyman III

Installation of AMD chipset driver failed (Error 1603)

AMD Ryzen 3700X and Gigabyte X570 I AORUS PRO WIFI

Installation success or error status: 1603.

I have attached the log file.

67 Replies
Journeyman III

After eventually getting the chipset drivers to install without error I suffered from games and other intensive applications failing regularly. Rather than remove the latest drives I restored my OS partition using a previous working backup. All is now OK.

You may find that getting the drivers to install is the start of your problems.

Thanks for the report. That's what I was worried about with this chipset version. Once I am absolutely sure one thing is broken (installer, verified by others and my 5-6 attempts), how do I know other things are not also broken? (And those are much more difficult to find, test, may take while to be reported). I would not trust it, at least not until official explanation. Previous version is fine.

However, I always avoid "restore" as well. Absolute last resort for me, before OS reinstall. Recommend uninstall chipset (or all AMD drivers, plus cleanup) and install previous version.

Journeyman III

To solve the PCI device driver problem which caused the entier AMD chipset driver not installed:

Check your log you will probably see something like this:

MSI (s) (04:E8) [15:51:59:256]: Product: AMD PCI Driver -- Error 1309.Error reading from file: C:\Users\[UserName]\AppData\Roaming\AMD\Chipset_Driver_Installer\AMD_Chipset_Drivers\{2457B349-20D8-423A-B291-CD885B9108A1}\IODriver\PCI\PCI Driver\W7x64\dpinst64.exe.  System error 3.  Verify that the file exists and that you can access it.

But the driver package actually uncompress the files into C:\Users\[UserName]\AppData\Roaming\AMD\Chipset_Driver_Installer\AMD_Chipset_Drivers\{2457B349-20D8-423A-B291-CD885B9108A1}\IODriver\PCI\PCI Driver\WTx64

If this is the case, just rename the folder name back to W7x64 and run the installer again.

And after driver installed, you can remove the entire Roaming\AMD\ directory.

Journeyman III

I just tried to install the last chipset drivers ( and it failed (i am on windows 10 2004)

I looked at the installed logs and found a lot of errors like this.

MSI (s) (D0:74) [10:50:21:589]: Folder is not accessible: C:\Users\[YOUR_ACCOUNT_NAME]\AppData\Roaming\AMD\Chipset_Driver_Installer\AMD_Chipset_Drivers\{2457B349-20D8-423A-B291-CD885B9108A1}\IODriver\PCI\PCI Driver\W7x64

I looked at the installed files and the directory was named WTx64 instead of the W7x64 the setup was looking for (inside, i found all the files the setup was missing).

Steps to fix :

1 - Run the installer once (let it fail)

2 - go the directory (use your user account name for [YOUR USER ACCOUNT] )

C:\Users\[YOUR USER ACCOUNT]\AppData\Roaming\AMD\Chipset_Driver_Installer\AMD_Chipset_Drivers\{2457B349-20D8-423A-B291-CD885B9108A1}\IODriver\PCI\PCI Driver\

3 - Rename WTx64 to W7x64

4 - Run the installer again, it should complete successfully.

PS: I copied the above from another place. It worked with me, without the hassle of removing nor adding drivers.

unfortunately this didn't help

Adept III

I'm trying to install AMD Chipset Drivers
Anyone found a solution for the following error message please ? I do not have a RAID setup at all.

System configuration is not compatible for RAID drivers or applications installlation.

My system :

  • Windows 10 Pro v2004 (may 2020 update)
  • AMD Ryzen 7 3800XT
  • ASUS ROG Strix X570-E Gaming (BIOS v2606)
  • AMD Radeon RX 5700 XT (Sapphire Nitro + Special Edition)
  • AMD Radeon Software v20.8.2
  • AMD Ryzen Master v2.3.0.1591

Please help !

Adept I

I have exactly the same problem and no solution yet. Now I am just waiting for the next drivers version hoping to be more lucky next time.

Have you used AMD CleanUp utility or Display Driver Uninstaller (DDU) before trying to install the AMD Chipsets Drivers?

I'm starting to think DDU is what broke my chipset driver installation.


as far as I am aware, DDU doesn't delete any Motherboard drivers. Only the Graphics and Audio drivers from your GPU card and its related software.

As for the RAID error it is possible you have some BIOS Setting set to RAID. Like changing SATA AHCI Controller to RAID Controller in BIOS.

Check Device Manager and see if you see any RAID drivers installed.


Thanks for the hint but I checked in the BIOS - SATA Mode is set to AHCI, not RAID (which is the alternative option). Also, I cannot find anything suspicious in Device Manager.

I didn't uninstall the previous version of the chipset drivers since I am afraid that this could lead to more issues. At least, my system is stable now and I could live with the older drivers for a few months more.

What find as a little bit puzzling is that there is no sign from an AMD representative in this discussion to tell us whether they are taking our issues into account and whether they are planning to address them  It looks as if we have been completely forgotten.


Can not speak for the Moderators, but they are aware of all threads here at AMD Forums. If they feel it is a bug they probably already advised the dept. in charge of Chipset drivers about the issue.

But the best way to let AMD Support know is by having Users open a AMD Service Request (Official AMD Support).


shenny79elstacichucktownrc51 masu amdmatt

I've found the only working solution for this problem so far !

Sadly, it's probably not the most efficient solution, but you'll have to format your Windows drive (OS drive, usually your SSD / NVMe drive) and start afresh with a spanking brand new Windows installation. Please note that you can't keep your apps and settings, I tried and if you do keep your apps and settings, you'll be stuck with the same error message when you try to install the AMD Chipset Drivers again.

Here's what I tried before going all-in by formatting my PC, which wasted tons of time, and did not work at all in the end :

  • Re-installed Windows 10 (while keeping personal files, apps and settings)
  • Flashing BIOS to older version (v2408 - ASUS ROG Strix X570-E Gaming)
  • Flashing BIOS to latest available version (v2606 - ASUS ROG Strix X570-E Gaming)
  • Loaded optimized default BIOS settings (press F5 and then Save & Reboot for ASUS motherboard)
  • Uninstalled AMD Chipset Drivers
  • Uninstalled AMD Radeon Adrenalin Software
  • Uninstalled AMD Ryzen Master
  • Ran Display Driver Uninstaller (latest version) in SAFE MODE
  • Ran AMD CleanUp Utility (latest version) in SAFE MODE
  • Manually deleted the following folders and files :
    • C:\AMD
    • C:\Program Files\AMD
    • C:\Program Files (x86)\AMD
    • C:\Users\[your username]\AppData\Local\AMD
    • C:\Users\[your username]\AppData\LocalLow\AMD
    • C:\Users\[your username]\AppData\Roaming\AMD
    • C:\Users\[your username]\AMDRM_Install.log
    • C:\Users\[your username]\AMD_RyzenMaster.log
  • Manually deleted every AMD related keys, strings & values from the Windows Registry (regedit.exe) that I could find.

Needles to say, the next time i'm facing an issue with AMD driver i'm not wasting a second trying to fix it, i'm formatting immediattly. Took only 8 minutes on my NVMe SSD to format / install windows. I wasted a good 10 hours trying to fix it prior end, which was a complete waste of time.


I am not so much concerned with the re-format and fresh installation of Windows as with the following fresh installation of drivers, applications, games, etc. It usually takes me half a day to complete all the usual stuff. I am running on SATA SSD, not NVMe but I doubt that this would save me much time anyway.

Besides, running drivers that are a few months old is not that critical issue for me to make me waste hours in re-installing, etc. just because of a buggy installer (no thanks to AMD). In fact. I have noticed that some of the default Microsoft drivers date as far back as 2009 but this does not prevent me from running a stable system.


Agreed, shenny79. I would not fresh install Windows for something like this, due to time required to setup apps as you explained. (That is a final, nuclear option IMO.) The previous chipset driver (2.04) installs and works fine. (If 2.07 won't uninstall, that's fixable, see my post above.) I also disagree with epsilons that DDU or AMD Cleanup is a problem, but obviously it should only be used with patience and care (and when full driver uninstall is needed).

That said, AMD really should have pulled this 2.07 driver and released a quick fix focused on installer. Disappointed this driver is still available, as it's no doubt causing problems for more and more people every day.

Adept II

Any fix for this yet?  These software issues are getting old AMD. 

Journeyman III

None of the solutions floating around the internet worked for me. I decided to do some digging and just start clicking on things because I figured I couldn't make it any worse and was confident I could fix anything I screwed up.
I eventually stumbled upon a utility that shows up after you run the initial extraction of the driver installer. In C:\AMD\Chipset_Driver_Installer\ChipsetDriversExtract\MSIFiles\Packages is an application called "AMD_Chipset_Drivers" that will fully uninstall any currently installed chipset drivers.
After running the utility, select the remove option, click next, click remove, let it do it's thing and restart after it's done.
My install went without a hitch after this.

I too tried that, but unfortunatly it did not work out for me. The utility told me I had "no chipset installed" so nothing can be uninstalled using that utility. In the end, the only solution that worked for me was to format my PC...

I'm pretty sure DDU has something to do with the issue I had because I used it after having trouble updating to Radeon Software v20.8.2 and this is exactly at that moment that my Chipset Driver started to refuse to install.

My recommendation would be to avoid using DDU and AMD CleanUp utility at all cost. Never use those app. Trust me, just dont. They were created with good intention, but I don't think the people behind them have full knowledge of what they delete in the windows registry and all that stuff, ending up creating more problems than solution. Not the first time I have issue after running DDU or AMD CleanUp utility. Never again.

(see this reply : )



Thanks for your solution!

To anyone still reading this thread: I managed to install the new chipset drivers by creating a local Administrator user in Windows 10. Log out from your original user account, log in to the new one and install the chipset drivers.


Was getting error "Unable to install AMD chipset drivers. System configuration is not compatible for RAID drivers or application installation. A system update is required to complete the installation."


I tried everything I could think of before I came across this simple solution... Kind of happy since next step was formatting...


Installing from a different windows profile is the solution, still not sure what profile-specific setting is causing the issue for my main one... Just created a local admin account, logged with it and installation went through without a hitch! Oh well, until the next update I guess /shrug #amdthings


I want to confirm that this worked perfectly for me.

Thank you for sharing results!!


Thanks your advice helped me get past this issue.

I suspect AMDs drivers can't overwrite the previous version AND the installation attempt of the new version wipes out the previous installation files in C:\AMD\Chipset_Driver_Installer\ which then gets you in a state of being unable to use add/remove to uninstall the previous drivers which lets you upgrade.

To get my install fix this is what I did. I wanted to avoid any regkey editing manually or with third party tools


1. Delete C:\AMD\Chipset_Driver_Installer\ which would have been corrupted when attempting to install the current release (

2. Run the installer for the previous version you had installed. For me this was I had kept a copy locally, but if you didn't you can grab it here  The AMD installer will likely fail or not do anything. But by running the old installer it will put the files needed back in C:\AMD\Chipset_Driver_Installer\. 

3. now that you have the old files back. The uninstall will work. Run the .msi version of the installer located at C:\AMD\Chipset_Driver_Installer\ChipsetDriversExtract\MSIFiles\Packages (<-- I think that's it, not looking at it now). The install will have a “remove” option in the wizard to uninstall. 

4. Once you run the uninstall. To ensure a clean install in the next step, I deleted C:\AMD\Chipset_Driver_Installer

5. Now that you have removed the old version, you can now reattempt the new version. This time it should work

Thanks man. This really works. I created this account to give my thanks to you. You really saved my day.


So for future reference for anyone who tried everything in here and nothing worked like me, I found a new solution.

1. After I ran the old chipset installer (this was after deleting my chipset drivers with windows uninstall tool) and it failed I poked around in the amd folder and noticed there was a folder containing all the drivers which is located in this pathway "C:\AMD\Chipset_Driver_Installer\AMD_Chipset_Drivers\IODriver" (without quotes).

2. There is where you will find all of the necessary chipset drivers to install and I installed them all manually using the installer file located in each of their respective folders (gpio2, pci, psp, smbus).

3. Then I located them in device manager and manually updated the driver by manually locating the folder where it installed each specific set of drivers when prompted by device manager and updating.

4. Then I ran the old chipset installer and to my complete surprise... it worked!

5. I decided to run the new chipset installer just to see if it would fail again... it didn't, everything installed correctly!

Honestly I have no idea why this worked but all the correct devices and drivers are installed in the device manager and all the chipset files are back when I run the microsoft install and uninstall tool. This is especially shocking because amd said on their website to delete the old chipset (without telling you how to do it, other than running their uninstaller built into the chipset installer which was not on my pc for some reason).

Journeyman III

I noticed that Gigabyte recently added AMD Chipset Driver v 2‎.07.21.306 dated 2‎020/08/11 on their support page for the Aorus X570 Master series. These have installed without issue and all seems stable since.

You may want to check your motherboard manufacturer's site and check if they provide their 'own' chipset driver.

Adept II

What worked for me.

1. Try to install normally. Will error out.

2. Navigate to folder c:\Users\YourUserName\AppData\Roaming\AMD\Chipset_Driver_Installer\AMD_Chipset_Drivers\

Inside there is an executable AMD_Chipset_Drivers.exe 
If unable to locate, maybe enter the subfolder named {2457B349-20D8-423A-B291-CD885B9108A1}

3. Run AMD_Chipset_Drivers.exe and select to remove all drivers. No reboot required.

4. Try to install again = Success

Everything else involving deleting folders, checking for updates or even own AMD cleanup tool is pure BS.

Adept I

Just for the record, let me say that after facing the same issue with the latest AMD drivers ( I finally tried the approach with their installation from a new local account and it worked. The root cause for the original issue remains unknown to me. However, the fact that both accounts run on the same OS and in one case the installation works and in the other one it fails with an unclear and misleading message points to a problem with the installer, not with the OS. They should be more careful how they test their software.

Journeyman III


Still nothing fixed.

It's nice that one of the newest and major chipsets has a wrecked driver installer.



Hello I am experiencing performances issues with my computer.
I think its linked with the windows 11 bug ...
So I have read that the new amd drivers fix this my computer is already running the latest update from microsoft : Kb5006746.
But the amd drivers fails to install ... (From this link
My configuration ;

AMD Ryzen 7 5800X
Asus ROG X570e
Asus ROG RTX3080
Crucial 16 GB DDR4
500Gb Samsung 980pro & 1Tb Seagate
Corsair 850w Gold

And ofc (windows 11 pro)

I have read in the log near the end Error 1308 then Error 1603 at the end of the file.

What I have tried ; uninstalling all driver, using the ms program install diag, using amd cleanup tool, using new administrator session, turned off ms defender and ms firewall.
Nothing worked ...
Can you help me please ?