cancel
Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

akula
Journeyman III

Installation of AMD chipset driver 2.07.14.327 failed (Error 1603)

AMD Ryzen 3700X and Gigabyte X570 I AORUS PRO WIFI

Installation success or error status: 1603.

I have attached the log file.

67 Replies
rolacka
Journeyman III

Also having this issue windows is fully up to date as are all other drivers but this gives the 1603 error no matter what I try.

Asus Rog Strix X570 - F Gaming.  3800X

Win10 Pro x64 2004 

0 Likes
kingfish
Volunteer Moderator

evol
Adept I

I have the same problem with my MSI B450M Mortar and Ryzen 3600. Instructions from AMD's document about 1603 error didn't help. AMD please fix.

0 Likes
mikes3000
Journeyman III

Same problem here.  Gigabyte x570 Aorus Pro Wifi and Ryzen 3900x.  I recently upgraded to Windows 10 2004.  I have never had a single chipset installation failure since I build the system a year ago.  I get failures on trying to install this version as well as attempting to reinstall the previous version.

0 Likes
mikes3000
Journeyman III

Ok, I found a solution.  Maybe my update to Windows 10 ver. 2004 messed something up.  I went to add/remove programs.  Turn windows features on or off.  Uncheck .Net 3.5 and .Net 4.8.  Allow it to uninstall.  Reboot.  Go back and check both boxes.  Let the software download what it needs and install.  Reboot.  Try to install latest chipset drivers.  PROFIT!  I hope this helps someone fix their system.

seems like in your case you had a corrupt Windows Update concerning .Net installation.

0 Likes
xela
Adept I

Same here ”installation failure 1603”

Crosshair VI Hero

3800X

Win10 Pro x64 2004 

0 Likes
elstaci
MVP

MS Troubleshooter seemed to help some other Users in installing AMD CHIPSET in the past. I have attached it to this reply so that you can download and run it.

Also delete C:\AMD CHIPSET folder that was created the first time you ran the CHIPSET Installer before running it again.

This tech site gives some basic troubleshooting methods to fix error 1603: How to Fix AMD Error 1603 - Appuals.com  (don't download "Recommended" software it is a scam but the tips are valid.)

MS Troubleshooter has fixed my problem. Thank you.

same problem error 1603 and uninstalling with "MS troubleshooter" posted by elstaci FIXED the problem...yes it works.
delete c:\AMD folder

use MS troubleshooting to UNINSTALL all the AMD tagged voices (can spare AMD ryzen master)

reboot...run amd_chipset_software_2.07.14.327.exe and install the new chipset without issues.

it also bring back the voice on installed apps&features. (previously delete due a failed installation)


don't forget to review you ryzen power plan if u touched something in there!

been at it for half a day and could not find a solution till your solution. Microsoft troubleshoot you had attached solved my issue. thank you so much mate

0 Likes
catch36
Journeyman III

How do you use the MS Troubleshooter to fix the install problem?

0 Likes

Run MS Troubleshooter hit next, then uninstalling and from the list choose amd drivers (only chipset drivers) one at a time and uninstall it. Then reboot and install the chipset package.

el_arantis
Adept III

Same problem here. I realized that in the installation folder exist very few subfolders comparing to prior versions of chipset drivers. There is no always the users to be the problem. AMD fix it

PC Specs

O/S: Windows 10 Pro x64 (latest build version with all updates)
CPU: AMD Ryzen 7 2700X
M/B: Asrock Fatal1ty X470 Gaming K4
GPU: XFX AMD Radeon RX 5700 XT THICC II
RAM: G.Skill FlareX F4-3200C14D-16GFX
PSU: SEASONIC FOCUS+ GOLD 1000W
Cooler: ZALMAN CNPS7X LED+
HARD DRIVE: SanDisk Ultra II 960GB
OPTICAL DRIVE: HL-DT-ST DVDRAM GH24NSC0
MONITOR: AOC AGON AG251FZ (1080p) DP Connection
CASE: Cooler Master N600
SOUND: Realtek High Definition Audio (ALC 1220)
SPEAKERS: Logitech 5.1
HEADSET: Creative Sound BlasterX H5 Special Edition
(Latest Drivers/BIOS/FIRMWARE for all devices)

jdoe2
Adept I

Same issue. I installed fresh Windows 10 2004 a few days ago, installed chipset drivers (the most recent at that time), everything was fine. Yesterday I noticed the new version of chipset drivers (2.07.14.327), tried to install it and it broke everything - installation failed, "AMD Chipset Software" disappeared from the list of installed programs in Windows 10, and now I can't install any version of chipset drivers - installation fails. Typical AMD...

ASUS ROG Strix B450-I Gaming, Ryzen 5 3600, all latest updates (Windows, BIOS, drivers).

el_arantis
Adept III

AMD please wake up and release a fixed version of these drivers

0 Likes
akula
Journeyman III

After using the AMD cleanup tool and retrying (and failing again) I gave up and reinstalled an older version.

0 Likes
gratefall
Journeyman III

Same issue. Instructions from AMD's document about 1603 error didn't help. AMD please fix.

0 Likes
jdoe2
Adept I

I was able to fix the issue (i.e. install chipset drivers version 2.07.14.327) by creating a new local (i.e. not connected to Microsoft account) administrative Windows user account, logging into it and installing the chipset drivers from it. After successful installation and reboot I deleted that user account.

This worked for me too, thanks!

0 Likes
programmist116
Adept I

Same problem
pastedImage_1.png
Amd ryzen 5 3600 
MSI AMD Radeon RX 580 GAMING X
Asrock Fatal1ty AB350 Gaming K4
Fresh Windows 10 2004

Help pls(

lesev
Journeyman III

Hi, I've got same problem but I've got sorted out just now. If the instalation of the new drivers remove your old chipset drivers ( as my case ) restart the system  and install old drivers again. After that go in Add/Remove programs and uninstall chipset drivers manually and restart  again. After that you should be able to install new drivers with no problem. At least thats wotk in my case. Also be sure you have deleted AMD extraction folder from previous chipset drivers. I hope that's  gonna work for some of you. 

Really needed
1) through "Uninstall or change the program" uninstall it
pastedImage_1.png
I uninstalled via the "Uninstall tool"
In the "System" section
pastedImage_2.png
2) Reboot you PC
3) Install New Driver Chipset
Perfect
pastedImage_3.png

0 Likes
williamna
Adept I

creating new user I was able to install the driver but after restart I ran into black screen  AMD please do something you are superior to this

0 Likes

did you ensure windows 10 was right up to date as i think there may be some minor issues running chipset (2.07.14.327) otherwise

0 Likes
shenny79
Adept I

I have a slightly different problem. When I try to install the newest drivers, the installer says that a system update is required before the drivers for RAID can get updated. I don't have any RAID configuration and I am running Windows 10 2004 release; Windows Update says that there are no new updates for my PC. So how can I proceed in this case?

0 Likes
kevinkitho
Journeyman III

After wasting hours trying EVERYTHING EVERYONE had suggested....I FINALLY got mine to work, (updating windows to latest, uninstalling, reinstalling various versions combos, dot.net, enable/disable airplane...Tried EVERYTHING)

Heres what worked for me; I enabled the windows administrator account, (set a password) > logged into it > downloaded and reinstalled the the last successful Ryzen chipset installer (2.01.15.2138) > made sure windows 10 version was bang up to date (2004) OS version (19041.388)> rebooted> logged into administrator account > downloaded latest version of Ryzen master (2.07.14.327) > disabled the built in windows real-time antivirus and firewall defender> ran the installer > hey presto finally installed after what 10 attempts previously! (you could also try right clicking and running as administrator too) hope this helps.

spec:

3950x 4.15ghz @1.21875v

Asus ROG Strix x570-I gaming

DDR4 3200mhz

2070S Founders Edition

Phanteks Evolve shift (mesh edition)

Arctic liquid freezer II AIO

idle temps: 46-54, Max load temp: 82

Cinebench R20: 9559, single:476

Windows 10 enterprise edition, version 2004, OS build 19041.388

el_arantis
Adept III

I think I solved the installation problem. Of course it is a patent and AMD must create a normal fix. After the installation that had the fail result, I checked the device manager and realized that the latest versions were installed without problems but chipset were missing from control panel's programs and features. What I did is the following. Uninstalled with the use of the file provided by elstaci the Ryzen power profile driver. Then I ran the install file again and I only ticked the Ryzen profile. Everything went perfect.

shenny79
Adept I

Has anybody encountered this error below? I don't even have RAID devices and I checked that I am using the latest Windows 10 build. Actually, my OS was freshly installed one month ago and I didn't encounter any issues with the previous version of AMD drivers.

pastedImage_1.png

Hey mate, have you found a solution yet? I'm facing the exact same problem right now.

Look at my reply here :

https://community.amd.com/message/2991115?commentID=2991115#comment-2991115 

0 Likes
vanon
Adept I

Same problem here. Tried the usual install over the top. FAIL. Error 1603 logged. (Repeat install and uninstall failures until adequately sad.) Still would not install after thorough driver cleaning.

Temp Fix: Install OLDER chipset drivers (like 2.04.28.626). Example: Uninstall. Preferably completely clean AMD drivers (via AMD Cleanup Utility, and DDU, in Safe Mode). Restart after every step. Install older chipset drivers. Restart some more. (Now have fun installing graphics drivers; at least they're fresh now.)

Notes: Uninstaller also broken. Uninstall failed every time (and entry remained in Settings, Apps & Features). AMD Cleanup and DDU did not fix (they don't clean chipset). To remove Apps entry: Had to install (fail) again, grab the missing "Setup.exe" and place in certain folder, run uninstaller again (fail, but did remove entry).

More notes: I'm also getting "black screen" problem every 10-60 seconds in games right now (Shadow of the Tomb Raider, Talos Principle). Started before this problem, is actually what prompted me to install latest drivers. Please fix this mess soon AMD. Or perhaps these are caused by Microsoft (build 2004). UPDATE: Seem to have solved black screen (see my post history; Basically, with HDCP disable and/or underclock). Older chipset working fine, too. Happy gaming.

Specs: AMD Chipset Drivers (version 2.07.14.327). ASUS ROG B450-F motherboard (BIOS 2501). MS Windows 10 (build 2004). Windows Security AV (temp disabled).

kingfish
Volunteer Moderator

Latest version of DDU?

https://community.amd.com/thread/250936 

0 Likes

All AMD options were checked in latest DDU. Did not fix broken entry in Apps & Features. Or fix this install problem. (Seems like DDU is claiming partial removal of chipset drivers at best?) At this point, will not touch 2.07.14 with ten foot pole, torture for my PC and I. Will wait for next version.

0 Likes
kon33
Adept I

Crazy how we have all this great hardware from AMD yet the drivers are flawed . yes flawed . 

Roll back too 19.12.1 or 19.5.1 satble . 

use DDU latest . !

Used device manger uninstall . !

delete AMD folder with ever uninstall reboot system after . !

Gone back to intel  .

Thats right two weeks of mucking around with drivers to get a Ryzen new build up and running vega64. 

Sent all the AMD hardware back except Vega64 as it works on intel motherboard . 

0 Likes

The magnitude of this problem is not nearly enough for me to give up and support companies like Intel (or Nvidia). Most driver versions work very well (about 4 of 5, in my many years with AMD), but of course some have problems. This is one of the more obvious ones. It's complicated. I can forgive the occasional screw-up. That said, it is critical that they have the competence to solve the problems that occur in a timely manner, and AMD has not let me down in that regard. I would be surprised if this was not solved by the next chipset driver (under a month).

0 Likes

Actually, since I switched from Intel to AMD in March, the average waiting time for a new driver is about two months (for example, the previous version was released around June 5th). So we would be lucky to get new drivers before the end of September.

0 Likes

Fair enough. I think for something like this, a quicker "hotfix" would be released. Either way, as long as previous release is working fine, I don't have a big problem. Next release needs to be solid though, or credibility is lost (and customers).

0 Likes
jdmpower
Adept I

Wait next driver, don't touch anything.Same as problem on F21 X570 Aurous Ultra

0 Likes
uzverlogin
Journeyman III

You can try to install Power Plan, both GPIO, PSP and SMBus for now.

Bug is in "AMD PCI Device Driver" installation. But according to Release Notes https://www.amd.com/en/support/kb/release-notes/rn-ryzen-chipset-2-07-14-327 this driver is old one.

pastedImage_1.png