cancel
Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Highlighted
Adept I
Adept I

impossible to install RAID DRIVERS / RAID EXPERT 2 with OS installed on an NVMe drive

I get this error:
OS is booted onto the NvMe volume and upgrading the driver will make the drive
unbootable, so aborting the installation.please load OS on Non-NvMe drive and continue
with driver installation.

error-chipset.jpg

When trying to install the Windows 10 64-bit RAID drivers on a number of different motherboards with AMD Chipsets.

I was trying to setup a SATA RAID ARRAY on two of these computers.  I Also tried setting up an NVMe M.2 Array on one with similar issues, I couldn't get windows setup to detect the drives regardless of which driver or what order I added them.

I ran into this problem on these motherboards listed below but if you search the error message above you will see that it is happening across the board on many boards.

Boards I have experienced this issue with both a year ago and remains unresolved:

ASUS X399 Zenith Extreme

ASUS ROG STRIX B450-F GAMING

Gigabyte X399 AORUS Gaming 7


Other people having the same issue left & right:
https://rog.asus.com/forum/showthread.php?98829-Can-t-Update-Chipset
https://community.amd.com/thread/230353
https://community.amd.com/thread/232871

https://community.amd.com/thread/232861

https://community.amd.com/thread/237720
https://community.amd.com/message/2870049

https://community.amd.com/thread/233788

Some details:  Windows 10 is installed on an m.2 NVMe drive just as a single drive, not RAID.  The m.2 slots are not configured for RAID in the UEFI.  I wanted to experiment with m.2 based RAID on my Zenith Extreme but I didn't mess with it after this was such a nightmare and haven't been able to get even SATA RAID working.

I am simply trying to get the RAID drivers installed for the SATA RAID array.  Thank you for your time & help in this matter.

The error is accurate:  If you try and manually install the .inf file the system will not boot.

Note: I have tried installing the driver during windows installation but then it doesn't see the M.2 drive and I cannot proceed with the install.

Note:  I am running into this issue using Windows 10 64x Version 1903 (OS Build 18362.175).  Obviously, when I tried this a year ago it was on an earlier version, I think 1709 but I'll have to double check.

Note: I updated the BIOS on all motherboards to the latest version for each.

Tags (1)
2 Replies
Highlighted
Journeyman III
Journeyman III

Re: impossible to install RAID DRIVERS / RAID EXPERT 2 with OS installed on an NVMe drive

Windows 10 1903 OS installed on NVME not using Raid, with 3 SATA HDs in raid used for storage.

I also couldnt get the raid drivers to install.  I did manage to get the INF files to install successfully, but the OS wont boot now because the NVME appears mistakenly recognised as LEGACY mode.  I now have to click to continue to boot but at least i can get her to load Windows 1903 and my raid drive works.

So why is my NVME drive appearing as LEGACY?  And how do i get my PC to stop prompting to continue to boot because of the mistaken offline LEGACY NVME array which doesnt exist?

0 Kudos
Highlighted
Adept I
Adept I

Re: impossible to install RAID DRIVERS / RAID EXPERT 2 with OS installed on an NVMe drive

I have same problem after upgrading my system with latest RAID drivers 9.3.0.38.

It worked perfectly with prev version (think 9.2) but after upgrading to 9.3, cause of 1909 update, I can only see SATA RAID drives but my second NVMe is invisible (I can boot from first NVMe).

Solution for this is to enable NMVe RAID in BIOS!

But, after enabling NVMe RAID in BIOS (besides my second NVMe being recognized as Legacy - I have no RAID on NVMe) its speed dropped 50%!!! Without RAID I was getting 3400 read with RAID enabled in BIOS I get 1400 !!!!!!

Also, it looks that my two SATA drives in RAID are very slow (also with prev RAID drivers).

0 Kudos