cancel
Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

WellDone
Journeyman III

IGPU 780M from Ryzen 7 8700G - black screen after drivers installation

Hi All,

 

I've just finished my build

- MSI B650 Gaming plus WIFI with latest BIOS - 7E26v1D  2024-05-31

- Ryzen 7 8700G/Radeon 780M

- PSU 650W

- 2x16 Lexar 6400

- Windows 11 Home - with latest updates

 

Last thing which I can't solve Is that any AMD drivers for Radeon 780M (Adrenalin 24.5.1 - 24.2.1) causes 

screen freez and black screen with cursor. This is visible during drivers installation and after reboot

it happens sometimes on Windows login screen, sometimes just right after login.

I was able to check device manager (quite short time before black screen) and there are no errors and Radeon 780M is visible.

 

Does anyone had similar issue and know what need to be done, updated, changed in order to make IGPU full functional ?

 

Regards,

WD 

0 Likes
8 Replies
FunkZ
Exemplar


@WellDone wrote:

- 2x16 Lexar 6400

If you're using XMP/EXPO to run that at 6400 try turning that off so the memory runs at default, see if your issues clear up.

Ryzen R7 5700X | B550 Gaming X | 2x16GB G.Skill 3600 | Radeon RX 7900XT
0 Likes
WellDone
Journeyman III

Hi,

 

I don't think that it might be related to DDR5 as with enabled EXPO on 6400 everything is working without Radeon 780M driver. 

 

I disabled EXPO XMP in bios and RAM is now configured with standard 5200.

But still when I switch from default Microsoft graphic driver to Radeon 780M after few seconds there is a freez and later on black screen with cursor.

 

Should I install something else then adrenalin drivers ?

 

#Update

I used AMD cleanup utility and removed all of the stuff from PC

and after I tried again with Adrenalin 24.5.1 and freez and black screen happened during instalation

monitor blinks few times (new graphics driver was enabled) and after this freez + black screen again.

 

How to trace down problem with IGPU drivers ?

Is there any tool that I can use in order to check whats going on ?

 

Regards,

WD

 

0 Likes

It is a little bit weird but I removed driver again and I've installed again latest version of the Adrenlin 24.5.1 - during installation there was again freez and black screen. So I rebooted PC again in switch back to default Microsoft driver So I starter installation of the driver again. Installer found that there is a problem with graphic driver with information to fix it. Such procedure I repeated few times and now I dont See any problems - no more black screens

 

I even enabled EXPO 6400 for DDR5 and it works till now.

 

Now I need to perform some igpu tests.

Cinebench works without any issue.

 

Do you think that FurMark is good tool to check igpu stability? 

0 Likes

Furmark will certainly stress test a GPU, probably more so than most games.

Ryzen R7 5700X | B550 Gaming X | 2x16GB G.Skill 3600 | Radeon RX 7900XT
0 Likes
Frederik
Journeyman III

Hi,

same issue here.

Did deinstall, install multiple times, latest windows update (KB5037853) does not run through and I'm not able to deinstall it.

But I will try again ...

Frederik

 

(Grafik: AMD Radeon RX 6700XT; Board ASUS TUF Gaming x670e-plus mit AMD Ryzen 7 7800X3D)

0 Likes

I'm sure that this is related to GPU drivers.

I thought that problem was somehow solved but it is still visible from time to time in random places.

Eg I'm able to play 2h in CS GO2 and everything is fine and 2 min after game in windows pulpit there is freez and black screen.

If you have the same problem please look at comments after 24.5.1 release. There are many posts about freez + black screen related to amduw23g driver crash.

When I uninstalled latest windows quality updates I think it was even worst..... I was not able to Quick disable 780M driver after login to windows because of crash. But later on forca moment it was ok.

I believe that in next update or patch it will be better .....

 

WD

0 Likes

Well then.

I had to reinstall Windows 11 and have been careful what driver to install.
As long I was using the Winows11 driver supplied via update everything worked fine.
But I had to install a new AMD-GraphicsCard thar demanded an update - and suddenly came the issue:
graphics went into suspend Mode without any prelimitary notice: on internal or external graphics.

No problems with overheating so far!
The funny thing is:

When changing in running system to internal graphics (on AMD Ryzen 7 7800XRD)  or vice versa the system runs  perfectly - for some times.
I can not tetermind when graphics crash - neither inetrnal nor external.

Neither I can say what a special program I use: I supposed it is an issue with foldingathome - but since I am not folding on the internal graphics Card and the same error occured again it must be an issue with the adrenalin drivers - not the grapihics.

Any Clue?

TX

Frederik

0 Likes
Mikulos
Journeyman III

I seem to have a similar problem.

I'm a bit of a fresher on the subject of building pcets, so my first problems with changing cpu from 7600 to 8700g were related to bitlocker. After the difficulties and accidentally encrypting the disk then I finally managed to understand how the bitlocker works, so then I was already running win10 on the new cpu without difficulty.

 

I waited a while for everything to set up, as I already had Adrenaline installed, the image went blank for a moment, lit up, frontedn from drivers showed an error, (I heard the sound of new hardware being installed) and then.... two seconds or less - it was clear from the mouse that there was some kind of frame rate problem.... and bang: bsod.... The system did not get up again, there was still the same error "whea_uncorrectable_error. I hooked up the beeper to decode the signals , because I noticed that even POST started to be heavily delayed .

The LEDs were somehow flashing strangely. I decoded the buzzing of the speaker (one long, three short) as a shortage of power to the gpu, and indeed: the motherboard I had powered atx24, eps12v- 8pin. 4pin I had not connected, because it was not necessary, although, asus recommended connecting 8pin12v and 4pin12v. And I didn't have an extra cable in the psu (500W thermaltake) anyway, for the cpu, only 4+4 which I had to connect as the whole 8pin and in fact everything worked.

 

Well, it almost worked, because over time while using the GFN service when I returned to the windows in the background, I had micro frezes, not very troublesome, but still strange...I was talking about impressions on this mobo but with r5 7600 cpu.

going back to the new cpu r7 8700g .... after using the option to format the disk from the bios, windows installer still did not see the ssd on which the system was previously (could it be because I encrypted it??). I plugged in the spare HDD, it turned out that it had preinstalled windows with some hp bloatware, but eventually it worked, it booted, and updated what it should. I uploaded the chipset drivers manually because I was too impatient to wait for windows to download it by itself. and during the installation of the vga drivers an error popped up (something about other drivers not fully configured), but after all drivers got installed and, I even fired up a game, which well... ran as I would expect it to run on this igpu. In the meantime, with the disk manager I formatted the sdd, it took a long time, even a long time, but hmm... the message at the end told me that I failed after all, but after unplugging the hdd I proceeded to install windows on the sdd and this time the installer already saw the disk without any problems... First boot, installation of drivers, windows update etc., I think I only manually uploaded the chipset from the mobo, and for the rest it downloaded automatically.... well and indeed. in the queue of automatic updates appeared the vga drvrs. AND as soon as vga were updated: the mouse was cramming for a while, and then bsod....

 

The system on the HDD also stopped working because supposedly some critical file is suddenly lost, and windows will not boot without it, Repair from the installer, of course it's just a fairy tale, so the only thing that helps me is to insert the old cpu, authorize with bitlocker and suddenly windows on ssd laughs like before.

I was at the store: got a molex ---> 4pin adapter to power the CPU fully ie 8pin + 4pin simultaneously. ( In the mobo manual it was recommended to do it any way).

The r7 8700g continues to suffer torment on the system login screen and will commit harakiri there, and the cpu r5 7600 continues to do micro frezes when I fire up gfn and some other nonsense in the background, that is, the cable-transformer did not help....

 

 

 

mb: asus PRIME B650M-A WIFI II
RAM: not sure if it matters because I even unplugged all of them and left only one bone - kingston fury ddr5 4800mhz

I thought it might be a power supply issue, but after all, 500W should be enough with my setup which is not intended to run without a dedicated GPU.

 

 

 

Or maybe it's because there are some traces of encryption left on the ssd? ......


Well, what did I do wrong, except that I wrote too much?
I have an idea to install windows again, but do not move anything completely anymore, just wait for it to do itself :]
Could I have messed up my ssd? Earlier, in between encryption I used formatting the drive from the bios level and there after time I realized that the option to use at your own risk if the device is not in the list.... well, but the disk works, because I am on cpu 7600 and I write from it

 

what is??????

 

0 Likes