Showing results for 
Search instead for 
Did you mean: 

Drivers & Software


The Problem:

I have an Acer Aspire A515-41G-13U1 (an awful laptop) that I bought a little over a year ago. It's always had problems with blue screens (from removing the charger cable to just playing a game) and I have never managed to solve them, not even after sending it to warranty.

It seems to happen randomly whenever I'm using an application that uses the discrete graphics card (a Radeon RX540), and doesn't seem to be related to either time, temperature, clock or usage.

The Specs:

Processor: AMD A12 @ 2.7GHz

Integrated Graphics: AMD Radeon R7, 2GB shared memory

Discrete Graphics: AMD Radeon RX540, 2GB shared memory

Hard Drive: WD 1TB, 42.6% free space (super slow bench, max speed is lower than the expected minimum)

Memory: 8 GB SODIMM @ 933MHz

Primary Display (External): 1080p @ 60Hz (NOTE: The presence of an external display does NOT affect the bug)

Secondary Display (Lid): 768p @ 60Hz

Here's a snapshot of the system information and the latest minidump.

What I've Tried:

  • Uninstalling the drivers that came with the laptop and installing the default drivers through Device Manager, results in the same bug
  • Installing AMD's Adrenalin software (the latest drivers), results in the same bug
  • Limitting CPU usage to curb thermals (I even opened it up to clean out the dust, which wasn't even that much)
  • Lowering graphical quality in games to reduce GPU usage
  • Setting my energy plan to "Maximize Performance" in the GPU section to make sure the discrete graphics weren't being hot-swapped
  • Openning the MEMORY.DMP file in Visual Studio to see what I could make of it, resulted in an exception when trying to load it
  • Created a restore point and tried to use Driver Verifier, which resulted in Windows being unable to load due to SYSTEM_THREAD_EXCEPTION_NOT_HANDLED bugchecks

Latest Bugcheck Info:

The computer has rebooted from a bugcheck.  The bugcheck was: 0x000000ea (0xffffc40937aac440, 0x0000000000000000, 0x0000000000000000, 0x0000000000000000). A dump was saved in: C:\Windows\MEMORY.DMP. Report Id: 3710d359-704c-4180-a78e-9928ed642428.


I want to be able to use the discrete graphics in this laptop, since it's basically what I paid for. It wasn't a cheap laptop and the frankly pathetic quality of the rest of the components makes it worse than something that was OK-ish in the early 2000's. Its only saving grace is its GPU, which is actually pretty good (if you ignore the awful bottlenecks from the APU and HD), so a solution like "Just don't use/disable the discrete graphics" is to me the same as "The computer is dead, just buy a new one"

Also, I have been trying to solve this issue through my own research for almost six months now, and this post is an admission of failure. I hope someone can help me with this.

The contents of this thread are cross-posted from my associated Microsoft Community post. They were helpful up to a point, but this does seem to be a driver issue, so I figured to post it here.

Thank you for your time!

0 Replies