Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Adept I

i2C Device Cannot Start - error 10

Hey there,

I am not exactly a computer professional and I am having a problem that I cannot find the solution to.  I posted a this problem back in May but since then my situation has changed a little so I am returning with a different thread. I hope that is ok. Thank you in advance for any help and insight.


I have a Razer Blade 14 2021 model - Windows 11. 

The touchpad has had this problem for a while where it just doesn't work. Sometimes a reboot will fix it but sometimes it will go a day or two without fixing. My deep internet searches have lead me all over the place but always coming back to the I2C HID Device - Error Code 10. I have read and re read so many people's solutions to no success myself. 

Over the summer I sent my device to Razer for repair. They did a system reboot and got the touchpad working. But a month later it went out again. I began speaking with Razer about the repair that they did, but to no success. My touchpad did turn back on (for no apparent reason) one day. Razer told me that this seems to be the way that it is (not a quote). I was confident that I had a hardware issue but they were confident that I didn't. September rolls by and all is good but just yesterday my touchpad went out again. 

I started going through usual steps of checking for missing updates and drivers but again to no success. 

I am coming here because if it is true that I do not have a hardware issue, then maybe I was talking to the wrong people. Someone here might have the solution that I need.

Things that I have done to solve problem on my own:

  • Talk to Razer Support, Microsoft & Razer Community
  • System reboots
  • Uninstall i2c HID Device
  • Factory Reset on machine
  • Installing drivers from AMD, Razer, Nvidia, Windows
  • Read dozens and dozens of posts on the interest from people who have almost the same problem as me and tried everything I can.


Thank you for any help and insight!

7 Replies
Journeyman III

@dloudsmilks Did you solve the problem? I'm encountering the exact same issue

Adept I

Sorry for my late response.

In short: No. I have no solution to this ridiculous problem. I find it irrationally frustrating that there seems to be no actual solution. Like I struggle to find polite words to express myself about it. 

That said, mine has been working all of December. Even still, literally every day I boot up my laptop, I am just as anxious about whether it will work or not. 

If you ever learn anything - please let me know.  



This user with a i2c Touchpad (HP) in device Manager uninstalled all the HID drivers and rebooted and that seemed to have fixed his specific issue:

Here is another User from Reddit that fixed his Razor touchpad:

This tech site gives some very good troubleshooting tips besides the usual ones from other websites on how to fix i2c HID Device not working:

Another Windows Tech site with good troubleshooting tips concern i2c HID not working:

Device Manager Code 10 error from Microsoft Support:

Full Error Message

"This device cannot start. Try upgrading the device drivers for this device. (Code 10)"


Typically, the device's hardware key contains a "FailReasonString" value, and the value string is displays an error message defined by the hardware manufacturer. If the hardware key does not contain a “FailReasonString” value the message above is displayed.

Recommended resolutions

Update the driver

In the device's Properties dialog box, click the Driver tab, and then click Update Driver to start the Hardware Update Wizard. Follow the instructions to update the driver.

Note You may be prompted to provide the path of the driver.  If you are asked for the driver and you do not have it, you can try to download the latest driver from the hardware vendor’s website

Run in a elevated Command Prompt/Powershell the following simple command to check your Windows OS for corruption: SFC /scannow

Edit: I presume you have the latest Razor firmware and drivers installed from here:


Update: mine has been working all of December and January but stopped on Thursday of last week. I am unable to get it going again. I am doing my best to be patient (again).

Thank you for the research and helpfullness elstaci. I will read through some of this later today, but at quick skim of the reddit posted by a Razer touchpad user they describe my error perfectly but I have tried the solutions posted several times (maybe to my error though). The biggest problem here is that, Razer doesn't have drivers listed for my device. Razer has told me directly to get my drivers from Windows Update.


I will read through and try some of these things again later.

Thank you.

Adept I

Hey there,

I appreciate your help, effort, and insight. I am trying very hard to not be a 'woe is me martyr'. I have tried the solutions above to no success. Below are some notes on my experiences.

  1. Since re-encountering the problem again in January I have:
    1. Ran updates via:
      1. Windows Updates
      2. Nvidia Geforce
      3. Razer Synapse
      4. Amd Software Adrenaline Edition
    2. Notes on AMD 
      1. This program disappeared from my system back in November. It was weird. Just suddenly not there one day.
      2. I tried to reinstall it but whenever it would run the installer it would complete but then be no where on my system. Weird.
      3. Even still my touchpad was working just fine at the time so I let it be that way. 
      4. I tried installing again in Feb after having the touchpad problem again and this time it worked. I have access to the AMD system updates which is encouraging
    3. Why I think AMD is the solution/problem? 
      1. When I run the installer for my specs the installer lets me install factory mode which removes and replaces old setups with fresh installs. 
      2. The installer then shows the chip set being installed
        1. dloudsmilks_1-1707936386798.png
        2. This includes the i2c Device which is super encouraging because that is the driver that I need
        3. But this has never been the fix in over 18 months so maybe I shouldn't be so encouraged.
    4. I have attempted to uninstall / install / update the i2c driver in Device Manager
      1. There are times where my touch pad is working but then when it wake up from sleep the touch pad stays off. 
      2. During these times, uninstalling the i2c device works and solves
      3. To avoid this problem I literally never let my computer sleep. I turn screen off after a few minutes but hibernate after 10 minutes. I hiberate when closing the lid. This works really well at avoiding the small common problem.
      4. When I attempt to update the driver as some many people suggest
        1. Windows Updates can't find a driver
        2. I browse my PC and it says that it has the best driver installed
        3. There is no driver to rollback to
        4. I don't know where to find a driver because it should be in the amd chipset as seen above. 
    5. Find new drivers for my System by the manufacturer
      1. I am up to date in every way I know how
        1. System bios 
      2. When I go to the manufacturer site - as linked above - it shows no drivers for my device Razer 14 2021 AMD
      3. I am up to date in the bios version - one of my dozens of past attempts to solve problems.
      4. I have heard that the other models drivers might work for my device specifically the Razer 14 2022 or 2023 drivers. 
        1. I have not tried this yet. I guess this is what I should do next and will try today.
        2. I just don't want to break things.
    6. Bios
      1. Some people send me to Bios to change the touchpad settings from  I2C to PS2.
      2. This option does not appear for me.
      3. They say if it doesn't appear then in the Main of the Bios press Ctrl+S but this doesn't show anything either.
      4. So maybe a dead end here?
    7. Additionally I have sent my device to Razer over last summer. 
      1. They said that they performed a factor reset and updated drivers
      2. It worked immediately for them. 
      3. Upon receiving it back it worked for about a month
      4. I reached back out and they said "well it might just be the way it is" (paraphrase)
    8. About factory resets
      1. I have done several over the past 18 months and never had success with this immediately fixing the problem. 
      2. This is disappointing to me because this is like the thing  that should work. 
      3. I am going to do another this weekend. I guess.

Again thank you if read this far.

And thank you if you have suggestions and or patience to help.


It gets to the point where your issue seems to be most likely hardware related and not software related after so much troubleshooting involved.

In another words, it seems like you have a defective Razer Touch Pad. That response by Razer was rather unprofessional and they should have asked you to turn it back in to see what is happening again. Unless they actually changed some hardware while it was in their possession and didn't mention it to you.

By the way, Thanks for the very detailed reply about everything you have done so far. I just feel sorry for you because I have a strong feeling you basically have a defective Razer.

All the troubleshooting steps you have done should have fixed your issue a long time ago.


Adept I

I am not really here to put Razer Support on blast. I am certainly disappointed in my situation and the response I received but that is besides the point. I appreciate your help and research. 


One last update: I did a factory reset last night: still no touch pad. I am going to give in to the problem for now. At least while I am setting my computer back up.