cancel
Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

osamagabr
Journeyman III

I have dell m6800 and it seems like the ghraphic card is not detected by the system

the graphic card is amd fire pro m6100 running on windows 10 and i have everything updated

0 Likes
4 Replies

0 Likes

Went to Dell Support for your laptop download site: Support for Precision M6800 | Drivers & Downloads | Dell US 

Make sure you have the latest BIOS version installed.

You FIRST must update all of your Intel Drivers especially the Intel Graphics and CHIPSET drivers. If you laptop doesn't have a Dell Driver updater you can download Intel's own driver updater to update all of your laptop's Intel drivers.

Then install the latest AMD generic Professional laptop driver. If it still doesn't work I highly suggest you install, using DDU,  all the latest Intel Driver from the link above. Doesn't matter if it is a year old or older.

Then install Dell's AMD Driver for your m6100 GPU card even though it is a year old. See if everything works correctly. If it does't it means that something is incompatible with your AMD generic driver latest version.

Make sure you use DDU with the internet disconnected until after you install the new AMD Driver on your laptop. Also delete, if created before, C:\AMD folder in the Root Directory.

If it still doesn't work use Dell's laptop Diagnostics on the link above and see if you have any defective hardware or software.

If all of the above still doesn't work, I suggest your restore your laptop back to Factory defaults by using the Dell Recovery disk or partition. Now see if your GPU card is recognized and is working.

If it is, then start updating the Intel drivers first. Then update the AMD driver. Make sure your Windows 10 is fully updated via Windows update BEFORE updating to the latest AMD driver.

If it still doesn't recognize the GPU card run Dell's Diagnostic again to check for hardware or software failure.

I tried all that when i downloaded a new windows  it was detected when i setup the drivers the problem happen again that's when i knew it's software not hardware problem 

0 Likes

anything else i can do ?

0 Likes