Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Journeyman III

I can't get the driver working in any linux distro

I'm trying to get the amdgpu pro driver working on any linux platform, So far I'm not successful with any atempt.

I've tried:

  1. Ubuntu 16.04
  2. Ubuntu 16.10
  3. Ubuntu 17.10
  4. Linux Mint Sylvia
  5. Manjaro - didn`t boot, even with nomodeset
  6. Antergos - didn`t boot, even with nomodeset

All those attempts was made in a fresh installation

The steps I did was as it follows:

  • Download the 17.50 version of the driver from here:
  • Updated the system to the lasted stable version, whitout adding any new repository
  • Extract it in a folder
  • Executed the ./amdgpu-pro-install -y command
  • rebooted
  • Black screen =/
  • I read at some foruns to add amdgrpu.si_support = 1 radeon.si_support = 0 amdgpu.cik_support = 1 radeon.cik_support = 0, so I did
  • Erase the 10-radeon.conf from /usr/share/x11/10-radeon.conf
  • Erase the old 10-amdgpu.conf from /use/share/x11/10-amdgpu.conf
  • Still black screen

I tried changing kernels at ubuntu 16.04, since it`s the supported OS, updated to 4.15, from 4.13,  but still couldn`t make it work.

I'm using a RX480 which is a card tecnically supported for the driver

I doubt it`s the card that`s at fault because I`m using it at a windows installation and is working just fine.

Anyone can find any miss step that I did? Or if the driver is just not working properly?

2 Replies
Journeyman III

Is there any resolution to this issue or do I need to switch to nvidia? I have an RX 560 and have also tried every suggested solution I could find. NOTHING works.


Good News! I downloaded the 'daily build' of the preliminary ubuntu 18.04, and my RX 560 works.