Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Journeyman III

Hyper-V causing BSOD, even after disabling

I have a problem with Hyper-V causing BSOD on my system upon opening an Android emulator with Nox. 

Earlier today the situation was: virtualization was enabled in the BIOS, but Hyper-V was disabled. I ran an android emulator via Nox which worked fine. Then I enabled Hyper-V because Android Studio asked for it. After restarting the pc, opening a single instance on Nox caused a blue screen crash. So when the pc booted back up I disabled Hyper-V in the same way I enabled it, restarted the computer, but the same thing happened: blue screen upon opening Nox.

Since then I have tried to do a system restore to before I enabled Hyper-V, as well as a system restore to a point three days ago. Problem persists. I have tried disabling virtualization in the BIOS and enabling it later, no change. 

On the same note, for some reason Google Chrome also won't start anymore. I have no idea how this is related (might be that the crash broke something) but wanted to add that.

So what's bothering me is that when enabling Hyper-V caused the problem, I hoped that disabling it would fix it. That is not the case, and I'm not sure what else I could try right now. I am a little hesitant to mess around with drivers at the moment as it has caused trouble in the past.

My setup is:

Windows 10

AMD Ryzen 5 2600x

AMD Radeon RX 480

16GB memory

I'm not sure what other information I should add so please let me know if I'm missing something. Thanks in advance for your time.

0 Replies