cancel
Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

someguyontheweb
Journeyman III

How to fix GPU hang by start of high loads

ok so the recent problem of the GPU hanging while trying to start or while playing games, is because the GPU idles and ramps up as the load increases, there's an issue with this. the GPU oversteps while ramping up because the load is more then the current clock speed can handle.

is there a way to fix the overload of commands, or is there a way to disable this idling and just keep the clock speed at say 1000 - 1150 MHz so that it's already ramped up for the games load.

if there's a different fix, please tell me.

also, this has NOTHING to do with the engine because I can't play old and new games now, BO2 nope, apex nope, fortnite nope, gmod nope, it's starting to get on my nerves.

I've got an 'MSI r7 370' using Adrenaline 19.4.1 I have tried 19.5.2 but that has the same issue.

0 Likes
5 Replies
kingfish
MVP

Re: How to fix GPU hang by start of high loads

In Wattman/game profile...do you have the Power Limit set to the max + value? (slider all the way to the right)

https://community.amd.com/thread/195150 

someguyontheweb
Journeyman III

Re: How to fix GPU hang by start of high loads

I have tried setting the clock speed to 1050mhz and the power value to 0, +5, - 3. It didn't help

Outlook für Android<https://aka.ms/ghei36> herunterladen

0 Likes
kingfish
MVP

Re: How to fix GPU hang by start of high loads

I suspect your 'custom' settings are causing your problem.

You would do yourself a favor by setting everything..especially clocks...back to default and leave them alone.

someguyontheweb
Journeyman III

Re: How to fix GPU hang by start of high loads

1050 is the default clock speed

Outlook für Android<https://aka.ms/ghei36> herunterladen

0 Likes
kingfish
MVP

Re: How to fix GPU hang by start of high loads

All fans/clocks set to default/automatic.

Increase the power limit as I suggested. AMD graphics performance 

Disable ULPS. AMD graphics performance 

Computer power plan must be set to 'Performance' (not balanced).

https://community.amd.com/thread/176003