Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Adept I

How do I Install an OpenGL Extension So I Can Run the Original Tomb Raider

Hello, I am not sure if this is the place to post this, but since it's an OpenGL question (and because I don't know where else to get support for decades old game) I thought I would ask here.

I tried launching Tomb Raider I (not the remake) for the first time in a couple months but have come across the error, "Severe Problem: OpenGL GL_EXT_packed_pixels extension is required for OpenGLide!" I haven't had this problem before so I think the issue may have come up when I updated my drivers (possibly?) or I accidentally messed with some files when I was clearing space.

Since updating my driver has not worked, I would like to download the extension but I don't have any idea how to. I've found the extension on the Khronos OpenGL Registry but since I have never worked with anything like this, I don't know how to use it.

Help with this, whether it's with using the extension or an easier fix, would be appreciated. Sorry for my complete lack of knowledge on the topic.

7 Replies

OpenGL is activated by installing the AMD Driver. You shouldn't need to install any OpenGL extensions to get a game to work in OpenGL

You may have deleted some files that affects OpenGL in Windows or in the AMD Driver itself.

Run in a elevated Command Prompt the following command line to check your Windows OS for corruption or missing files: SFC /scannow

Also run DXDIAG.exe and save the file to your computer. Open the saved DXDIAG file and go to the last Category under "Diagnostics" and there you will see all files that are having issues in your PC.

Upload an image of GPU-Z and to check if OpenGL is activated and has the correct version installed. Several Users are showing OpenGL version 1.1 instead of version 4.x in GPU-Z.


Thanks for the suggestions and sorry for taking so long to respond, I didn't get an email like I expected for a reply.

The scan said it repaired some corrupt files, but Tomb Raider still wouldn't run. When I checked the  DXDIAG file, I found that DOSBox.exe showed up due to APPCRASH (which I assume happens every time I run Tomb Raider I and it crashes). I don't understand any of the other information associated with the log.

I have OpenGL 4.6.

Adept III

 Give this a go.  Phsyx x install, i know its an nvidia thing but its required for some older titles..  I had to do it to run some older titles like dragon age etc... on my 7900xtx and all the adrenaline drivers since release of the card at least.

NVIDIA PhysX System Software 

Louis Imbrogno
Linux Administrator/Application administrator
Dpt. of Army Civilian, former ET NAV submarines U.S. Navy.

Hi, I download Tonb Raider I  to, when that message apears I just press "OK" and the game opened after te cutsene. 

And in the emulator you can go to Display - OutPut and go to Direct3D

Here Works


Hi, thanks for the suggestion. It didn't seem to do the trick, unfortunately.

Adept I

I downloaded a mod for the game that allows me to run it without DOSBox. That has done the trick.

Journeyman III

Can someone explain how we install the mod? I paid for the game on steam and it's not working now. Seems a little stupid that I should have to install something secondarily or aftermarket when I'm paying for a gaming software developer to provide me with a game that works. That said, I'm getting the open GL issue was well and I have never installed a mod nor do I know how to do so. Someone would literally have to put my hand on it for me to understand what to do. If this is just going to be how things are and somebody can't help me cuz I just can't grasp what they're saying or if no one actually helps then my best bet may just be to switch to consoles