Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Journeyman III

Help Please Cant get into Windows . Weird screen glitch.


Cant even get into Windows . The problem comes in once i try to install latest version of radeon software for my gpu and it prompts me to restŕart my computer. The computer will boot up, windows logo will come up and a loading symbol is shown , then the screen will go black flash once or twice and a wierd rectangle of white static looking blocks will appear on the screen . The computer will then try to restart and this whole process will begin again

My specs are as follows:

Ryzen 5 1400

16GB ddr4 ram (2 x 8GB )

Gigabyte Radeon RX550 2GB

500W Raidmax power supply

Asrock a320m-hdv motherboard

Windows 10 64bit Home

I have tried to fully reinstall windows which allows me to boot into windows 10 . I am then prompted to get graphics drivers which i download from the AMD site (i have tried all different versions of the intstaller all give me the same result) once the drivers and software is installed i am then prompted to restart my pc after which the above mentioned problem happens again.

I have also tried formatting drives DDU software ...

Please help!

Ps.the image at the top is the weird screen glitch i was talking about

8 Replies
Adept I


Have you ever seen this card actually work? Because the photo you've added implies its broken.

The fact that your displays works when booting up doesn't mean the card works completely. While it's a little bit more complicated, while booting up the card is operating in what you could call a very standard "compatibility mode" (low resolution, no 3d acceleration) which allows you to see the bios and OS bootup and/or installation. Once the driver kicks in, the full potential of the card starts being used which is where things go wrong for you (it's starting to use parts of the card that apparently don't work).

If you just bought this card new:

Try putting it in other machine that has a similar card that worked (maybe you have a friend with a computer you can try this with). Doesn't even have to be a AMD card. If you can't get it to work then, just return it to save you the trouble. If it does work in another computer:

- Your power supply may be insufficient (also, some cards require an additional power connector).

- You may need to update your BIOS.

If you bought this card used:

Try the above, but if the same glitch happens it could be the previous owner has messed with the cards firmware. If so, let me know and I may be able to guide you through the process of fixing that.


Don't bother formatting and reinstalling windows. For the time being you can boot windows in safe mode and disable or uninstall the driver.

His PSU should be sufficient. The RX 550 requires a minimum PSU wattage of 350 unless the PSU is defective.

I agree, the best way to check if the GPU card is good is by installing it in another computer and see if you get the same issue.


Hi there ,

Thank you for your reply!

I have actually seen the card working but only on older versions of the Radeon drivers/radeon software in general , is it possible that the later versions are just not compatible with my card or is it the actual install process that is causing an issue?

Ive tried it in other computers and its the same problem just shows that screen artifact when latest drivers installed.

Its a new card and its still under warranty but i dont want to change it out prematurely and not know the real cause of my problem .

Should i try a new hard drive as mine is pretty old? Maybe its not writing data as it should? I dont know at this point .

Ive tried updating bios , clearing cmos , formatting drives , used DDU software to directly unstall drivers for graphics , updated windows then tried.

Anything else i can do  


If your RX works fine with a previous older version of AMD driver then it could be installation conflict or something in your computer, software or hardware is not compatible with the latest versions.

Try this basic method of install AMD Drivers and see if it makes any difference:

install AMD driver:

1) Download the correct AMD Full Set of drivers from AMD Support. Make sure your Windows is fully updated via Windows Update. Windows Must be fully updated because the latest AMD Drivers requires all the latest "Optional" and "Recommended" updates to be installed.

2) Use Windows Uninstall to uninstall current AMD driver and software and disconnect the internet from your computer. Then use DDU (Display Driver Uninstaller) Display Driver Uninstaller (DDU) from Wagnardsoft  Forum in Safe Mode. This will eliminate all traces of the AMD driver and software from your computer.

Delete C: \ AMD folder from the Root Directory. Reboot

3) Go to Device Manager and click "Display Adapter" and make sure you are on the MS Basic Display Adapter. If not, uninstall the AMD driver using Properties.

4) Try reinstalling the AMD FULL SET OF DRIVERS that you have downloaded manually. Make sure you disable the Internet to prevent Windows from installing a newer version. So configure windows to prevent it from updating drivers via windows update. So it has been mentioned to disable any anti-virus programs before installing AMD Drivers.

5) If the new AMD drivers installs and works correctly, delete again the C: \ AMD folder from the root directory. To save space on the HDD.

6) Enable both the Internet and Anti-Virus program (if applicable).

7) Go back to Device Manager and check your GPU card driver is working and identified correctly.


hallo, how can i check if graphic card firmware is changed on not?


Since you were able to reinstall windows without issues don't worry about your harddrive. It's highly unlikely that has anything to do with this issue.

If I were you I would:

Open a support ticket with Gigabyte (GIGABYTE Global ) as it is possible their customized firmware is causing the problem with a newer driver version.


Return the card.


i have amd radeon RX 550 4GB memory and i have the exact same problem. exact same glitch pixels. i havent done anything yet cause we are on quarantine for covid and all technical stores are closed if something happens and i need help. did you find any solution?


hallo i have rx 550 and the same exact problem with you, same artifact. did u find what was the problem eventually?