Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Journeyman III

HDMI "No Signal" On Driver Install (RX 580 Windows 10, 20.2.2/20.4.2 Drivers)

Computer Type: Desktop/Gaming Rig plugged into TV via HDMI
GPU: Sapphire Radeon RX 580 NITRO+ Special Edition 8 GB GDDR5, no overclocks or mods
CPU: AMD Ryzen 3600X, no overclocking or mods
Motherboard: Asus ROG STRIX B450-F GAMING
RAM: 2x8G CorsVengLPX DDR4 3200 Ryz, in positions 2 and 4, no overclock or mods
PSU: CORSAIR - RM750x Modular ATX PSU - 750 W
Operating System & Version: Windows 10 Pro 64
GPU Drivers: 20.2.2
Description of Original Problem:
Post completes fine but then Windows 10 boot hangs and eventually the HDMI signal to my TV is lost (yep the TV is my primary and only display). I see nothing past the Post boot and TV displays "No Signal" message.
This starts at the point the driver install kicks in and resizes the display during the install process. From this point the signal drops and a reboot results in no image.
Troubleshooting: Reinstalling Windows 10 fixed the issue, however, on installing 20.2.2 drivers the system reboots and the issue starts again. I'm able to go into recovery mode and reset the PC to a point before the drivers, which works, but then on driver install we have the same issue. Safe mode works.
Set a System Restore point to before driver install, it's definitely an issue with the drivers as the issue disappears when I roll back.
Noticed AsusUpdateCheck.exe being launched as a service. Stopped and Disabled it. It's an Asus solution for getting you the latest drivers, unfortunately it fetches the GPU drivers when I don't want it to and forces the issue. The solution is to disable this in the BIOS, yes, you disable a Windows service in the BIOS.
Looks like I have to disable this in for Windows too, (google Disable Automatic Driver Downloads).
This issue is confirmed with 19.10.16, 20.2.2 and 20.4.2. All result in the same outcome. When the screen resizes during installation process the signal to the tv fails over HDMI and the TV can't find a signal again.
3 Replies
Journeyman III

If I reboot into Low Resolution Mode via the Recovery process (the same way you'd launch into Safe Mode) then I have visuals and can interact with my desktop. If I change the resolution to 1920x1080 I get the same "No Signal" issue. Scrap that, changing the resolution to anything results in the same issue.


From today I have the same problem with mine RX 580 4GB Nitro connecting with tv via hdmi. Yesterday it worked. Tried 20.4.2 and 20.4.1, same issue. Uninstalled amd software. Very frustraiting

Journeyman III

The only work around I have is to use a a DVI to HDMi adaptor and take the signal from DVI to the TV. 

This is super lame as it restricts me to a max resolution of 1080p, but at least I have an signal. 

Interestingly the DVI to HDMI setup results in a "No Signal" condition for POST. Once POST is complete and the windows boot starts the signal is found. 

Not impressed with the lack of official response on this.