cancel
Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

poweredbysoy
Journeyman III

Having trouble getting FreeSync working - Asus MG279Q

I'm not entirely sure how Free-sync is supposed to work, but for whatever reason it doesn't seem to be working for me. Right now the two games I'm trying it on are Diablo 3 and Bioshock Infinite.

Within the monitor OSD I enable FreeSync.

Within the CCC I enable FreeSync.

The FreeSync range of this monitor is 35-90 Hz.

I seem to be able to restrict these games' FPS to 89. Within the Diablo 3 options I limit the frames per second to 89. I also use the frame-limiter in the CCC and set that to 89.

But whenever I start up Diablo 3, during the loading screens, I get a monitor OSD prompt that FreeSync has been disabled 'due to it being out of the range of 35-90'. I assume this is due to the low fps of the loading screens, which is pretty common, is it not? While in game, frame rate stays at 89 (limited by the game), but the monitors Hz is up at 144.

When I start up Bioshock, the game jumps to 89 frames per second (the CCC limit), but my monitor Hz remains at 59. In-game Vsync is turned off. And as you would expect, I see a lot of tearing.

I feel like I'm missing something by trying to get this tech to work. Any input is appreciated.

Tags (1)
0 Kudos
2 Replies
willyfisch
Adept III

Re: Having trouble getting FreeSync working - Asus MG279Q

You need to set the refresh rate to 90hz in Windows.

It's at display settings at the monitor tab.

Then the message from the monitor should come that Freesync is enabled, as soon as you launch a game in full screen mode.

amdmatt
Community Manager
Community Manager

Re: Having trouble getting FreeSync working - Asus MG279Q

Please provide more information so we can help.

I would recommend using FRTC only to lock the FPS for the moment, try setting it to 88 and see if FreeSync remains enabled.

How to enable FreeSync document might be worth checking.

0 Kudos