cancel
Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Hardware acceleration is broken with RDNA cards, due to poor AMD drivers and support does not care

My issue is random video and audio stutters when playing a you tube video or web scrolling, so i did a lot of testing trying to rule out this very annoying issue the things i have tested was

I reset my motherboard bios to factory defaults and made sure my motherboard had the latest bios and made sure resizable bar was enabled in the bios and in the Amd software

i did a fresh install of windows 10 pro and did all the widows updates

installed the newest chipset drivers for the motherboard

updating the DirectX drivers

Did a fresh install of Amd newest gpu drivers version whql-amd-software-adrenalin-edition-24.3.1-win10-win11-mar20-rdna

I even swap my power supply to my back up Corsair vs 550 watt 

So none of the trouble steps was working so i did a fresh install of windows 11 pro, and windows updates all up to date update and chipset to gpus drivers all over again same results

So i rolled back the Amd drivers from adrenalin-edition-24.3.1 to 24.2.1 the same results stutters i back dated to adrenalin-edition-24.1.1, same thing happen again sutters, so i rolled back to whql-amd-software-adrenalin-edition-23.12.1, Then all the stutters went away

And yes i used ddu cleaner, i can't stand Amd clean tool it does a poor job of cleaning the files

I also attempted to install my old XFX RX 580 8gb with the newest Polaris drivers whql-amd-software-adrenalin-edition-24.3.1-win10-win11-mar20-vega-polaris

And guess what there was no Sutter problems 

 

So you clearly see there is a problem hear with AMD's crappy drivers

 

 

 

 

My brief specs are 

Intel i5 10400f using arctic sports duo 34 cpu cooler 

MSI Z490 PRO-A

Gigabyte RX 6600 eagle 8gb

Adata XPG D50 RGB 32gb ddr4 3600mhz

1tb Lexar n620 gen 3 m.2 nvme

512gb Adata gen 3 m2 nvme

Adata XPG core reactor 650 watt gold fully moduler A tier psu

i have tested with win 10 and win 11 same results

 

 

 

16 Replies
iainob1
Elite

Agreed, 7900xtx very poor video playback so far.  Nothing is smooth, even turning off hardware acceleration. All video resolutions too. Having a play with different settings but if I can't get smooth video playback the card will be going back and will be on a 4080 super. That and it using 10 times more idle power when two monitors are on.

10-12 w one monitor at idle 120w two monitors at idle. Even the custom resolution tweak people do still has it very high. That is totally unacceptable. It means you can't use multiple monitors on AMD.

johnnybgood89
Adept II

Same thing with RX5700XT...Disabling HA helps,stutters stop on every browser.

HA is broken 

0 Likes

Thanks good to know and have you done a lot of the trouble shotting steps that i have ?

0 Likes
FunkZ
Forerunner

7900XT here, 6700XT prior to that. Up to date software and drivers. Hardware acceleration enabled in Chrome, no problems.

Ryzen R7 5700X | B550 Gaming X | 2x16GB G.Skill 3600 | Radeon RX 7900XT

Interesting so maybe its motherboard chipset related or certain chipset drivers version, or maybe its my msi motherboard bios or maybe its my gigabyte rx 6600 bios, or maybe its dirty power from the wall or a faulty display port cable/Hdmi cable, These are the things i have to test i guess i have extra HDMI and display port cables and extra psu cables and i will plug my system into another outlet, and test out different version of intel chipset drivers, and i will even test my RX 6600 in my old media pc that's using a amd chipset 

 

But yea thanks for letting me know your 6000 and 7000 cards are ok with HW acceleration, i am just hoping i did not get a faulty card 

0 Likes

Check your monitor refresh rate. When you have a big gap between what your gpu can handle and the monitor, it will cause stuttering. Sometimes its the game itself. 

Some game ports that seem to be limited at 60fps when run on a high refresh monitor without VRR can cause it too. 

It even happens on the phone as well. There are games that needs to have 60hz locked. If I leave the refresh rate at 165 I'll have lots of stutter.

Worth checking if you didn't 

The Englishman
0 Likes
Earnhardt
Grandmaster

Currently a STRIX RX6750XT,X570 Crosshair Dark Motherboard ,Smooth as butter, No problems here either.

0 Likes

Are you using Amd latest driver 

0 Likes

Yes I am

0 Likes
iainob1
Elite

I can get the YouTube video playback smooth now up at 4k in Chrome but not Firefox.

 

In Chrome setting the back end to dx9 in the flags section stops the regular judder.

There is a similar function in Firefox but it made no difference. There is a regular judder every second no matter the settings. 

 

 

0 Likes
johnnybgood89
Adept II

Problems with every browsers for me.

0 Likes
432hz
Adept III

RX 6800 on 24.2.x and 24.3.x had intermittent Windows / BIOS stutters for me. Scrolling web pages, resizing windows, moving windows, keying through BIOS, etc.

Disabling Resizable BAR helped.

I ended up clean installing 23.12.1 with ReBAR disabled and have had good stability.

BIOS:

  • ReBAR - disabled
  • Above 4G Decoding - enabled
  • fTPM - disabled
  • Secure Boot - disabled
  • CSM - disabled

Windows:

  • HW-Accelerated GPU Scheduling - not an option
  • Chrome/Firefox/Brave HW Acceleration - enabled
RX 6800 • Intel 12600k • G.Skill 6000 32GB • MSI B760M Mortar
0 Likes
johnnybgood89
Adept II

I already have RBAR disabled and nothing...

I turned off HA... thats the only fix. 

Can try with 4G decoding, ftpm, secure boot and csm.

 

0 Likes

I think this helped need more testing.

johnnybgood89
Adept II

Nah nothing helps, its broken.

Disabled HA.

0 Likes
tomasmark79
Adept I

I have the same issues with NB:

Hello. 
I am very happy that I can share my experience.

I have bought this awesome laptop machine ZBook Firefly 14 G10 A.

 

Unfortunately I'm facing regularly issues from the begin I am owner of this device and the issue is regarding to video playing in any web browser.

 

Issue:

Playing video stream from the web (YouTube, Vimeo, Twitch) is failing randomly. More frequently if Windows UI is actively used.

 

Fixes:

 

I tried already all the possible solutions at the begin with reinstalling OS, Drivers, latest BIOS firmware.

Issue is something solved for several days and later is coming again back.

 

Bug:

 

As I am technical professional and I have more than twenty years of IT experience I guess it is software bug. I can't specify if the problem is where but need to be analyzed and fixed by responsible people.

 

Solution:

 

If somebody here from the HP Members is available to forward this message deeper technical HP engineers, it would be very useful. This issue looks like need to be fixed by HP developers and their Hardware drivers. 

 

Reproducible:

 

The issue is reproducible on each laptop with the same hardware configuration and latest Windows 11 to date 13.5.2024.

 

Thank you

Tomas

 

 

0 Likes