Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Adept II

Gigabyte vega 56 oc 8gb crash randomly all the time, black screen, fans 100%

Hello, im having this weird problem since i brought my new GPU a few months ago, my whole build is new, the GPU was the last  purchase, previously i had a R9 290x in this same build, all works perfectly!

The crash is sometimes a black screen on all monitors and fans turns 100% speed, nothing to do here just force shutdown, sometime i got a blue screen with the message, THREAD STUCK IN DEVICE DRIVER.

All this happens randomly, between 1 hours to 4 maximum,  while gaming and casually browse on my second monitor.

i have tried all the possibilities, clean windows install, a lot of drivers versions 18.x.x / 19.x.x, diferente pci-e socket, diferente PSU, two diferents power rails, undervolt, power limit +50%, GPU and motherboard BIOS update, basically all known tricks. 


My systyem:

  • AMD Graphics Card
    • Vega 56 Gigabyte OC version
  • Operating System
    • Desktop Windows 10 64bit
  • Driver version installed
    • 19.11
  •  Display Devices
    • LG IPS FULLHD (1920x1080@59Hz Active DP to HDMI adapter
    • 23MP55 (1080x1920@59Hz) HDMI
    • HISENSE (1920x1080@59Hz) HDMI
  • Motherboard + Bios Revision
    • Z370 AORUS Gaming 5 + Bios F10
    • Intel Core i7 8700k
  • Power Supply Unit  Make, Model & Wattage
    • Seasonic 750W Gold 
  • RAM
    • 16GB Gskyll 4133hz


The only solutions that works is the driver 17.11.1  

whql-win10-64bit-radeon-software-crimson-relive-17.11.1-nov10.exe - Google Drive 


I have been testing the new bios, for a week i think, no crashes.

UPDATE THE BIOS USING THIS VGA Bios Collection: Gigabyte RX Vega 56 8 GB | TechPowerUp  (or search for your manufacturer if its not Gigabyte )

Im using the default settings, with the lastest driver version,  turned off zero rpm,  changed the fan speed and power limit -50%


Radeon pro drivers seems to fix all problems 

429 Replies

Thank you. I've already contacted the company I bought this from. I'll share your note with them. I appreciate the response. Cheers.


"There is another thread for the vega 64 in this forum, with more than 600 comments and no reply for AMD ib more than a year." - For similar issues to this? Can you link it, please?

Adept III

I wouldn't say they are not supporting Vega, actually, RIS was added few months ago, with Navi already in the market.
I have this card of the post but the 64, RX Vega 64 Gaming OC 8G. 

I got it by the middle of 2018, since then I been trying to correct issues with the card. BSOD and BlackScreen crashes with fans 100%.

I sent at least 20 different support tickets to AMD reporting problems with drivers.
The last adrenalin 2020 is the most stable driver for me. My card is crashing like 1 time a month, not more than that, I already repasted it, change the pads, install 5 coolers into my case creating airflow, replaced my PSU to Evga1200.
I always suspected that my card really try hard to reach 1600mhz coreclock. But it did it some times. 
With adrenalin 2020, using the same config as always, my card does not reach 1600mhz any more. It stays at 1560mhz... and also, I reduced the voltages from 1130mv, to 1080mv getting the same results.

I was thinking that after sending too much support tickets they identify my card this time and reduce the clocks in las driver iteration, hhahahaha they must be tired of my complains.
Before it was 7439 score points in TimeSpy at 1600mhz, now is 7244 points at 1550mhz, and is colder and it feels more stable, less problems, no stuttering. 

I think the best way to approach this is updating to last version drivers, put the damn heatsink on the backplate, and try to reduce clocks and voltages.... Time will tell I will keep you updated guys.


I've also been fiddling around with the new 2020 drivers, lost around 260 score on 3Dmark firestrike and I also noticed core not running as high as it used to compared to the previous drivers with exact same settings. Also note that 3Dmark wont give u a validated score with this (I dont know if new) tessellation override in the AMD settings. Mine was on default AMD optimized. I haven't checked to see if this increases or decreases score though. 

I can't remember what I was doing but I do remember this weekend I started a round of pubg and forgot to load my fan profile, as I started kitting myself out I got black screen and fans blasting. This has to be a confirmed design fault on the card with regards to cooling, with the fan profile I've set it never ever happens. It happened a few months ago too when I first installed ARK survival when I forgot to load the fan profile. Other than that no problems at all only these 2 problems when not loading custom fan settings. 

You have to be kidding me, I noticed ALSO absolutely the same, even my last one unique crash was playing ARK, is the only game who pushes the card so far that some times it crashes with fancoolers going nuts. 
I think that is temperature on the VDDC it fails because of high temps, and it crashed, those components cooled by the backplate at the sides and near the GPU. How agressive is your custom fan curve?? I will send you a screenshot with my config when reach home tonight maybe increase fan cooler spee can help with thos VDDC, today ARK is the only game where stability is a problem. BFV is rocksolid. 


I've experienced the same since using the profile you shared. Only time I've had a black screen in last few months is when I've forgotten to load it (in PUBG & Rust).

I do however still get frequent, yet intermittent BSODs, but only on shutting down the PC. (PFN_LIST_CORRUPT).

Adept I

I bought a brand new Seasonic 750W Focus 80 Gold PSU and updated the drivers to latest 2020 drivers but the MSI Vega 56 still crashes even on low GPU usage like Hearthstone where less than 20 watts are in use. This tells me the crashing is not caused by high GPU load but merely any load will cause crashing. The types of crashing I experience are:

  • Crashes - Black screen, 100% fan speed or regular speed.

I'll submit an RMA ticket to MSI to see if that helps (probably won't), if it doesn't help then I'm going to be very pissed at AMD and will do everything I can to piss them off for not acknowledging this glaring issue. Nobody should have to do anything extra like messing with voltages for the card to be stable; you follow the installation instructions and should just work out of the box. If this card isn't stable then we all just wasted $300 for a faulty product. Bring on the class action lawsuits to get their attention!

Adept II

I'm still running the same as last time - temp 30 fan 35% 45 - 50% 55 - 60% 65 - 80% 75 - 100%

I have 2 fans on so its not that loud and my case is on the floor next to my desk. I haven't changed anything core clocks same voltages same etc. 

I go on leave on the 20th so will have more time to mess about. Again this is true we spent quite a bit of money on something that's not working the way it should, and us as the consumer/general public have to come together and try find work arounds to get it to work ON TOP of having zero response from AMD about it. They just play stupid and anyone trying to contact AMD with these problems be prepared to get nowhere. Vega is a failed product and they don't want to admit it 


I don't know if it was a failed product. Because if you take a look closer, our Vegas are almost the same as Radeon Instinct MI25 (Which are successful products for server computing tasks). Maybe card manufacturers are not dealing well with Vegas, MSI and Gigabyte are always having issues. For this particular GPU the best option is go with Sapphire Nitro. All the others are pretty bad.

Gigabyte vega 56 oc 8gb.JPG

I'm suspect these 12 components give backplate so much heat that previous reply need put extra heatsink + fan to cold backplate.

for me, I already remove the heat pipe on the backplate.

I also put id-cooling frostflow 120vga on top GPU and modified the bracket using a zip tie, I will provide pictures later

Adept II

i think changing the thermal pads under the backplate and adding a fan duct connected to a case fan intaking cold air could solve this problem

Adept II

There is a video on youtube titled "Unboxing GIGABYTE Radeon RX Vega 56 Gaming OC 8G - Random crash with black screen and 100% fans" Aug 20, 2019

in the comments Dirk Braakman added a solution to this problem, it requires using an unverified bios, give it a try if you are ready to take the risk

Adept I

Flashing my card with this BIOS seems to be helpful. VGA Bios Collection: Sapphire RX Vega 56 8 GB | TechPowerUp . no problems with the newest version of driver. but you need to adjust the speed of fan manually and turn off zero rpm.

I have MSI Vega 56 AIRBOOST OC 8GB.

I have the same card as you but trying to flash the rom you linked resulted in a "subsystem id mismatch" error. Did you use a specific version of ATIFlash? I used the 2.93 version from Techpowerup.

Look what AMD forces us to do... Never had a problem with the green team cards lol


I used ATIFLASH 2.84 but there's no problem if you are using another version i think.. Just place your bios file in the ATIFLASH directory, create .bat file in it. Open in notepad and type this "atiflash -f -p 0 biosname.rom" replace "biosname" with your's bios filename. Then just open bat file and your bios is flashed. Reload PC. But don't forget to make a copy of default bios. And make sure bios switch is closer to the hdmi outputs. My card is working fine under and without load for 2 weeks.

P.S. Sorry for my English.

Thanks for your reply.

It worked, or so it seems. I didn't see anything except that the .rom file disappeared after the .bat file ran.

I forgot to take a screenshot of the ATIFlash window when I backed up my original BIOS to compare before and after.

Well, GPU-Z still shows MSI under Subvendor, what is yours showing?


Mine is showing sapphire. Have you renamed a sapphire bios file from TECHPOWERUP? I haven't, but when I tried to rename a bios file I got the same result as yours.If you  do it right gpuz will show Sapphire as a subvendor. 


Still nothing but I've got enough for today xD

Maybe it's an issue with Windows Defender or something, I'll dig some more when I have time. Thanks for the help!


try amdvbflash -f -p 0 biosname.rom. it's for newer version of atiflash

Awesome, this one worked. Thanks again!

(I saw there was no AtiFlash.exe on the newer versions of the tool, but I was hesitant to run the amdvbflash.exe instead.)

I'll make sure to push the card to its limits and post here to let people know if it worked or not. * fingers crossed *

I'm using Gigabyte Vega 56 OC 8GB and can not use the bios of Vega 56 Saphire, I tried flash this bios and when restart the LCD is going blank. So I back to the Gigabyte Vega 56 bios newest bios


I also got an MSI Vega 56 AIRBOOST OC 8GB which I mounted a morpheus on. Going to try that and report if it will fix my issue. Thanks for the hint!

EDIT: I noticed that I have been using a daisy cable for powering the Vega. Now I have two separate PCI-e power cables, each of them connected to a single 8 pin of the GPU. In other forums this measure was suggested to improve stability. Afterwards I tried to flash the Sapphire Bios, however afterwards my GPU didn't output any video. Very strange, since I have the same GPU as dahuckk. Thankfully I was prepared for that (I noted down the keystrokes, location and commands which were needed to be executed) and was able to blindly flash the original bios back to my GPU. Afterwards I tried the Gigabyte bios which worked without a problem. Stability seems to have improved. I have run 3DMark TimeSpy in looping mode for 24 hours and no crashes. I will report back in a month. If I still have no crashes by then, then I will see that as the real proper fix to my black screen crashing problem which I had now for over 1 year. Though I won't really know if it was the power cable thing or the bios.

Also I'm wondering if I should try any of the Vega 64 bios to improve performance since I have a morpheus. But stability comes first.

EDIT2: Still got crashes and black screens. Then I went on with the Vega 64 bios of Sapphire. It worked for some reason even though the Vega 56 Sapphire didnt work for me. But with Vega 64 bios I still got crashes.

What seems to work right now is that I have set the p0 state as Min and p1 state as Max and disabled (?) all other states in the AMD performance settings. Also set power limit to -50%. I do not have much clue about OC so I dont really understand what I have set there but now at least it is stable for now. Will report if I get another crash.

As a short update to my post on Mar 24, 2020 8:47 AM on page 13:

After tying a bunch of different options I was still getting crashes. I then ordered the 5700 XT anniversary to finally ditch this card. The new card was running stable for days but then I still got a crash. And after a few more days again! It happened roughly every 8 hours of the GPU running folding@home. Even though it was a lot more stable than the MSI Vega 56, having paid for a brand new card it was unacceptable for me to deal again with this bullcrap. I returned the 5700 XT, put back the Vega and installed the 17.12.2. I'm getting a crash now once every 12 hours of running folding@home which is almost acceptable to me.

I will try this PRO driver next to hopefully run this crap of a GPU stable at last. 

Thanks for the hint guys! 


Hi All

i already install driver 

20.Q2 with uninstall anything

i has been playing Far Cry New Dawn and the Witcher 3 for 8 Hours combine within 72 hour after install driver


I hope this can help you all too 



I tried the driver, but got Graphics Glitches in CoD Warzone.

Did you have any problems with the driver at all? Did you change any settings?


Try tweaking some settings to avoid the glitches, remember this is a Pro / Enterprise driver, was made for workstations in mind which means is not a gaming driver, some games could have glitches. For example, Phantom Doctrine show some ghosting with illumination, I fixed it tweaking the shaders on medium instead of ultra, and it ran wonderfull. I prefeer that, instead of crashes and inestability. I don't know COD but try to play with settings for a while. 


Yes, take in mind that WX8100 is the Vega 56 Enterprise counterpart. So I don't know if those drivers could work on Navi's 5700s.
I think you must try something like W5700 Pro driver, which is the pro version of Navi accelerators.


VGA Bios Collection | TechPowerUp 

Here all Bios for

Gigabyte Vega 56 OC 8GB

Adept II

Well guys, it might be too soon to celebrate, but the trick given by @dahuckk worked for me!

I stayed idle in No Man's Sky for about 2 hours, which could crash in just 10-15 minutes idle at time. Then tried A Plague Tale's demo, which hit the GPU pretty hard and could crash under 10 minutes. All good!

It's worth a try, I say

Journeyman III

Been following this thread for quite a while now, have tried virtually everything suggested with no joy.

I've got the MSI airboost vega 56 and tried the bios flash suggested by @dahuckk and so far it's been working, as mentioned you have to control the fan separately if you want it to go below 28% but the crashes that were happening almost every 15 minutes seem to have abated.

Big thanks from me!

Adept III

Seeing as multi-display is in use here, the issues are very likely the same as those in regards to the SoC hardware bug that first-gen vega has. If you believe you may have found a solution (has to be over a month stable), check for it and post it here;

Journeyman III

Have a Radeon RX Vega 56

Did the bios update to newest

Did all this1.jpg

Still crashing after 30 to 60 minutes...


Mmhh 960mv sounds like a pretty extreme undervolt, your settings at p7 are near to 1600mhz which can be done but you must have really a good chip there.

What are you using for testing the stability of your undervolt ? What about you memory clocks ? 


To be honest i don't even really understand how all this works. I was just

looking for any possible solution, and this is the last thing o found.

Somebody dis this and said it helped. Should i go back to default settings?

Adept II

The settings us3r123 is using, is the one I suggested, except my power limit is set to 0% not 50%. 

If its crashing it can't be from the undervolt, when I was testing with too low voltage using Firestrike 3dmark - Radeon settings would tell me it was reset and I had to load it again and increase voltage and so on. Mine still working fine with same settings. Regarding the new bios flash I'm not sure what settings it sets the card to (and I'm not flashing my bios cos nothing broke) As far as I understand by changing wattman settings it defeats the object of flashing the bios, cos u still setting ur own settings and wattman using the information u putting into it. 

Us3r123 if u reset ur wattman settings to default (I would recommend keeping the fan settings) and continue to crash then unfortunately it seems the bios flash didn't work for u. If someone who has flashed their bios please post the default settings of new bios so we can use this info for further discussion

Adept II

Wow! Nearly a whole year later and OP also thinks we have a solution!

"I have been testing the new bios, for a week i think, no crashes.

UPDATE THE BIOS USING THIS VGA Bios Collection: Gigabyte RX Vega 56 8 GB | TechPowerUp  (or search for your manufacturer if its not Gigabyte )

Im using the default settings, with the lastest driver version,  turned off zero rpm,  changed the fan speed and power limit -50%"

Thanks, so much for all your help AMD! /s

I've been holding off doing this until I saw more people here post back with positivity, but looks like I'll be doing a BIOS reflash soon then. Great job to dahuckk‌ and also neopyhte‌ in this thread.

Journeyman III

Well... Not having black screen and 100% fans now. But Thread stuck in device driver now occurs.

Journeyman III

So It,s 2020 and i have same problem as hundred of users reporting here, strix vega 56 win 7 64 bits, random black screen fan 100 rpm. I was switching from Rx 480, before with rx480 on driver 18.5.2 not a single black screen on 3 years. 
I was trying today 19.12.1 seems more stable, but after a day i get black screen again, guess i will try 17.11.1 as alexx855 sugested. I just upgrade psu from sirtec 750W bronze to zalsman 1200w platinum, but it not the psu lol, it not eighther temp cause i just change paste and termalpads and temp are good in the 50-54 degree celsius in games.


I have been testing the new  vga bios as mentioned above in this thread, for a week i think, no black screens

Im using the default settings, turned off zero rpm,  changed the fan speed and power limit -50%