Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Adept II

Gigabyte vega 56 oc 8gb crash randomly all the time, black screen, fans 100%

Hello, im having this weird problem since i brought my new GPU a few months ago, my whole build is new, the GPU was the last  purchase, previously i had a R9 290x in this same build, all works perfectly!

The crash is sometimes a black screen on all monitors and fans turns 100% speed, nothing to do here just force shutdown, sometime i got a blue screen with the message, THREAD STUCK IN DEVICE DRIVER.

All this happens randomly, between 1 hours to 4 maximum,  while gaming and casually browse on my second monitor.

i have tried all the possibilities, clean windows install, a lot of drivers versions 18.x.x / 19.x.x, diferente pci-e socket, diferente PSU, two diferents power rails, undervolt, power limit +50%, GPU and motherboard BIOS update, basically all known tricks. 


My systyem:

  • AMD Graphics Card
    • Vega 56 Gigabyte OC version
  • Operating System
    • Desktop Windows 10 64bit
  • Driver version installed
    • 19.11
  •  Display Devices
    • LG IPS FULLHD (1920x1080@59Hz Active DP to HDMI adapter
    • 23MP55 (1080x1920@59Hz) HDMI
    • HISENSE (1920x1080@59Hz) HDMI
  • Motherboard + Bios Revision
    • Z370 AORUS Gaming 5 + Bios F10
    • Intel Core i7 8700k
  • Power Supply Unit  Make, Model & Wattage
    • Seasonic 750W Gold 
  • RAM
    • 16GB Gskyll 4133hz


The only solutions that works is the driver 17.11.1  

whql-win10-64bit-radeon-software-crimson-relive-17.11.1-nov10.exe - Google Drive 


I have been testing the new bios, for a week i think, no crashes.

UPDATE THE BIOS USING THIS VGA Bios Collection: Gigabyte RX Vega 56 8 GB | TechPowerUp  (or search for your manufacturer if its not Gigabyte )

Im using the default settings, with the lastest driver version,  turned off zero rpm,  changed the fan speed and power limit -50%


Radeon pro drivers seems to fix all problems 

429 Replies
Adept II

I have the same issue with the same card, also DP and HDMI connections if this is important at all. Also tried just about everything, undervolting, underclocking, increasing power limit, decreasing it, different rails and so on. I have Corsair 750W PSU, but it worked like a charm with my previous 390X. I did notice a pattern, after turning on the computer and gaming (or doing a stress test) for some time (on my computer it's usually no more than 10 minutes) a blue screen with THREAD STUCK IN DEVICE DRIVER will appear. If I only reset on each subsequent gaming/stress test fans will ramp up to 100% and a black screen will appear. If I turn it off then I am back to a blue screen.

Volunteer Moderator

Driver issues should be reported to AMD > AMD Issue Reporting Form 

Submitted to both Gigabyte and AMD. I was hoping someone might suggest a driver, if this is driver related at all, that works. I guess a driver automatically provided by Windows 10 works for alexx855 . I don't know what driver that is, but I will try it just as an intermediate solution.

I can confirm it is indeed a driver issue. Windows installs Radeon Software Version 17.7 and there are no issues with it. I will try higher versions and hopefully find out at which version the issue starts.

LMAO!!! I've been reporting this exact issue on my RX 570 since I got it last May and they STILL haven't done anything about it! Oooooh but the brand spankin new 5700 cards are getting a crap load of attention regarding issues.....

Adept II

It seems it is more complex than I would like it to be. Already on 18.12.2 drivers the issue is back, but a little differently - it takes longer to crash the system (about 30 minutes of gaming on my rig) and there are no blue or black screens only a total freeze. It does amount to the card being useless. We both have the same Gigabyte Vega 56 OC, but everything else is different.

MonitorAsus MG279Q monitor on DisplayPort (Freesync) + HDMI (TV)
MotherboardASRock Z170 Extreme6+
BIOSAmerican Megatrends P7.40
CPUIntel Core i7-6700K, 4 Cores, 4400 MHz (44 x 100)
RAM32 GB (4x8GB DDR4-2133)
PSUCorsair CS750M
Adept I


Finally i found people with the same problem.

I have the same gpu. Gigabyte vega 56 oc 8gb. I even RMA the card as my new build kept crashing. 

Turns out as you say its a driver problem. If i do a clean install of windows and let the default drivers installed the pc works perfectly.

If i update to any other version the crashes begin.

Hope we all find a solution asap. 


After more testing and a lot more reading I will RMA the card. It's a complex stability issue and I cannot wait/hope Gigabyte/AMD will stumble upon the solution any time soon.


nixsar i've read about a lot of people that sent the GPU to RMA, and they still have the same issue with the new ones, there are also topics on reddit about this, you can use the default windows drivers, these works perfectly, no crash in months, i know that it is not ideal, that was the reason because i opened this topic.

Adept I

If your problem is the same as ours i wouldnt recomend rma. I send it and they told me everything was ok. I gues even with a new gpu it would still happen. 


I am very lucky that the store I bought the card from will allow me to change the card for a Sapphire VEGA 64 with a little additional payment. I really don't think it's acceptable for a 400+ EUR card to use two-year-old drivers that will not even run every game, don't have Relive and don't use the cards to their full potential (probably the reason 17.7 drivers that come with Windows update are stable in the first place).


Do you have the same problem with the vega 64?


I will receive it on Monday and will report after testing.

After much delay finally received the new Vega 64 card a couple of days ago. The specs are below. Everything is working perfectly with 19.2.2 drivers after stress testing and gaming for more than two days straight. I can only conclude there was something very wrong with my Gigabyte Vega 56.

GPUSapphire NITRO+ RX Vega 64 Limited Edition (Vega 10)
MonitorAsus MG279Q monitor on DisplayPort (Freesync)
MotherboardASRock Z170 Extreme6+ (3 PCI-E x1, 3 PCI-E x16, 1 M.2, 4 DDR4 DIMM, Audio, Video, Gigabit LAN)
BIOSAmerican Megatrends P7.40
CPUIntel Core i7-6700K, 4 Cores, 4400 MHz (44 x 100)
RAM32 GB (4x8GB DDR4-2133)
PSUCorsair CS750M

Although changing model but not family seems to be evidence that Vega 56 hardware has some kind of issue, that does not rule out the driver issue theory. When searching, I've found out that the specific issue at hand (specially the 100% fan noise when black screen) seems to be only for the Vega 56, not 64 (from what I've seen, only the black screen issue affected the 64, but not the fan part). My conclution is that wheter Vega 56 has a critical hardware structure issue only shown in custom cards (you could go to the amazon page for the Gigabyte G1 Vega 56 and see the comments), or the driver has some instructions issue when operating a Vega 56. I would love that an admi or someone from AMD tech support came forth and explain which posiblities are true, if any.

You are right, it doesn't rule out the driver issue. However, my suspicions as to why 17.7 are working (on 18.5 it did crash for me although less often) is that they are not utilizing the full computing power and features of the card. You can indirectly confirm this by testing in games and benchmark software with the 17.7 driver and then run the same tests with the 19.2.2 (usually they worked long enough for me to perform short tests). You should see considerable performance gains with the latest drivers. Even more tellingly I could see considerable visual difference in quality on the same settings in games like Shadow of the Tomb Raider and Kingdom Come Deliverance, to name a few.

so what exactly can we do about this? This wasn't exactly a cheap card, and some of us can't even use it even after an RMA. If there is some straight up hardware flaw with the Vega 56, would it not just flat out take an AMD recall?


Unfortunately, if you can't return it or exchange it for another you don't have many options right now. One is to settle for 17.7 or 18.5 drivers, if those work for you, and hope it's only a driver issue that will soon be resolved. Another, more extreme option, is to test it in another computer and, if it works then, buy the same kind of motherboard for yourself and solve it like that. The last solution is just an idea based on some reports that these cards don't work well with a handful of motherboards. Can't tell you which ones, but there are posts here and there mentioning certain AsRock and Asus boards.

Well, my system is almost exclusively gigabyte and IS an ITX rig, so that makes things very awkward. I'll work my way up and see what is the most recent working driver, and go with that for now. I don't think this is hardware, that would be a VERY awkward issue. No idea if gigabyte's warranty on this card transfers or not.

Neet config, by the way!

Adept I

Please if anyone finds a fix for this post it here for everyone that has the same problem.

I installed the oldest driver I had laying around and haven't experienced a crash in 3 days.



Please keep this updated, i will try with this version also


terapia‌ where did you get those drivers? in the amd download page for vega 56, the oldest it is Adrenalin Edition 18.8.1


Downloaded them when they were new. But...

AMD Radeon Adrenalin Edition 18.5.1 Driver download 

Adept II

I have the same card gigabyte Vega 56 tried about every fix mentioned on the web .   fault black screen and fans ramp up or driver crashes all random times for 1 minutes to an hour .  So unstable and also runs so hot.  I have just started the RMA process as only two months old.    Never buying a AMD card again.     


Did you tried with the windows update drivers?  17.7 version, i sure this is a driver issue and not a hardware one, so probably you will have the same issue with the new one like other users already reported.


I'm going to ask them to change the card for a different model.  It's supposed to be designed to work with the latest drivers.  It works better with the stock driver but it still crashes, just not as much. The card get way to hot for my liking too.  I'm not going to except a replacement card.


Are you sure it was crashing with the windows drivers? its been months of hard working and gaming, no crash or temperature problems at all!


Yes, it still crashes with the default driver but nowhere near as much with the current ones, after a few minutes of operation I can't put my hand on the back plate it's that hot.   Just not what you expect of a card that's only 2 months old.  The problem has got slowly worse and worse it normally goes two or three driver failed and recovered errors then black screen and full speed fans.    Then you have to hard reset but it's so often but yet also random. I have tried over and under  settings on watt man and the TDR delay but nothing has worked.  Just so annoyed right now.  

Send the GPU back and buy a PowerColor RX Vega 56 Red Dragon instead if you can get one.
Gigabyte did a really poor job on the RX Vega 56 and 64 AIB cards.
The cooler on those GPU is no better than reference blower, yet they OC the cards out of the box.
They consistently crash.

If I were you I would not go near any Gigabyte AMD GPU unless you really have to - for example if it is the only 2 slot AIB RX590 you can get.

You should also be careful about ordering Gigabyte AMD GPUs.
They like to launch REV 1.0 version with lots of features and then produce REV 2.0 cards with those features removed.
Then the REV1.0 features get advertised but REV2.0 get delivered.
See this: Have you been a victim of a Gigabyte RX 590 "" Bait and Switch Purchase online? If so what action di...

Adept I

Has anyone tried updating the bios to the latest version? F5


First thing I did when the fault got worse, made no difference for me sadly .

Adept II

Hi folks, same issue here. I have been having this pesky trouble since december and I've try a few things, alas with no avail. First, rollback drivers: so far I have try to rollback the drivers to 18.7 (though I'm about to try the OP suggestion and I've just installed 18.5, will check later), but nothing. Update anything that I could think off: Windows, checked AMD beta drivers, BIOS update (I'm using TUF 470X Bios version 4207, 12/21/2018), I even tried to use that shitty AMD Master, which I totally NOT recomend. Then, the hardware: so far, I only saw people recomened switching PCI molex lanes and trying not to use one single lane for the same card, which I'm not doing. I'm runing the card with a EVGA G2 Supernova 1000w PSU. My last resort was messing with global wattman and I tried the following config: STAGES 6 and 7: 1536 Mhz (I also tried some combinations with less frequency clocks, but didnt change anything) Voltage control (mV) 1100 in the afordmention stages, and Power limit, I have tried both +50 and -50 (also some combinations with +/- 25). Zero, no changes, only some variations in how much time the card would take between crashes. The only "permanent solution" I have found is RMA the card, but if what you people say is true, it's just the same thing. I'll try with both 18.5 and 17.7 drivers and see where it gets me. Just for the sake of information, my config is as follows: Ryzen 1800X (3600-4000 running at 3800), 24 GB DDR4 2400MHz, TUF 470X Asus, and the PSU I mentioned before. I sincerly hope this fraking buisness gets a swift resolution and, if it is a hardware issue, that AMD come clean to the customers and just gad damm say it.

Did you try with the windows default drivers? as mentioned above, it's the only "way" that i've found where i have 0 problems and not crashing at all! not ideal, but still working

Hi there, thanks for the reply! The 17.7 (I think those were the default drivers you mentioned above) are my last resort. I'm still testing the 18.5 driver. So far, +4 hours into Civilization IV have yeld positive results since HW monitor states almost 90-95% GPU ussage (1550 mhz), 72 max temperature (65 average), and no crashes so far (Wattman reported 99% peak and 80-70% average usage with similar temps). As the day follows, I'll keep testing with more demanding software (Apex, RE2 remake, or even Unreal Heaven Benchmark, though the last one is not a good source of information in this case since I had the test benchmark runing for 3 hours straight, with 19.2 drivers, no crashes, but I still had a crash today early in the morning playing Civ IV). I'll keep you guys posted tomorrow with more news, however, If you guys found a solution to this (like using 17.7 default drivers), keep using it. Wait until the release notes say "black screen 100% fans crash solved for vega" to change drivers. At least that's my advice. 

Adept II

I would say it's a hard ware issue on certain batches and my mate has same card and he has had no problems at all with his card.

Gigabyte or AMD admitting there is a problem is not going to happen lol


I took a look at your comments and your issue seems to be a little bit more complex. I have detect NO issue as regards temperature and termal throttling. Setting the target temperature at diferent temperatures (60, 75 or 82) seems to have nothing to do over the discussed issue. And if this is a "bad hardware batch" why some people in this post have reported that, when sending to RMA, the RMA people have reported no issue with the "faulty" card? Or that when recived a new card, the problem persisted? For information's sake, putting a hand over a piece of hardware and noticing that it is "hot" is not an indicator of anything by itself alone, that's why there are dedicated software for temperature and performance monitoring. I'm still testing the 18.5 drivers and I will give an update if something new happens.  

if this is a "bad hardware batch", how they explain that windows drivers works perfectly fine? in my case at least, no crash in months, im sure its a software problem, vega still young.