Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Adept II

GCN 1.0 UVD Clock Speeds Get Locked

1 Solution

Really glad to hear that.

This issue has now been resolved in 18.8.1.

View solution in original post

51 Replies

I've opened a ticket with engineering. If i have any further updates i'll post them here.

Journeyman III

HI , i might found a quick fix you guys , at least it works for me , i made an account special to tell you this fix as i searched for 1 in a long time.

What i did its very simple , ive downloaded RadeonMod and on the Tweaks Tab i disabled ULPS then pressed restart drivers. (the last option there is UVD Clock FIX , and its on by default if its not just enable it!). Now i can be on youtube and twitch and play a game at the same time and the card uses the boost clock. I have an Asus r9 280x , before doing this if i had youtube/twitch or anything that used UVD and i was starting any game the clock was sitting at 970 now is sitting at 1070 as it should. Hope this will help you guys too. Best Regards.

RadeonMod (Tweak Utility) | guru3D Forums

Disabling UPLS isn't a solution for the problem I've listed above as "1)", which is the perma stuck UVD clocks. It might be helping you with "2)" (uvd to correct 3d clock transitions) under specific circumstances, but I've just tested with mpc-hc playing and then start gpu-z render test, and fails to apply the proper 3D clock.

In the past, the best way to solve "2)" was to use OC apps that applied clocks in "non-official mode with power play support" such as MSI AB and Trixx before it was removed from drivers. By that way, 3D clocks could be started from a UVD state, not requiring the card to be at 300/150.

Journeyman III

Hello, i just have the same problem but i was not aware what it was before some research, for me the bug is on since computer is turned on.

I got an Asus strix r7 370, with factory OC to 1050mhz but I was kinda worried about my idle temps being so high (56ºc) so I changed the thermal paste and saw no change at all, I've realized that on idle was very hot and on load it won't even do the factory OC, and was only at 925mhz (the stock clocks) and it supposed to run at 1050mhz, then I downloaded the GPU tweak II from the asus page and saw that even won't overclock at all.

After some days on google, I've used DDU to reinstall the drivers (I've tried with the last 3 driver versions available to date) and tried disabling ULPS and nothing, I saw a video about editing the bios so the UVD state has the same clocks as the performance state but i don't want to do that, I thought this was fixed and yet many people on the internet noticed this and the RX series has the same problem too and i guess some people has the bug going but won't even noticed because they don't know about computers.

for me bug is on since startup (win10 up to date)

[Normal operation]
ASUS STRIX R7 370 (is overclockable)

Load (1050mhz core / 1400mhz vram)
Idle (300mhz core / 150mhz vram)

Temps (idle 35ºC / Load 69ºC)

On the GPU Tweak II there is an option called "Overclocking range enhancement" that do what it's name says but has to disconnect/reconnect the gpu, that allows to the gpu be back to the normal operation on which drops the temps significantly.

[My case]

ASUS STRIX R7 370 (is NOT overclockable, you can move the settings but it won't change anything on the HW Monitor)

Load (925mhz core / 1400mhz vram)

Idle (450mhz core / 1400 mhz vram)

Temps (Idle 56ºC / load 66ºC)

I took a peek on the bios editor and downloaded the bios knowing what's going on and yes those are my UVD settings and not the performance clocks.

Temps and power are a matter that concerns me, since the normal operation only reach 35ºC and with this bug and from the start reach 56ºC at idle!, I had to set a custom fan curve just to keep it at 50ºc idle all the time.

So please I hope this could get fix soon, I bought this card because the RX series is so expensive on my country right now, and knowing the bug affects the RX too I have to check on my friends to see if they had the bug too and are unaware of it, so i write here to let known to AMD people that there is many more people with this bug than you may think.


If you wan't an immediate solution without frequent manual driver resetting or bios editing, your only option ATM is to use 16.7.2 drivers.


Thanks! so... this is a driver fault then? do you think if do a clean reinstall of windows could I get rid of the bug?, anyway I'll install the 16.7.2 thanks again.


Don't bother reinstalling windows, providing you haven't something running in the background that causes those clocks (so then it's a different problem related to "2)", as I explained on a previous post on a post), this issue ("1)") will happen on any driver after the 16.7.2 set. Just test them and see what happens.

Adept II

I have an msi r9 280 in my bedroom pc

and can confirm that the uvd bug has been present since 2016

how amd say they cant reproduce it is beyond me

its simple to reproduce

they clearly arnt using the right card or are not monitoring clocks properly


The stuck clock bug may be fixed but

the clocks arnt

Play AVC video on Media Player Classic on monitor 2

Start Game on monitor 1

Results in the R9 280 running at UVD speeds even though a game is playing

e.g. 827mhz instead of 1000mhz

oopsy poopsy

can we expect a fix for this quicker than 2 years?

Community Manager

The issue reported by the OP has been addressed.

If you have a different issue, open a new thread on it.

Uvd bug returned with the version of drivers of AMD 18.12.2 again. Help please

Uvd bug returned with the version of drivers of AMD 18.12.2 again. Help please!


Yes, this issue "2)" has been in CGN 1.0 cards since as far as I remember (late 2013', since didn't have one before).

They simply won't switch to 3D clocks if a 3D app is started at the same time something is already making the card use UVD clocks, 3D clocks will only be correctly applied if the card is resting at 300/150. This was tolerable with the first gen non-boost cards running stock, because the highest UVD clock is equal to the 3D clock as in my example above. The nuisance would be apparent when using a OC over the "true" 3D clock, as it would be ignored.

But it becomes a problem on boost cards where the highest UVD clock is considerably lower than the boosted 3D clock, like on your 280.

The driver fixes note seems to address this issue in the way it's phrased, but it only solves the stuck UVD until reboot problem (still, MUCH appreciated!).