Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Journeyman III

Games keep crashing with R9 280X

Hi, I signed up here just now to seek some advice regarding my problem: I can't play any games (besides TF2 and very old ones) without a crash happening in 2-20 minutes.


Games that didn't work when tried out where: GTA V, The Crew, PUBG, Witcher 3 and Rise of The Tomb Raider.


I just play the game and at some point the game image freezes, the sound continues. GTA V and PUBG gave me their "crash screens" after that, TW3 just closed when I tried tabbing out and The Crew was crashing with the message "The Crew.Exe stopped working". Tomb Raider just closed to the error message.



My PC has the following parts installed: i5 7600k, Gigabyte R9 280X Windforce, 8GB DDR4 Ram by Corsair, Asus Prime Z270-P, beQuiet Power Zone 650W.


I then uninstalled the driver using Revo, I had used the 200 series driver. I rebooted my PC and used the auto detect driver and if I recall it correctly, it is a different one now. The issue however still persists.


I am aware of that the GPU is OC from factory, but I didn't change any settings to that manually, I (have to) have MSI Afterburner and Riva though, maybe those did something to it?


Temps never exceed 70° on GPU and 65° on CPU. Crashes happening mostly when GPU at full load.


The GPU was used by a friend before [only for gaming], since he upgraded to something better I could have his. Speaking to him about this he told me he could fix the issue with a reinstall of the drivers. What I also did was running memtest86 with no errors. I updated my BIOS, ran 3DMark and Heaven Benchmark and both crashed at some point. I also removed the GPU to see if I still got crashes. The only thing I had happen in The Crew (the game I used for testing since it crashed fastest) with my Integrated Grpahics was low fps. I also ran Cinebench which surprisingly didn't crash, I got  CPU: 522 cb and OpenGL: 103,47 fps scores


You guys have any idea for me what to do?




1 Reply
Volunteer Moderator

You did not supply OS or if this is a laptop. So, I ASSUME you have Win10 and a desktop computer. INFORMATION REQUIRED WHEN POSTING A QUESTION

Please delete  (uninstall) any third party graphics controls (Afterburner,etc) as they conflict with Wattman. Then...clean install the proper driver.

Clean Install AMD Graphics Drivers

Correct desktop drivers > Desktop