Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

FRTC dosn't work in Game Profiles

This has been a problem for while since I've bought my RX 480 near launch. FRTC is a great feature that I would love to use for some games. Specific framerate limits for certain games, where I would like.

There is a problem with Frame Rate Target Control though and that is that is doesn't work when set in the game profiles and also doesn't seem to work depending on certain monitor's as well. I have a Freesync monitor where FRTC seems to more consistently work. I set the FRTC setting in the game's profile though and it doesn't work but if I set it in the Global Profile it'll work. Now this is useless because if I want to set a lock in one game to 30 and the other to 120, I have to keep going into Radeon Settings and changing it before I play and, that's very annoying. I also have seen the FRTC setting in the Global setting change when I've change it in another game profile as well which makes no sense. As for non Freesync monitors like my TV that I use connected to my PC, FRTC doesn't work at all.

I just recently bought a RX Vega 56 and the problem is still around and this it very disappointing to me.

Any one know if there are any plans on getting this fixed? I've submitted tickets on this many times but problem still not fixed and I'm not the only posting threads online about FRTC not working.

I feel if this feature is not going to work, AMD should remove it from the settings.

AMD chill seems to work all the time but introduces some frames stuttering.

9 Replies

Same issue with me....Windows7. I have filed numerous reports...with "It's being looked in to" response. I tell you what else doesn't work...Wattman fan and temperature settings, and Power Limit....Profile settings do not override the Global settings.

I hope you (and anyone else with this problem) report it here > Email Form


Your service request : SR #{ticketno:[8200802193]} has been reviewed and updated.

Response and Service Request History:

I would like to inform you that I have filed a report on this issue internally. Please rollback to the prior working drivers, and wait for the future driver releases.

Thank you.

In order to update this service request, please respond, leaving the service request reference intact.

Best regards,


AMD Global Customer Care

The problem with that response you got it that none of the previous drivers have completely worked with these features. It's been the same problem for like 2 years.

Also yes as a side note, I also have problems with AMD Wattman as well, are you have said, which I have reported multiple times. It'll just reset my OC settings randomly. I'm not even sure if it's a stability problem or not because it'll just randomly be reset on system start up sometimes not during long periods of gaming or anything. Or even just the Powerlimit settings will be set to zero again from the +50 I set while all the other settings are the same. None of this makes any sense to me. I've been told that if I have a 3rd party GPU overclocking app installed than that can cause the issue, but I don't have one installed.

I'm tired of these driver issues. Like these are great features that are in Radeon Settings but if they are not working correctly or consistently than, what they heck is the point?

Is there anywhere else where my issues can be reported to because i have tried this method before. I would really like these issues to be fixed but obviously my problems, that have been around for years now, aren't heard. There was a point where some of these issues where in the known issues part of the AMD drivers but never saw them show up in the fixed issues with a driver release since they dropped off that list.

FRTC worked great for a while in Profile settings......I can't find a driver now where it is working. Only in Global settings. The link I gave you is the best there is read by a human and will be responded to. Reference my ticket number...I went through quite a bit with them over the months.

Another issue I have with any semi-recent driver is, it does not start the AMD app when the computer boots...there is no icon in the taskbar and no program in System/Startup:

I am beginning to wonder if there was a change to the installer itself. Did somebody make a change to it....maybe that's why the older drivers won't install correctly either.

This has been fixed (for me) with the new 18.7.1 drivers. All Profile settings will now override the Global settings.



Great sounds good. I'll give it a try, thanks for letting me know this!


I literally just tried the new driver version and the problem is still there. I just witnessed it happen. I Enabled FRTC in Hellblade for 30FPS only (I want to play the game at 4K 30fps smoothly without frame jumping around), enabled the profile and went to play. I launched the game and the framerate was locked to 30fps as i set and the game was running fine. When I left out of the game and went back to Radeon Settings, in the Global settings the FRTC was now enabled (I did not touch this) and set to 30FPS. I disabled this in the Global settings and then went back to Hellblade's game profile and made sure the FRTC was still set to 30FPS and enabled. I launch the game again and now the Framerate lock is not working anymore, unless I turn it on to 30FPS in the Global settings too.

This is obviously an issue, especially since settings are turning on without me touching them with no real reason or warning that this is going to happen.

Must be something with such problem on Win7. That's a bummer.


A year later and I now have this exact problem, with games automatically changing the global FRTC when their own is activated. Are they ever going to fix this? The strange part is I didn't use to have this problem, though I was always on Windows 10.