cancel
Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

lfx64
Adept III

FRTC disables itself after reboot.

Frame Rate Target Control keeps disabling itself after reboot or when the system wakes. I've had countless drivers over the last year and as far as I am aware it has never stayed enabled on any driver. I even use DDU and safe mode and still no. I know it CAN work because I enable it whenever I turn my PC on by going into the AMD software and turning it on and it will remain that way until I reboot. Frankly I am tired of it. A search online seems to show that this is actually a fairly common problem that has been around for a few years.

I have Windows 10 64 Pro. Up-to-date.

Gigabyte AX730 Gaming K7 rev 1.0 (had numerous BIOSes and no change)

Sapphire Radeon RX 580 Nitro+ 8GB

2x 8GB Team Dark Pro 3200 DDR4 (Dual Channel)
Seasonic Focus+ Gold 850W PSU
No AV conflict.

What gives? I really need to use this because I don't want to use Vsync or Enhanced Sync, I want to just have them all off and cap their FPS at 90-100fps. I have a 60hz monitor and I don't intend on upgrading it for the sake of two or three games.

0 Likes
10 Replies
kingfish
MVP

Re: FRTC disables itself after reboot.

In the game profile/Wattman....enable 'Histogram' and then reboot your computer. This will fix the issue for that game...the Profile setting is not overriding the Global setting.

Also, try disabling Fast Start.

The Pros and Cons of Windows 10’s “Fast Startup” Mode

0 Likes
lfx64
Adept III

Re: FRTC disables itself after reboot.

Profile Wattman? So I have to do this for every game that I want to use FRTC on? That's ridiculous. Histogram isn't there for Global. I want AMD to fix this so FRTC works in the Global graphic profile. I want to be able to set a max FPS of 100 and use Enhanced Sync to prevent tearing. As it currently stands, in menus I am getting anywhere between a ridiculous 300-2000fps, completely pointless frames, then the normal 62fps (E-Sync) at 1080p for all my games.

If there is an incompatibility between FRTC and E-Sync, that is fair enough, I can do without E-Sync, however I know for certain that even with E-Sync off, FRTC still resets itself.

So I have to disable another feature because AMD won't or can't fix this? Disable Fast Start-Up because of a problem which is now a few years old. That's not really acceptable is it. Also, while FRTC wasn't something I chased in cards, they really shouldn't be advertising it on their packaging if it doesn't work.

0 Likes
kingfish
MVP

Re: FRTC disables itself after reboot.

Uhh...fast startup is a Windows/Microsoft program. You didn't read the article did you? This is a windows setting...not a AMD/graphics setting. It is not in the bios.

How hard can it be to enable histogram? One click to much for you?

Send your report to AMD > AMD Issue Reporting Form 

0 Likes
lfx64
Adept III

Re: FRTC disables itself after reboot.

What's with the snappy, unjustified response? THERE IS NO HISTOGRAM OPTION IN GLOBAL WATTMAN! I already said! Is reading too much for you? I do not give a care in the world about Profile Wattman! I said Global; G. L. O. B. A. L. There is no Histogram option that I can see within Global Wattman. Go and check for yourself, unless you have some magical version that isn't released to general users.

In future, before you get start being so passive-aggressive and being incredibly rude to people, may I suggest you read things properly for yourself.

0 Likes
kingfish
MVP

Re: FRTC disables itself after reboot.

Fast Start up is a procedure you change in BIOS and having to change that for the sake of a game "

"I didn't need to read the article"

Let me read it to you:

Windows 10’s Fast Startup (called Fast Boot in Windows 😎 works similarly to the hybrid sleep mode of previous versions of Windows. By saving the operating system state to a hibernation file, it can make your computer boot up even faster, saving valuable seconds every time you turn your machine on.

Why You Might Want to Disable Fast Startup

Sounds awesome, right? Well, it is. But Fast Startup also has its problems, so you should take the following caveats into consideration before enabling it:

  • When Fast Startup is enabled, your computer doesn’t perform a regular shut down. Since applying new system updates often requires a shutdown, you may not be able to apply updates and turn your computer off. Restart is unaffected, though, so it still performs a full cold shutdown and restart of your system. If a shutdown doesn’t apply your updates, a restart still will.
  • Fast Startup can interfere slightly with encrypted disk images. Users of encryption programs like TrueCrypt have reported that encrypted drives they had mounted before shutting down their system were automatically remounted when starting back up. The solution for this is just to manually dismount your encrypted drives before shutting down, but it is something to be aware of. (This doesn’t affect the full disk encryption feature of TrueCrypt, just disk images. And BitLocker users shouldn’t be affected.)
  • Systems that don’t support hibernation won’t support Fast Startup either. Some devices just don’t play well with hibernation. You’ll have to experiment with it to see whether your devices respond well or not.
  • When you shut down a computer with Fast Startup enabled, Windows locks down the Windows hard disk. You won’t be able to access it from other operating systems if you have your computer configured to dual-boot. Even worse, if you boot into another OS and then access or change anything on the hard disk (or partition) that the hibernating Windows installation uses, it can cause corruption. If you’re dual booting, it’s best not to use Fast Startup or Hibernation at all.
  • Depending on your system, you may not be able to access BIOS/UEFI settings when you shut down a computer with Fast Startup enabled. When a computer hibernates, it does not enter a fully powered down mode. Some versions of BIOS/UEFI work with a system in hibernation and some do not. If yours doesn’t, you can always restart the computer to access BIOS, since the restart cycle will still perform a full shutdown.

RELATED: How to Make Your Windows 10 PC Boot Faster

If none of these issues apply to you, or you can live with them, go ahead and try Fast Startup out. If it doesn’t work how you expect, it’s easy to turn off. And if you decide you just don’t want to use Fast Startup, there are plenty of other ways to make your Windows 10 PC boot faster.

How to Enable or Disable Fast Startup

Deciding whether to bother with Fast Startup actually takes longer than turning it on or off. First, open up your power options by hitting Windows+X or right-clicking your Start menu and selecting Power Options. In the Power Options window, click “Choose what the power buttons do.”

power options

If this is the first time you’ve messed with these settings, you’ll need click “Change settings that are currently unavailable” to make the Fast Startup option available for configuration.

available options

Scroll to the bottom of the window and you should see “Turn on fast startup (recommended),” along with other shutdown settings. Just use the check box to enable or disable Fast Startup. Save your changes and shut down your system to test it out.

fast startup

If you don’t see the option at all, it means hibernation is not enabled on your machine. In this case, the only shutdown options you’ll see are Sleep and Lock. The quickest way to enable hibernation is to close the power settings window and then hit Windows+X and open Command Prompt (Admin). At the Command Prompt, type the command:

powercfg /hibernate on
0 Likes
lfx64
Adept III

Re: FRTC disables itself after reboot.

I did actually read the article because I changed my mind (I am allowed, after all) so sorry for wasting your time posting all that. What's with the missing Global Wattman Histogram? Is it profile specific? If this is the only solution then jumping through hoops to get FRTC to stay enabled sucks... quite frankly.

I'll try this out but this seems a bit ridiculous. FRTC has been around for a while now and doing some digging online shows that lots of people have had issues with it.

Edit: disabled Fast Start-Up, rebooted. FRTC is disabled again.

0 Likes
kingfish
MVP

Re: FRTC disables itself after reboot.

Make sure you have the latest driver 19.1.2

Clean install the drivers while your computer is disconnected from the internet. Do not reconnect to the internet until you have completely uninstalled/installed the new drivers and rebooted your computer.

Histograph is only available in profiles. The 'fix' I mentioned ensures the profile loads...and uses the profile setting..not the Global setting. I know as I had the same issues months ago.

There are many different reasons that could be causing your issue...third party controllers (Afterburner, Trixx, Asus, etc) are a common cause.

It is not hard to try these fixes, or revert to a driver that worked for you.

0 Likes
lfx64
Adept III

Re: FRTC disables itself after reboot.

I've done everything suggested and it still always disables itself after reboot. I will just leave it off. Even if I enable FRTC for a single game (in profile), it will still be disabled after restart. I've prevented anything like Trixx from launching, I've disabled Fast Start-Up, I've enabled Wattman Histogram on profile. I've booted in safe mode and used DDU, restarted whilst not being connected to the Internet and installed the latest driver 19.2.1.

Considering that FRTC comes with a host of other issues (judging by a simple search online) since its implementation a few years ago, I'd advise AMD and it's partners omit any sort of advertising involving FRTC as it simply doesn't work for everyone. They've had years to correct any issues with it and while I wouldn't be surprised if some games didn't play nicely with it, the fact that it simply resets itself every, single, time I boot my PC up is unacceptable.

I appreciate the help but I'll just have to rely on regular old in-game settings or standard V-Sync.

0 Likes
kingfish
MVP

Re: FRTC disables itself after reboot.

I don't use FRTC anymore myself. Enhanced sync is way better...if you enable it, be sure to dis-able vsync in the game settings.

0 Likes