Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Adept I

FreeSync flicker source solved?

Let me start by saying this is a huge issue for some of us. If you google freesync flicker you get tons of people suggesting all sorts of things but no solution. This issue has also followed me through several complete system builds with both my Vega 64 liquid and now my Radeon VII has it.

For those who dont know this is what the issue is  (video is not mine)

I'm connecting via display port on an Acer XF270HU. The problem goes away as soon as you turn off Freesync just like in the video. It was suggested that its being caused by relive by a kind Reddit member. 

I turned off Relive via the toggle in the Radeon console but still have the issue. What I found is if you do a fresh install of the driver and choose NOT to install relive when you click the relive section in the driver you have no Freesync flicker at all. 

I know this is a decent ask for some of you with this issue but please try reinstalling your driver but dont install Relive. If this works for you please post your findings to this thread as well as report here AMD Issue Reporting Form 

12 Replies

You still good? Just got my radeon and I have some flickering with multiple monitors as well. I did a Mobo bios updated on my Asus X470 to 4602 and just did a clean install of GPU drivers but I did install relive before catching this post. Not sure if I will still have the issues yet. 

Adept I

I try this and not working for me without relieve also have screen flickering. I have a lot of flickering when the pc start for the first time. If restart the pc all problems are resolved. Now I need to live with this when I whant to play games, I asume need to restart the pc two times.
I have a amd radeon vega64 with this monitor  lg 34UC79G-B


This Samsung CFG70 & CFG73 Freesync flickering fix - YouTube  resolve my problem with

FreeSync flicker


After doing this on Xiaomi Mi Surface Display I got flickering gone. As FreeSync. It's still enabled in Monitor settings and driver, but monitor is still at 144 Hz instead of equaling to game fps (~90 in this case of PUBG on High+Ultra running on Radeon VII)

Also strange thing - in Fullscreen mode it flickers just whole the time

But in Borderless mode it flickers only on frame time spikes

Also tried decreasing lowest range value from 48 to 30. I got just nothing changed again


I found a Solution just right now for all Monitors that suffer from flickering if you turn Freesync on its not the monitor producing that flickering its a option in amd adrenalin that is enabled called freesync premium. If your monitor only have standard freesync turn that off. You have to go to Gaming and on the right side where you can see Amd Freesync above that ther is a button called Global Settings click on that and then you will see the Freesync Premium option you can turn on or off.

I hope i could help with this solution ^^.


I just realised that the Freesync Premium option i mentioned turns Freesync off if you switch it.  :smileyfrustrated:

So flase alarm sorry i thought for a moment its meant to support only monitors that have Freesync Premium so why should they call it that way... strange.

It only turns on VRR = variable refresh rate thats it.


Journeyman III

I just end up turning of freesync. its unplayable if i use it. thats how i solved it. which kinda sucks since its not a solution Im happy with..

Monitor: Samsung CF791
GPU: AMD radeon VII
CPU: AMD Ryzen 7 1700x
MB:Gigabyte Aorus GA-AX370-Gaming 5, S-AM4
RAM: 4x8GB HyperX Predator DDR4 3200MHz 


I ocasionally have this problem in certain games, trying to tie down the fps with tfrc works as a fix most of the time but some games just don't cooperate. 

7 Days to Die is a pretty prime example of a game that doesn't like having the radeon chill range set to the monitor freesync range - just mad flickering.

Journeyman III

This is kinda sad. The recommendation from 2019 to NOT install ReLive to avoid the flickering issue is still a valid solution in 2023 for the newest driver. I had insane flickering, which could go away if FS is disabled. Reinstalled the same driver, chose Minimal install (which excludes relive and perf tweaking). Maybe it's actually perf tweaking feature that was causing the issue, but not sure, I did not use it after all.