Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Adept I

Firepro s9170 showing 43 error on windows 10


At work we have a Firepro S9170 not used for now. I'm trying to test it.

Windows 10 automatically installed a drivers, which to be the same I managed to find on the internet for this board and this OS.

I have read on the internet this error could be caused by a bad BIOS... But I am unable to find anything about the BIOS of this card.

On AMD website, only linux drivers are available. Is this card suppoed to work on windows ?

Thanks for your help

10 Replies
Adept I

Note that under Ubuntu 18.04, using lspci, the card show up as a FirePro w9100...

Community Manager

This card is ONLY supported under Linux, it will not work under Windows.

Ray_M is correct since at AMD Download page it only shows LInux drivers.

But under the latest Professional GPU card AMD Driver it shows this: 

Seems like it is a typo that AMD needs to correct when it mentions "+ all other AMD FirePro TM S Series products"

So it seems like AMD stopped supporting Windows 10 on the S9xxx series Professional card.

EDIT: Deleted out-dated previous AMD Driver information to prevent confusion with previous reply from RAY_M.

Adept I

Thanks you all for the help.
I'll try out an old drivers, see if I manage to get anything working.
the install on linux is not straighforward either... I'm getting error at the end of install. I'll try windows once.


I deleted the out-dated information on the previous AMD Driver since it doesn't apply here. That driver is only compatible with Windows RS2 and AMD indicates that only Linux drivers can now be used for your GPU Card.

What type of errors are you getting from both Linux and Windows when installing or after installation?

EDIT: This is something I should have inquired from the beginning. What are your Computer specs or setup. Make & Model of Motherboard, CPU, GPUs, etc. What versions of Windows 10 are you using and Linux OS versions. What BIOS and CHIP Set versions do you have installed?

If this is a Server type environment that you are working on, I suggest you open a Thread at AMD Server Gurus‌. Possibly someone there may be able to find out what you are doing wrong but you need to post your computer setup.


Actually, I just have this board at work, which I don't know if it's working or not.

I picked a PC that was not used, it'sa DELL precision T5500.

Graphics : 512MB AMD FirePro 2270
Memory : 8GB (4x2GB) 1333MHz DDR3 ECC RDIMM

Processor : Intel Xeon Processor E5-2609 (Quad Core, 2.40GHz, 10MB, 6.4 GT/s)

I installed Ubuntu 18.04, tried to install the amd driver, but Figured out it was for 18.04.2, so I uninstalled the drivers, updated Ubuntu to 18.04.3 and reinstalled drivers.

But since it seems like some libraries are missing. If I try to start blender for example, it crash immediatly.

I don't know if the fact that I have 2 graphic card can be an issue. The firepro s9170 only have a display port, hidden behind the brackets, so it was clear to me that I needed another GPU for display.

Today I'll reinstalled a fresh Ubuntu 18.04, update it, and then install AMD driver. I may have messed up something the first time...

This is the only AMD Driver I found for your Legacy FirePro 2270 from AMD Download page: 

The driver page: 

Not sure if this driver also supports the S9170 GPU card or not.

This looks like AMD Forums resident expert fsadough on GPU cards will need to give you advice about having those two cards on the same motherboard and to determine which AMD Driver you need to install to get either one or both Professional GPU cards working correctly.

In my opinion if you need two different AMD GPU drivers than you have a problem. Since one driver could be in conflict with the other driver.

NOTE: The S9170 is not designed to have any monitors connected to it according the this Tech Website Specs on the GPU Card: AMD FirePro S9170 Specs | TechPowerUp GPU Database 


Yes, I saw the same thing, which is why I edited my previous reply. But previous AMD Professional Graphics driver 17.Q.4.1 shows under Windows 10 as S9170 being supported: 

So unless that was a mistake in the past, seems like AMD did at one time support the S9170 with Windows 10 drivers. But now seems like AMD dropped support for Windows entirely but not for Linux.

Is the above information incorrect? 

EDIT: The OP has tried with Linux with problems also. Does he need to remove the older FirePro 2270 Professional GPU card for him to be able to make his S9170 work in Linux?


I just setup ubuntu 18.4.3 no the computer. Without installing anything else (the 2270 display GPU works fine to display).

I then plugged in the S9170

Tried to install the drivers using --compute option, which setup drivers for headless operation.

I can't reboot, Ubuntu got stucked before reaching the session login.

I'm installing a fresh Ubuntu again.

The amdgpu install script has two arguments which I think could be relevant for my issue.

The --no-dkms option, and the --compute option

The first one keep the current kernel untouched. And the second one should install only opencl, support.

I'm sorry, I'm struggling here, I'm quite familiar with linux system use, but the kernel and drivers stuff are a bit beyond my knowledge