cancel
Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

0v3rkill
Adept III

fan control doesnt really work on manual.

I put the graph my self and I can see the fans still work on their own. They don't seam to understand what I am telling them to do. They always start spinning around 55c and that creates vibrations on the chassis of the card. I have a 590 black edition from XFX. Please make the fan controls use the graph. I am also using the latest driver 20.3.1

Here I have attached a picture so you see that the fan is not moving at all when it's actually at 47c. . It starts moving around 55c. I want the fans to move gradually. Not go from 0 to 2000+ every single time.

1 Solution
28 Replies
0v3rkill
Adept III

I noticed in this new 20.4.1 version the fans are actually moving exactly with the graph. Then I restarted a few times and I checked back today and They were back to not moving how I want them. So I loaded the profile ones again and it did work, again. Something in there is making the driver forget I have it set to manual, the fans that is. Ill keep you guys up to date. Let me test this out a bit more

Yeah I'm in the same boat. I went from 20.2.1 I believe, and the fan control wasn't working then. It constantly turns on the Zero RPM mode, causing my GPU to get to around 55C as well before it stabilizes. This is unacceptable. It does not remember settings. This has been going on for months. AMD's incompetence is overwhelming.

AMD, GET YOUR ACT TOGETHER!! Zero RPM, when turned off, shouldn't be overruling my decisions.

You all should report the issue and what is fixing it to AMD so they can incorporate a fix in upcoming drivers: https://www.amd.com/en/support/contact-email-form

0 Likes
chad27
Adept III

I have had this same issue far as fan curve going flat etc.

mickeekung
Challenger

I set fan speed to 100 percent but it's showing 0 RPM. Is it normal?

no that is not normal at all

chad27
Adept III

Don't sound normal,but im no expert. Have you looked at them to see if they are on?

0v3rkill
Adept III

ok. I did a little video explaining what was the problem and a little work around for now until AMD fixes it for good. I also inserted the video to my first post in case there are people out there in a hurry with the same issue and they dont feel like reading all the comments or they just don't feel like scrolling down.

I booted my system up this morning and check the settings and they are still there. Its been so random on when it resets my settings. After a black screen yesterday the setting reset also.

yes when they get reset is annoying too. But it doesn't have to be reset for the fan not to be working. You can see the graph I made in the video and the fans were not moving at all. I had to trigger it in order for it to work. So what you do is save a profile and every time you start your pc apply the profile. At least that's a little work around for now. I hope it works for you.

0 Likes
misteright
Adept II

I'm using MSI Afterburner's fan curve but when using 1440p or more my screen will blink to black every a few seconds. Anyone had this problem? RX 5600 XT btw, RX 580 running just fine with fan curve.

hmm, that is weird. My card is a 590 fatboy black edition and my wife and daughter have 580 XXX and we all have the same exact problem. I tested my little remedy on all of them and they all work after I reapply the saved profile. They are all XFX Video cards. Been using XFX video cards since 2002 or less. I remember Giants: Citizen Kabuto and Sacrifice just got released. Cause I was playing that like crazy.

0 Likes

I don't know the blink doesn't happen with 1080p and my RX 580 running just fine with fun curve. So i always turn off the fan curve and instead manually set it to 70% when gaming.

Glad i'm not the only one with fan control issues.

I always disable Zero RPM and enable Advanced Control then set my own preferred curve but more often than not, when i restart my PC i have no GPU fan activity until i hit 50 degrees.

When i go into Adrenalin it can still still show my fan profile and the manual setting and still have no fan activity until i reset and redo it... Often though it has just reset and enabled Zero RPM automaticaly

chad27
Adept III

Mine is xfx 5600xt

0v3rkill
Adept III

the problem is still there in this new driver 20.04.02. Nothing has been addressed yet.

I have a new Sapphire rx570 itx and the fan increases past 3K under load - it sounds like a lawn mower.  No matter what maximum percentage I use for the fan control, it slowly climbs to 3.6K+

MSI Afterburner appears greyed out for me when I install that as well. 

look at your temps. if it's reaching 85c or so it's justifiable. Is better to have a loud card that works than a dead fried one that doesn't, no matter how quiet it is now. But you said that it gradually goes up. My situation is that it doesn't go up gradually. Mine you can see in the video. Starts turning at 59 or so and stops at 49 or so. Creating jolts from 0rpm to 2k+rpm and noises when it starts instead of gradually working it's way up like I drew the graph.

0 Likes

Ok thanks.  I have now got MSI Afterburner working and I can create a fan curve with that.  I see my temperatures on heavy games go to 79 degrees and stay there.  It doesn't matter how hard the fan goes because it doesn't lower temperatures and I have set the fan so it doesn't get to the point of rattling.  I would prefer to use the proper AMD software to do the curve but I will wait to see if drivers fix the issues in the future.

yes I know what you mean. I hate using third party software. I rather wake up and apply my profile every morning manually so that it works. But yes after burner is an option.

0 Likes

I just gave up with Adrenalin in the end and downloaded Argus Monitor to set my own permanent fan curve and RivaTuner to lock my max FPS. 

GPU has never worked better for noise and thermals.

kingfish
Volunteer Moderator

Zero RPM should never be applied in a game profile. It negates your fan/temp settings.

Zero Rpm should be applied in Global settings. (default)

When you are playing a game/app with a manual fan/temp setting that is the profile that is used while playing and as soon as you quit the app/game..it reverts to Global settings.

This can be clearly seen by running hardware Monitor in the background while playing a game Open Hardware Monitor - Core temp, fan speed and voltages in a free software gadget , then check it when you quit. .

https://www.amd.com/en/support/kb/faq/dh2-020 

Zero RPM

Zero RPM enables quiet operation whilst the GPU is under light load and is enabled by default. The GPU fans should spin up as the GPU is put under load and temperature increases. Zero RPM is automatically disabled if any changes are made in the Tuning menu.

To do this....reset (use the icon) the Global settings.

Reset the profile/Wattman settings to default (use the icon)

Reboot your computer

In Global settings, select the options for anti-alias, etc....but do not touch or open Global Wattman. Leave at default.

In your game profile, select the options you want for AA, Enhanced Sync, etc

In Wattman select manual for speed/fans. Disable Zero Rpm. Set the fans / temp as you wish. Increase the Power Limit. Click apply. Don't allow any over/under clocking/volting or any of that other _rap.

Click apply

I always reboot after all is finished.

Just tried it right now and after doing a complete shutdown, waited a minute or two and then came back the rpm's were back at zero. You cant just restart and assume everything is ok. Restart doesnt turn off anything on your system so it remembers what you did. It is when you shutdown that some how the card forgets what ever you did. So you would have to apply your profile every single time and it's annoying as hell lol

0 Likes

No. I have everything on high performance and I manually make sure nothing goes to sleep or hibernates. I don't even let my hdd sleep. I don't like it. You get that option when you have hibernate. So I dont even get the option to turn fast restart or fast start on or off

wait I found where it is. It wasn't where the article you sent me said. I'll let you know if that works after I turn it off.

0 Likes

yeah I think that did it. For me the disable fast startup was on the "choose what the power buttons do" So far I disabled that and it did remember everything after shutting down completely. So I think you might've found the solution. Thank you. Ill let you know if something goes bad again. Tho I highly doubt it. Thank you again.

kingfish
Volunteer Moderator

Glad you have it sorted out!

kingfish
Volunteer Moderator

How to Enable or Disable Fast Startup

Deciding whether to bother with Fast Startup actually takes longer than turning it on or off. First, open up your power options by hitting Windows+X or right-clicking your Start menu and selecting Power Options. In the Power Options window, click “Choose what the power buttons do.”

power options

If this is the first time you’ve messed with these settings, you’ll need click “Change settings that are currently unavailable” to make the Fast Startup option available for configuration.

available options

Scroll to the bottom of the window and you should see “Turn on fast startup (recommended),” along with other shutdown settings. Just use the check box to enable or disable Fast Startup. Save your changes and shut down your system to test it out.

fast startup

If you don’t see the option at all, it means hibernation is not enabled on your machine. In this case, the only shutdown options you’ll see are Sleep and Lock. The quickest way to enable hibernation is to close the power settings window and then hit Windows+X and open Command Prompt (Admin). At the Command Prompt, type the command:

powercfg /hibernate on

After turning hibernate on, run through the steps again and you should see both the Hibernate and Fast Startup options.

Uncheck and reboot.