Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Adept I

Event ID 129 envirtahci Reset to device

Hey there community -

Describe your system:

  • Custom built system
  • Windows 10 Pro (64 bit) (fully updated)
  • GPU: gtx 1080 (latest driver)
  • Drives in storeMI tier: Corsair Force Series MP500 240GB M.2 NVMe PCIe Gen. 3 (fast tier) + Seagate 4TB BarraCuda SATA 6Gb/s 256MB Cache (ST4000DM004) (slow tier)
  • Driver version storeMI: (latest)
  • Asus Strix x470-F Gaming, Bios Revision 4018 (latest)
  • CPU: 2600x
  • Power Supply Corsair TX 750 (750W)
  • RAM: Corsair Vengeance LPX 16GB (8GBx2) (CMK16GX4M2B3000C15), XMP 3000MHz

Describe your issue:

I am running a Store MI tier drive for my data (games) drive with an NVME SSD and HDD.  After several months of having zero issues, my system suddenly started having freezes and apps not responding.  Eventually I tracked it down to occurring when Event 129s started appearing in my Event Viewer every minute while these freezes are occurring. The source is envirtahci, which I tracked down to the AMD Virtualized AHCI Controller for Ryzen 400 series.

I have uninstalled and reinstalled the storemi and I am still getting this error.  I've tried adjusting power options and updating my chipset/bios to the latest.  Still keeps happening.

Update (List of things I've tried so far):

Windows Update-Install (to ensure Windows wasn't the issue)

SeaTools Scans (SMART, Short, Long (bad sector scan), all passed)

Configured Power Settings on the AHCI controller (recommended via the web)

Ran chkdsk (pass)

Ran sfc /scannnow (pass)

Updated to latest chipset drivers

Updated to latest Bios

Uninstalled and reinstalled StoreMI software (didn't break my tier)

Cleaned the registry

Defragmented (wasn't even needed)

Ran Malwarebytes scan. (no issues)

Ran Windows Defender scan. (no issues)

Ran Spybot Search and Destroy scan. (no issues)

Any ideas?


Error details:

Log Name:      System

Source:        envirtahci

Date:          7/12/2018 9:43:50 PM

Event ID:      129

Task Category: None

Level:         Warning

Keywords:      Classic

User:          N/A



Reset to device, \Device\RaidPort2, was issued.

Event Xml:

<Event xmlns="">


    <Provider Name="envirtahci" />

    <EventID Qualifiers="32772">129</EventID>




    <TimeCreated SystemTime="2018-07-13T02:43:50.581857500Z" />




    <Security />







5 Replies
Journeyman III

Unfortunately I have a similar problem but not with StorMI.  I recently purchased a 1TB SSD to raid with an identical drive.  (Mushkin Reactor 1TB) and as soon as I made a new RAID 0 array for my boot drive I began having the system freeze up for 10-45 seconds and in my system Event log I get the following:

The description for Event ID 129 from source rcraid cannot be found. Either the component that raises this event is not installed on your local computer or the installation is corrupted. You can install or repair the component on the local computer.

"If the event originated on another computer, the display information had to be saved with the event.

The following information was included with the event:


SSD issue.PNG

I tried 3 clean installs with different raid cache settings. Different versions of the PreBoot Raid drivers and 3 different Gigabyte BIOS revisions for the x370 Gaming K7 and nothing works.  Tried windows 10 1803 and 1703 thinking maybe it was related to the reported difficulties with intel ssds on 1803.

I contacted the SSD manufacturer yesterday because if this isn't going to work I want to return the drive while I still can.

tesladev​ as for your issue I would suggest you try some of the fixes I was referenced to online as it is likely a similar problem with the chipset controller.  Link Below.

Windows 10 Help Forums

So far I have been unable to fix this issue.  Usually this error may mean that there is a failing drive in your system so to rule out that you may want to try Crystal Disk Info, hddscan, or Hard Disk Sentinel to test your drives.  A failing drive can temporarily delay response to the controller causing what you are seeing as well.

If anyone else has any ideas I'm all ears. If not and the drive manufacturer doesn't have a solution I'll be going back to a single boot disk and just storage drives in RAID.  If anyone from AMD checks the forum maybe you can coordinate with Mushkin to see what is causing this as people have noticed this issue and noted it on as well.


Thanks for posting.

I had already tried the AHCI power management tweak to no avail. 

I've done error checks with no issues.  Regular chkdsk reports no errors. sfc /scannow is clean.  I've tried 3rd party apps...nothing...

I can't get through chkdsk /r /f as eventually I'll get the Event 129s and my system locks up.  The furthest I've made it is ~5%.

I've tried a dozen other things I've found on google, I just have no issues that I can find.

I'll keep digging, but I'm counting down my time to just removing storemi, since it seems to be some issue with the driver that I can't isolate.


Please post your Computer information as per AMD Forums rules: INFORMATION REQUIRED WHEN POSTING A QUESTION

This error seems to occur a lot with RAID type setups. Do you have an AMD or Intel based Desktop PC?

Try running CHKDSK before Windows boots up. You will need to start your computer with a Windows Installation disk so that you will be able to run Command Prompt in a Pre-Windows Environment.

Here is how to do it:

Follow these steps:

  1. Insert the original Windows disc.
  2. Restart your PC and boot from the disc.
  3. Click Repair your computer.
  4. Choose the operating system from the list.
  5. Click Next.
  6. Choose Command Prompt.
  7. When it opens, type the command: chkdsk /f /r.
  8. Press Enter.

This link found a solution that may solve your problem even though it doesn't concern the driver mentioned: Reset to device, \Device\RaidPort0, was issued. Event id: 129 storahci - Page 2 - Dell Community


RE: Reset to device, \Device\RaidPort0, was issued. Event id: 129 storahci

I had exact the same problem on quite a lot of my dell systems. Here is how i solved the issue:

First of all we need to change "AHCI Link Power Management" which is a hidden setting on power management. Open up registry editor and change the following settings.


Change attributes from 1 to 2


And again change Attributes from 1 to 2.

Now go to Control Panel -> System and Security -> Power Options click on "Change Plan Settings" and then click on "Change advanced Power settings".

Now under "Hard disk" you should have AHCI Link Power Management - HIPM/DIPM and AHCI Link Power Management - Adaptive options.
Change "AHCI Link power management" To active, which means there is no power management for AHCI and finally change Adaptive to 0 milliseconds (Although if you enabled "active" this option has no effect).

Finally under "PCI Express" Change "Link State Power management" to OFF.

I hope this will help you.

Good luck!

EDIT: Just followed the above instructions and now I have several Power Options instead of one in Control Panel under Power Options. So, at least, for me the Registry Change does uncover more Power Options than was viewed before. Now you can try other Power Options and see if it fixes your problem as stated in above comment from link.

This is a image of my Power Options with the new Options uncovered:


Thanks for the reply.

I have tried these solutions already with no luck.

I'm not running a RAID setup.  It is a storeMI setup, which is what the AHCI driver is installed with and the specific driver that is crashing.  The event description is a bit off, I'm not sure if that's just a default description for virtualized volumes...

When booting into repair to run cmd, the storeMI volume is not listed as a volume with either diskpart or chkdsk.  I'll give it a second (third?) try (creating bootable USB again right now).  This issue is also why I used seatools to test my drives independently.  No bad sectors have been found.  Every disk test utility I could find returns with no problems with my volumes or disks used in the storeMI volume.

Sure - I'll update my OP to include computer setup.

I have also opened a ticket with AMD - next step is to remove storeMI and go back to a regular non-accelerated setup.


Good idea, Forgot to mention that in my previous Post about opening an AMD EMAIL SUPPORT ticket. You can do that from here: Email Form . With Email Support you will get a reply back from AMD Support. The other type AMD REPORT ISSUE ticket just lets AMD Support know there is a problem they need to check on but you will not get a reply back.

Have you by any chance read the STOREMI User guide : .

I suggest reading page 27 of the Guide. Seems like it has some settings that need to be set for STOREMI to work correctly. One includes VirtualSSD or VirtualHDD settings that may involve the driver that is giving you issues:

Change Settings Use the change settings option in the StoreMI utility to change the following modes:

• RAM cache on/off

• VirtualSSD or VirtualHDD setting

• Manually convert the StoreMI tiered drive from single to tiered or vice versa


These PDF articles may direct you on a possible solution. It might be something you are doing incorrectly. That is if you already haven't read them yet.

I realized you are not running a RAID Setup. But googling the Event ID 129 error, seems like most involves RAID Setups. STOREMI is like an updated RAID system.

According to Asus Support this is the only Corsair Nvme/ssd that is compatible with your Motherboard: :


anyways, Good luck, Hopefully AMD Support will direct you to a solution if known is found in this Forum by other Users.