cancel
Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

podkop
Journeyman III

error in legacy driver?

Jump to solution

I have notebook ASUS K53TK with win10 x64 with 2 ati graphics

7670m     PCI\VEN_1002&DEV_6840&SUBSYS_21221043

6480g      PCI\VEN_1002&DEV_9649&SUBSYS_21221043

i download last driver: "non-whql-64bit-nieg-radeon-crimson-16.2.1-win10-win8.1-win7-feb27.exe"

from http://support.amd.com/en-us/download/desktop/legacy?product=legacy3&os=Windows+10+-+64

Applicable Products:

  • ​AMD Radeon™ R5 235X, Radeon™ R5 235, Radeon R5™ 230, Radeon™​ R5 220 Series Graphics
  • AMD Radeon™ HD 8470, Radeon™ HD 8350, Radeon™​ HD 8000 (D/G variants) Series Graphics​
  • AMD Radeon™ HD 7000 – HD 7600 (including A/D/G/M variants) Series Graphics
  • AMD Radeon™ HD 6000 (including A/D/G/M variants) Series Graphics
  • AMD Radeon™ HD 5000 (including M variant) Series Graphics

Applicable Operating Systems:

  • Windows® 10 (32 & 64-bit versions)
  • Windows® 8.1 (32 & 64-bit versions)
  • Windows® 7 (32 & 64-bit versions)

but when i try to install this it don't want to update graphic driver

in inf file of this driver for win8.1 cu299900.inf have:

"%AMD6840.1%" = ati2mtag_R476, PCI\VEN_1002&DEV_6840

AMD6840.1 = "AMD Radeon HD 7600M Series"

and

"%AMD9649.1%" = ati2mtag_Sumo_Mobile, PCI\VEN_1002&DEV_9649

AMD9649.1 = "AMD Radeon(TM) HD 6480G"

but don't have DEV_9649 in C0299900.inf for win10

and "AMD Radeon HD 7670M" have other DEV_ that my:

"%AMD6843.3%" = ati2mtag_VancouverA, PCI\VEN_1002&DEV_6843

AMD6843.3 = "AMD Radeon HD 7670M"

can you fix it: add  in C0299900.inf

DEV_9649 for 6480g

and if not difficult

DEV_6840&SUBSYS_21221043 for my 7670m?

thank you very much in advance

0 Likes
1 Solution

Accepted Solutions
kingfish
MVP

Re: error in legacy driver?

Jump to solution

No....your laptop has the AMD A6-3420M processor.

The following AMD APU products with AMD Radeon™ Graphics support up to WDDM 1.2 and DirectX® 11 on Windows 10:

  • AMD A4/A6/A8-3000 Series APUs
  • AMD E2-2000 APU
  • AMD E1/E2-1000 Series APUs
  • AMD E-200/300/400 Series APUs
  • AMD C-Series APUs
  • AMD Z-Series APUs

NOTE: These APU products must be installed only using the display driver version available via Windows Update. If you have upgraded to Windows® 10, please DO NOT install the AMD Catalyst™ Driver. Instead, enable Windows Update and allow it to detect and install the appropriate driver. If you have already upgraded to Windows® 10 and installed the AMD Catalyst™ Driver, please follow the steps listed below to resolve this issu

  1. Uninstall the AMD Catalyst™ Driver using the Program and Features option in the Control Pane
  2. Reboot the system
  3. Use Windows Update to install the appropriate graphics driver for the APU.

You must use the drivers Windows Update furnishes...not drivers from AMD.

View solution in original post

1 Reply
kingfish
MVP

Re: error in legacy driver?

Jump to solution

No....your laptop has the AMD A6-3420M processor.

The following AMD APU products with AMD Radeon™ Graphics support up to WDDM 1.2 and DirectX® 11 on Windows 10:

  • AMD A4/A6/A8-3000 Series APUs
  • AMD E2-2000 APU
  • AMD E1/E2-1000 Series APUs
  • AMD E-200/300/400 Series APUs
  • AMD C-Series APUs
  • AMD Z-Series APUs

NOTE: These APU products must be installed only using the display driver version available via Windows Update. If you have upgraded to Windows® 10, please DO NOT install the AMD Catalyst™ Driver. Instead, enable Windows Update and allow it to detect and install the appropriate driver. If you have already upgraded to Windows® 10 and installed the AMD Catalyst™ Driver, please follow the steps listed below to resolve this issu

  1. Uninstall the AMD Catalyst™ Driver using the Program and Features option in the Control Pane
  2. Reboot the system
  3. Use Windows Update to install the appropriate graphics driver for the APU.

You must use the drivers Windows Update furnishes...not drivers from AMD.

View solution in original post