Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Journeyman III

Enhanced Sync not working (again) in 22.3.1 on RX570

Well well i thought we left all this behind us, with the fix that came around 1 (or was it 1,5 ?) year ago, but here we are again.

Enhanced sync (not freesync) doesnt... 


Bad bad tearing & blittering especially when the metrics overlay is active. Shame as this driver seems otherwise very well optimised and nice.

Anybody else ?

5 Replies
Journeyman III

Same issue here. Started noticing the issue in VALORANT when there was heavy screen tearing, disabling & enabling enhanced sync in the driver didn't fix it. My screen was also (kinda obviously) not changing the refresh-rate (It usually shows the current refresh-rate on the OSD, but atm it's just stuck at 144Hz).

I'm running a Ryzen 7 2700x, AMD Radeon RX 5700 XT 50th Anniversary Edition, 32 GB 3200 MHz RAM (Running at 2933 MHz)

Community Manager

Thanks for the post. Please try downloading 22.3.2 and prior to installation, perform a factory reset. Check the issue status and let me know if it continues.

Hey, I've already updated to the version 22.3.2 before you replied. I didn't perform a factory reset and the issue only partly seems to be fixed. Sometimes I end up having enhanced Sync working and sometimes it just doesn't work. Which basically means, sometimes (even tho well beyond 100FPS) I get screen tearing (below/above 144FPS)/the screens refresh rate doesn't adjust (when below 144FPS).
As I stated, this randomly seems to happen, but it's really not uncommon. Sometimes it also just straight up works and the screens refresh rate adjusts


similar here, for some reasons it just feels like it doesnt works, im using the metrics overlay and for some reasons freesync doesn't seems to uncap my fps, im basing my statement from fallout 4, it seems to not want to uncap from 60, though i remember it working before, and i get massive screen tearing in red dead redemption 2... current radeon version, 22.11.2... is there a way to fix this?


Well, best configuration you can have is the default one I think.

You try to enable thing that AMD not make it default as enable means better let it off.


I try it to on every game I play (want to optimize by enable features that AMD offer to us) and has issue like yours.

So, default is the best.

MSI B550 Pro-VDH - MSI 6600XT - Ryzen 5600G